1. Are you ready for the Galaxy S20? Here is everything we know so far!

Having problems with my milestone... :(

Discussion in 'Android Devices' started by katiekilledkenny, May 26, 2010.

  1. katiekilledkenny

    Thread Starter

    I upgraded to a milestone a couple of months ago after lusting after one for a very long time. Worked like a dream for ages, but recently has got very slow and unresponsive with things such as when you enter a name in the 'to' field when wanting to send a text message. I tried clearing out my texts, deleting apps, had no effect. I also use TasKiller to see what's running to free up battery. I updated the software. I did a Battery Pull just now and my phone is taking a stupidly long time to switch on. I know milestones normally take an age to load, but it's normally like 1-2minutes, and it's been loading for almost 15 minutes.

    Please help :( I'm with Vodafone but upgraded through Carphone Warehouse.
     


  2. UnModified

    UnModified Newbie

    Are you opposed to a factory reset? If not I would give that a try if you have not done so already.
     

Motorola Milestone Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...