1. Are you ready for the Galaxy S20? Here is everything we know so far!

HBOOT?!?!

Discussion in 'Android Devices' started by g60madman, Dec 29, 2012.

  1. g60madman

    g60madman Guest
    Thread Starter

    Since I am still a n00b with the Evo in terms of hboot knowledge, what versions of the hboot are out there? And what in the world is the difference?!?!

    I am currently on 1.04.2000 I can install my CM10, my CM9 Alpha (haven't released it yet), and also Harmonia. I just tried to install Mobstergunz HD lite and it crashed all over the place. I also have read that to use the Viper ROM you need to use hboot 1.58 and or 1.57. So can some one give me a crash course on the hboot, or direct me to a link pretty please :D
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mysticalnyte

    mysticalnyte Well-Known Member

  3. Brian706

    Brian706 I like turtles!
    Moderator

  4. BackHandLegend

    BackHandLegend Android Enthusiast

    I run any ROM with 1.04

    Viper ROM works flawlessly, and so does mobstergunz HD ROM.
     
  5. xploPR

    xploPR Android Expert

    +1

    Im currently running Mazda's version of aokp cm10. With 1.04 and no issues.
     
  6. Prinny

    Prinny Resident Linux Nutcase

    Hai g60, plz2b responding to ur thredz.

    See full post here:

    http://forum.xda-developers.com/showthread.php?t=1817513

    Edit: mysticalnyte beat me to it. Maybe I should read responses before posting. >.>
     
  7. SuperAfnan

    SuperAfnan Android Expert

    I just use the ENG hboot everything works fine and smooth on it....


    What's the point of switching to another then?
     
  8. ramjet73

    ramjet73 Android Expert

    It used to be that the 1.57.xxxx or 1.58.xxxx hboot was needed to run the Viper3D ROM, but as of r310 it will work with any hboot. AFAIK, the only ROM's that require one of the ICS hboots at this point are the stock ROM and Cool ICS.

    There are some issues using TWRP with hboots other than the ICS version documented in the http://androidforums.com/evo-v-4g-all-things-root/663486-twrp-2-3-htc-evo-3d.html thread. I'm not sure if the error with other hboots will cause any significant problems or not but if you are using TWRP and only flashing Sense based ICS ROM's it might be best to use the 1.57 stock or JBear 1.57.5757 hboot.

    ramjet73
     
  9. joe_blow

    joe_blow Member

    Problem: When I try and install g60madman's CM10 builds it boot loops. I am running JBear 1.57.5757 hboot. It will boot loop even after I restore a working backup and even if I install stock hboot etc. The only way to get out of the boot loop that I have found is to restore the phone to stock and then restore the working backup.

    1) Could the CM10 build be made to work with an hboot of 1.57.xx or latter?
    2) What is the way to get out of the "boot loop" that does not require a full 5 steps back to stock?

    I am running Midnight ROM now but would like the ability to work on g60madman's CM10 builds. Is there a way to go between the two?
     
  10. Prinny

    Prinny Resident Linux Nutcase

    Try the 1.04 eng hboot. See if it.works for both.
     
  11. ramjet73

    ramjet73 Android Expert

    The engineering (ENG) hboot should work for both, but causes errors in the TWRP 2.3.3.0 recovery that joe_blow is using.

    I just tested the JBear GB (1.50.5050) hboot with TWRP 2.3.3.0 and that seems to work fine, and it boots mazda's AOKP 3.5.2. It also boots the ICS Sense based ROM's fine, so you might want to give that hboot version a try.

    ramjet73
     
  12. thebryceee

    thebryceee Android Expert

    I've ran Viper on 1.04. I used to run everything on that.
     
  13. g60madman

    g60madman Guest
    Thread Starter

    1.04 works on my cm10 still working on revamping it. Been also working on cm9
     
    Anonymo and SuperAfnan like this.
  14. treysmith

    treysmith Member

    Never have any problem with HBoot 1.04 for EVO V 3D 4G.
    I was running HBoot 1.57 S-Off with JBear.
    Now I'm running HBoot 1.04, because of CM/AOSP/AOKP
    Mobstergunz, HD Lite and Unlocked Potential Rom works flawlessly on HBoot 1.04.

    I appreciate devs hard work.
    Thanks, guys for y'all hard work.
     
  15. ramjet73

    ramjet73 Android Expert

    Most AOSP based ROM's (CM9, CM10, AOKP, PA) flash and boot fine with any hboot lower than 1.57. However, TWRP2 touch recovery doesn't seem to like the partition configuration of the ENG 1.04 bootloader so I recommend JBear GB (1.50.5050) over 1.04 if you are a TWRP2 user.

    ramjet73
     
  16. joe_blow

    joe_blow Member

  17. ramjet73

    ramjet73 Android Expert

    I'm surprised the Sense based ROM's for the Evo V don't flash and boot with the JBear 1.50.5050 hboot since I know every ROM does on the Evo 3D at this point except Cool ICS and the stock Sprint ICS ROM. In fact, I currently have the JBear 1.50.5050 hboot installed while I'm trying to become more familiar with TWRP 2.3.3.0. ;)

    Other than asking the Evo V developers about the hboot requirement for their ROM's, I don't know what to tell you since there is no single hboot that will run all ROM's on the Evo 3D/V. Viper3D used to have a requirement for the 1.57/1.58 hboot, but now it runs with any bootloader. Maybe virus would be willing to share what he did to remove that restriction with the ROM developers for the Evo V.

    Edit: What Evo V Sense ROM are you trying to run? I can flash it on my Evo 3D with JBear 1.50.5050 and 4EXT Recovery to see if I can get it to boot.

    ramjet73
     
  18. treysmith

    treysmith Member

    Actually I have no problem using H.Boot 1.04 it works prefectly for any Rom and CM/AOSP/AOKP Roms.
    I'm currently running H.Boot 1.04 CyanogenMod10 Android version 4.1.2 ParanoidAndAndroid and it work perfectly.
     
  19. ramjet73

    ramjet73 Android Expert

    Can you flash and boot all the Sense based ICS ROM's for the Evo V that are available on this forum with that bootloader? If so, that might be an advantage of engineering (ENG) 1.04 hboot, at least for 4EXT Recovery users. I've never had problems with most of the ICS Sense ROM's for the Evo 3D, so until I try the ROM's specific to the Evo V flashed with 4EXT and the JBear 1.50.5050 hboot I'm not ready to say that the ENG hboot is any more "universal" for the Evo V than other hboots at 1.50 or below, including the 1.4 version that seems to be popular with Evo 3D users. And it's been proven already that the 1.50.XXXX hboots are more compatible with TWRP2 (touch) than the ENG bootloader.

    The ENG 1.04 hboot works fine on most ROM's but doesn't boot anything based on the Sprint 2.89.651.2 kernel. Currently that includes the Cool ICS and Sprint ICS stock ROM's and versions of Viper3D at r284 or lower, which require hboot 1.57 or higher. Most Evo 3D ROM dev's have downgraded the kernel and/or other components of their Sense ICS ROM's to make them compatible with older hboots like ENG, but it's not clear what will be required for the JB 4.1.1 Sense 4+ ROM's to boot once they are available on the Evo 3D/V since there are none working yet.

    Edit: It seems the Evo V ROM that joe_blow is having problems with using the 1.50.5050 hboot is one the Midnight ROM's. Can you flash and boot those with the ENG 1.04 hboot? I noticed that the OP's for those ROM's have links to the 1.57 hboot.

    ramjet73
     
  20. nsciucco

    nsciucco Android Expert

    1.04 eng H boot. Works for me. Never had a problem. I use 4EXT. It seems to be a better recovery
     
  21. ramjet73

    ramjet73 Android Expert

    It works on most ROM's with 4EXT, but not all.

    Have you used either of the Midnight ROM's for the Evo V with the ENG 1.04 hboot?

    ramjet73
     
  22. nsciucco

    nsciucco Android Expert

    yes. I have tried every ROM for this phone. Now I just use my Rom MOBSTER/UNSENSEABLE
     
  23. ramjet73

    ramjet73 Android Expert

    Then I wonder why both of the Midnight ROM's link the 1.57 hboot on their OP's and say to download and install it if you can't boot. :thinking:

    I'll try flashing the standard version of Midnight with hboot 1.50.5050 and TWRP2 and if that doesn't boot, as joe_blow reported, I'll try it with 4EXT. If both of those fail, I'll try it with the ENG hboot.

    ramjet73
     
  24. ramjet73

    ramjet73 Android Expert

    What was the last version of Midnight ROM that you installed?

    I just tried flashing the current (1.4.2) version of Midnight ROM with hboot 1.50.5050 and 4EXT and it hung on the boot animation for a while, then rebooted and hung again at the same point. I switched to the ENG 1.04 hboot and got exactly the same result. I even re-flashed it with 1.04 just to make sure everything was done correctly.

    Next I flashed it again with hboot 1.58.5858 installed, which is the Sprint equivalent of 1.57.5757, and it booted fine so it appears the current version of Midnight ROM is like the Evo 3D ROM's I mentioned previously that require the current version of the bootloader. I'd be very surprised if you could flash and boot the 1.4.2 version of Midnight ROM with the ENG 1.04 hboot.

    So I still believe that the JBear GB 1.50.5050 hboot (and probably others that are lower numbered than 1.57) is just as "universal" as the ENG 1.04 hboot and doesn't cause errors with TWRP 2.3.3.0, so I recommend it as the preferred hboot when using the TWRP2 touch recovery.

    I'm not sure why Midnight ROM 1.4.2 seems to require the current hboot but maybe the XDA thread I linked in post #19 of this thread could help the developer make it compatible with other hboots.

    ramjet73
     
  25. nsciucco

    nsciucco Android Expert

    wow. thats a lot of testing. lol. Good Work!!! -- It was a much older version of Midnight. Probably last september
     
    ramjet73 likes this.

Share This Page

Loading...