1. Check out our companion app, Forums for Android! Download from Google Play

Support Headset buttons don't work?

Discussion in 'Android Devices' started by jcmtyler, Jan 12, 2010.

  1. jcmtyler

    jcmtyler Well-Known Member
    Thread Starter
    58

    Dec 7, 2009
    125
    12
    58
    Male
    Software Development Manager
    Houston, Texas, USA
    I just tried out the included headset today and couldn't get any of the buttons (prev/pause/next) to work. I tried this with the default Music player, Meridian, and Mixzing, all with the appropriate settings to enable headset buttons. I also made sure the headphone was plugged in securely.

    Any thoughts? Anybody else notice this?
     

    Advertisement

  2. jodaboda

    jodaboda Well-Known Member
    16

    Jan 8, 2010
    92
    2
    16
    add a music widget to the desktop, then try. Worked for some of us... don't know why...
     
  3. jcmtyler

    jcmtyler Well-Known Member
    Thread Starter
    58

    Dec 7, 2009
    125
    12
    58
    Male
    Software Development Manager
    Houston, Texas, USA
    I tried with the Meridian and Mixzing widgets, but no joy...
     
  4. jodaboda

    jodaboda Well-Known Member
    16

    Jan 8, 2010
    92
    2
    16
    It wouldn't surprise me if the remote only worked with the default music player and its widget.
     
  5. jodaboda

    jodaboda Well-Known Member
    16

    Jan 8, 2010
    92
    2
    16
    I just checked, and (on mine, at least), the remote ONLY controls the default music player, and only if I have the widget (so I guess you could say the remote only controls the widget).

    AND it will function regardless of whether or not something else is playing. I was playing music with Mecanto, then pressed the headphone play button, and the built-in music player started playing ON TOP OF Mecanto's music. Interesting...
     
  6. jcmtyler

    jcmtyler Well-Known Member
    Thread Starter
    58

    Dec 7, 2009
    125
    12
    58
    Male
    Software Development Manager
    Houston, Texas, USA
    So I played around with this a bit more and now I can get the headset to control the main player and widget for the default music player, Meridian, or Mixzing. I had to selectively disable headset support for the 3rd party apps, for example to get the headset to work with the default music player/widget I had to disable headset support for Meridian and Mixzing, etc...

    Bizarre, but anyway it seems to work correctly so probably I just had too many apps competing for the headset events.
     
  7. jodaboda

    jodaboda Well-Known Member
    16

    Jan 8, 2010
    92
    2
    16
    That's great! Where are the settings for the headset? How did you disable it for 3rd party apps???
     
  8. jcmtyler

    jcmtyler Well-Known Member
    Thread Starter
    58

    Dec 7, 2009
    125
    12
    58
    Male
    Software Development Manager
    Houston, Texas, USA
    In Mixzing settings, there is a checkbox to "Enable headset controls", and in Meridian's preferences it's called "Headset buttons".
     
  9. CharlieSpear

    CharlieSpear New Member
    5

    Aug 18, 2010
    1
    0
    5
    I wrestled with bluetooth headset button issues for weeks and finally fixed them by uninstalling Stitcher. Motorola Droid running Android 2.2; headset = Acoustic Research ARWH1 "bridge"
     
  10. cujoe

    cujoe New Member
    5

    Aug 3, 2010
    2
    0
    5
    The Problem i'm having is one day the headset controls not working at all. I dont get it. I used to be able to hold down one of the buttons on my headset and it would trigger voice calling. During music it would be able to pause and play. .. now nothing. I wonder if its a hardware issue in some of theses cases. I wish there was a main preference menu for these controls on the phone.
     
  11. LK1974

    LK1974 Member
    5

    Dec 17, 2010
    6
    0
    5
    Sydney, NSW, Oz
    Having same problem on Nexus One - Android 2.2

    Using Mixzing (Pro) - worked fine before on Hero with Android 1.6

    Now only if I have manually started a and the display is on (!?) will Mixzing have priority for headset controls. I actually preferred the media player in 1.6.

    I've seen the same issue on other media players like Lithium although apparently Meridian has a solution / setting to sort this.

    @jcmtyler - try with other headphones. Had same issue with helmet headphones & mic I bought. Also, fix didn't work for me.

    (It looks like this is the main reason behind this post)

    If stock media player had Genres I wouldn't even have bothered with Mixzing.

    C'mon Google, give us some options. It's why we (usually) like you!
     
  12. LK1974

    LK1974 Member
    5

    Dec 17, 2010
    6
    0
    5
    Sydney, NSW, Oz
    I just downloaded Meridian player (free version ) - issue no longer there!

    It even has a double click to skip feature which is nice.
     
Tags:

Share This Page

Loading...