1. Are you ready for the Galaxy S20? Here is everything we know so far!

Helium (Backup Solution for non-root users)

Discussion in 'Android Apps & Games' started by jmar, Dec 5, 2013.

  1. jmar

    jmar Nexican
    Thread Starter

    Let's discuss how this application is used, etc, to help AF users get the most out of it!
     

    Advertisement

  2. Petrah

    Petrah Psychotic Female

    If someone would write up a very detailed tutorial with screenshots, I'm sure it could be added to the F.A.Q. as a sticky. ;)
     
    jmar likes this.
  3. HighSierra

    HighSierra Member

    Helium (free) doesn't back up to PC. It goes to internal (phone) storage. you have to move the backup to your PC. This isn't very useful.

    Please review all the comments on the linked page (previous post)
     
  4. Deleted User

    Deleted User Guest

    The free version should have a PC Download option. It lets you download your data via a web browser on your PC.
     
    HighSierra and WoohooGuy like this.
  5. WoohooGuy

    WoohooGuy Android Enthusiast

    +1

    Your device and computer should be on the same wifi network.

    On your device in Helium-

    Click menu/ PC Download. Your device will now display "Helium server is running" and show you the IP address of your phone with a port.

    On your computer -

    Open any web browser, in the URL bar enter the complete IP address being displayed on your phone.

    You will be presented with Helium's web interface where you may select what apps you want to backup and the toggle "data only option".

    Your browser will then start to download a zip file of your backup, if you opt to save the full apps + data the download can take some time.

    In order to restore your zip file just run the Helium web server on your device, Launch your browser and select your zip file, or drag and drop it into the box and go from there.
     
    HighSierra likes this.
  6. HighSierra

    HighSierra Member

    Thanks for the clear instructions. That works fine. I was thinking that it would communicate between the phone app and the PC app to do the backup via the USB connection.

    BTW what is the purpose of the PC app?
     
  7. WoohooGuy

    WoohooGuy Android Enthusiast

    The only thing the desktop application does is send a series of ADB commands to your device that enables the helium app to access and save your app data.

    If you have a rooted device you do not need the desktop app as Helium can configure your device via superuser access.

    Once you are done with with the desktop app you can uninstall it if you so desire.
     
  8. UncleMike

    UncleMike Android Expert

    Until you restart your device - then you need to run the desktop app again. I wouldn't recommend uninstalling it.
     
  9. kurbie

    kurbie Lurker

    Hi

    I have a GPS problem and Google wants me do a factory reset, so I am trying to use Helium Free (for now)for backup/recovery and am having US connection problem

    I installed Helium on my MAC (10.7.5) and Nexus 7 2013 (Kit Kat 4.4.2).
    Both apps are running.
    Devices connected via USB
    USB debugging enabled in Developer options
    However neither the Nexus nor the MAC recognizes the USB port
    There is no notification for USB on the Nexus
    I found USB setting under Storage in Settings (weird place to find this)
    Set mode to PTP
    No dice.

    Mac Helium says: PLease connect your Android to USB
    Nexus Helium says: Waiting for Helium Desktop application to…
    Not talking to each other.

    What to do ?

    Thanks
    Changed USB port – no luck
    Changed USB cable – no luck

    Appreciate any suggestions
     
  10. UncleMike

    UncleMike Android Expert

    My desktop is running Ubuntu, which requires no drivers for Android devices. Add I understand it, it's the same for Mac. You might want to try switching from PTP to MTP - that's how mine is set and it's working fine.
     
    kurbie likes this.
  11. kurbie

    kurbie Lurker

    Thanks

    Tanks. Tried it. same problem.

    If the MAC does not need drivers, then I am assuming that the problem might on the NEXUS. When I enable USB debugging I do not get the response " The computer's RSA fingerprints is xxxx..." prompt. I think that I should be getting that.
     
  12. kurbie

    kurbie Lurker

    Actually

    I tried to use Android File Transfer app from my MAC. The Android device is not detected. MPT or PTP, does not matter
     
  13. x000x

    x000x Guest

    i like helium but the paid version isn't on the amazon app store :(
    i'm probably in the minority but i prefer to buy my apps through amazon if at all possible.
     
  14. funkylogik

    funkylogik share the love peeps ;)

    Any reason for that? Is Play not available in your region?
     
  15. x000x

    x000x Guest

    it is, but i dont like my apps tied to a specific google account. like if i ever want to switch to a new, different account and delete my old account, i'd have to re-buy all the apps. plus the app management on google play isnt all that great in my opinion. at least on amazon i can basically permanently delete an app from my list if i want, or permanently delete devices. just personal preference really.
     
    UncleMike and funkylogik like this.
  16. UncleMike

    UncleMike Android Expert

    I've always been anti-Amazon App Store, admittedly for no real reason other than there was always a Google Play store (or Market) and I saw no need for another app source. But you make a good point - having app purchases tied to a specific Google account can be a bad thing. In my case, my Google account is in my own domain, so when I retire (if ever), I'll need to keep my domain alive with a paid host, or repurchase all my apps under a new account. I never really thought about the Amazon App Store as a solution to this problem until now.
     
  17. x000x

    x000x Guest

    i really wish helium would be on the amazon app store so i could buy it :(
    i refuse to buy anything from google play if i can help it.
     
  18. Rxpert83

    Rxpert83 Dr. Feelgood

    Contact the Dev, they'll usually work with you

    Especially one like Koush
     
  19. x000x

    x000x Guest

    I thought about doing that via g+ or something, but then didnt want it to seem like I was pestering him. I tried asking via a support ticket(I think) on the clockworkmod/helium website, maybe 6 months ago and I didn't get a favorable reply about the possibility.
     
  20. TadeoNYC

    TadeoNYC Well-Known Member

    The newest version won't backup my S3, I never had a problem in the past. Anyone know where to find the previous verson. Play reviews indicate it is a widespread issue.
     
Loading...
Similar Threads - Helium Backup Solution
  1. spman
    Replies:
    0
    Views:
    201
  2. SexyLexxi
    Replies:
    1
    Views:
    86
  3. slippyjim
    Replies:
    6
    Views:
    541
  4. Mark_M
    Replies:
    0
    Views:
    175
  5. glasshalffull
    Replies:
    16
    Views:
    582
  6. JamesJoey
    Replies:
    0
    Views:
    255
  7. Android News
    Replies:
    0
    Views:
    293
  8. Android News
    Replies:
    0
    Views:
    49
  9. Sherif Ali
    Replies:
    4
    Views:
    476
  10. sheree1993
    Replies:
    1
    Views:
    249

Share This Page

Loading...