1. Download our Official Android App: Forums for Android!

Root [Help] 2 Irritating Issues...

Discussion in 'Android Devices' started by wanfaltm, Jan 4, 2012.

  1. wanfaltm

    wanfaltm Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    50
    8
    16
    1. A couple of weeks ago I had noticed that my WIFI on my phone has been acting kind of funny. Always seeming to go into deep sleep no matter what wifi sleep policy I seem to be under. I've tried many different Roms/Kernels (it seems to be effecting my stock back-up as well.) Aside from downloading that Wifi Wakelock app, which sucks down battery like no other, my phone always goes into deep sleep mode right after I lock it.

    2. This one seemed to happen right around the same time I noticed the wifi issue. My haptic feedback has also mysteriously vanished. I know that many people don't like using haptic feeback but for me it's almost a necessity. I've also tried many different Roms/Kernels for this issue as well. I have messed with it in the regular settings, CM7 settings, spare parts, even in the keyboard settings. It wont work on the keyboard OR my soft keys.

    I'm not sure if Ive messed a whole bunch of stuff up unknowingly, that would suck. I just want to know if I'm the only one having these issues or if there are others who have noticed this inconvenience as well.
     

    Advertisement

  2. ziggy46

    ziggy46 Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,688
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    1,688
    612
    213
    Being a pain in the a$$! LOL
    Chambersburg, Pa
    hmmm... what rom are you on? if your on cm7 or miui, try reflashing the rom or updating to the newest one
     
    wanfaltm likes this.
  3. wanfaltm

    wanfaltm Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    50
    8
    16
    I'm currently on the TG Reloaded rom with Whyzors newest kernel. Tried messing with the haptic feedback in the CM settings again to see if they would work. Still no luck :/
     
  4. Whyzor

    Whyzor Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,108
    Joined:
    Jul 7, 2011

    Jul 7, 2011
    1,108
    966
    213
    The haptic motors could've gone bad (rare but possible, especially considering MT's quality issues). Does it EVER vibrate? like when turning the phone on or off? or when trying to boot into recovery mode, it should vibrate on power up too, that should let you know whether the hardware is still working.

    Otherwise, a fresh wipe & reflash is what I'd recommend, also TITANIUM restores can cause weird problems, so I would suggest just reinstall apps manually.
     
    wanfaltm likes this.
  5. wanfaltm

    wanfaltm Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    50
    8
    16
    Oh i never use Titanium, i just always like to start fresh. I just restarted the phone and you guessed it. No vibration, I should have thought of that from the beginning. Well at least I know that's a hardware problem now instead of me screwing something up.

    Any idea on the wifi issue im having Whyzor? Like I said I've tried fixing that with new roms/kernels/backups and it's acting the same no matter what I do. Could that be faulty hardware too?

    Thanks for your help so far guys! Hitting that thanks button for sure!
     
  6. Whyzor

    Whyzor Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,108
    Joined:
    Jul 7, 2011

    Jul 7, 2011
    1,108
    966
    213
    Try a different wifi router, go to a friends place or starbucks, it could be a router setting. CM7 ROMs have hacks in them to keep wifi ON when screen is off, even if that's not what's wanted.
     
  7. wanfaltm

    wanfaltm Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Jul 26, 2011

    Jul 26, 2011
    50
    8
    16
    Mine's doing the exact opposite, it's turning off when the screen turns off no matter what wifi sleep policy it's under. I don't think it's the router, I've had it since before I got the triumph and have only recently having problems, like within the past 2 weeks.

    Edit: Sometimes it turns off right away, and sometimes it takes anywhere from 2-5 minutes to turn off.
     
  8. shmackshmack

    Rank:
    None
    Points:
    68
    Posts:
    432
    Joined:
    Dec 9, 2011

    Dec 9, 2011
    432
    111
    68
    Los Angeles
    for me, I need haptic feedback on the keyboard or I cant type. might be a mental thing, but when its off im horrible at typing. either way, the stock keyboard doesnt do it so I use WP7 keyboard app, and once in awhile the vibration will totally stop for minutes at a time, its not lag becuase the keyboard works perfectly, but it happens either way, then starts up again like nothing was wrong.

    also haptic feedback sometimes stops working and starts again. I have never found a fix for this even with new kernels and roms.

    as for the wifi, sometimes I like stuff to download in the background when the screens off but it turns off too, like yours, no setting I change fixes that. its weird but I have a toggle to turn auto screen shut-off, off, so it can download uninterrupted.
     

Share This Page

Loading...