1. Are you ready for the Galaxy S20? Here is everything we know so far!

HELP! Accidentally Wiped Internal Storage and OS on HTC ONE M8

Discussion in 'Android Devices' started by jschohan, Mar 4, 2015.

  1. Stevi555

    Stevi555 Lurker

    Drop
    Ive just signed up after reading this thread. Earlymon, one clever and patient person and if I ever get stuck I know where to go.
     


    EarlyMon likes this.
  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Welcome to the forums!
     
  3. Podivin

    Podivin Android Expert

    EM, you're always impressive to watch work.

    :)
     
    EarlyMon likes this.
  4. Guggy

    Guggy Android Enthusiast

    (EarlyMon for HTC Admin)
     
    Podivin and EarlyMon like this.
  5. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Lol, I appreciate the endorsement. :D
     
  6. Chillydog

    Chillydog Lurker

    Wow, I to had to sign up after reading this thread, glad to see there is still good people in this world.

    Way to be Earlymon. I will also spread the word about your page.
     
    EarlyMon likes this.
  7. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Thanks. :)

    Welcome to the forums!
     
    #107 EarlyMon, Mar 14, 2015
    Last edited: Mar 14, 2015
  8. arunasd

    arunasd Lurker

    EarlyMon thanks a lot for these detailed instructions.
    I had same problem as the OP, I wiped Internal SDcard memory on my HTC One M7 (I had a working ARHD rom, but was about to sell my phone and wanted to clear all the downloads, pictures and other stuff that remains even after performing a factory reset in recovery), and after wiping it I keep getting "Unforunately, System UI has stopped" message when the phone loads, I get black wallpaper, no status bar and not functioning home button. Also, it seems that there is no more internal SD card memory. I just sideloaded a new version of ARHD and performed a clean install, but exactly the same issues persist even with a fresh install. I am out of ideas what to do next.

    Could you help me to fix it?
     
  9. Granite1

    Granite1 Zercron Encrusted Tweezer

    So just to be 100%, you have the M7 correct?

    Better to ask twice, fix once right. :)
     
  10. arunasd

    arunasd Lurker

    Granite1 yes, I have HTC One M7 AT&T with S-OFF.

    I tried few more things yesterday:
    1. I flashed stock recovery, when I boot into it it would give me following error: Can't mount /sdcard (here is the screenshot https://db.tt/Pomo0LbF )
    2. Flashed latest firmware 7.19.401.2 , same issue persist.
    3. Flashed newest TWRM openrecovery-twrp-2.8.5.0-m7 - same issue persist.
    4. Flashed ViperOne_8.0.0, same issue persist.

    I was trying to recreate my steps what I did to cause this problem exactly, and if I remember right I went into TWRP recovery, then Wipe --> Advanced Wipe and selected Internal Storage.

    Here is a screenshot of the error I get once the phone boots: https://db.tt/9vwNzB9t

    Unfortunately I don't have TWRM backup from this phone, but I do have one from another HTC One M7 AT&T that I owned before. Do you think I could restore it to this phone? or that would not work?

    Thanks!
     
  11. Granite1

    Granite1 Zercron Encrusted Tweezer

    Nandroids as a whole are pretty much phone specific, so I don't recommend flashing those between different devices even if they're the same model. There are ways of doing this, but I'm not familiar with the process, so I'm not going to recommend it.

    Looking at your error, it just seems like there's something wrong with your rom flash. When you flash Viper, are you selecting the "Wipe" option from the Aroma installer while going through the install procedure? If you're not doing that, or if thats not how Viper loads on the M7, you need to wipe / factory reset prior to flashing the rom. Thats one possible cause of that error.

    Another might be a bad download of the rom itself. Did you happen to check the md5 sum for the rom?

    I'm not that familiar with the processes on the M7, since I never owned that One. :eek:

    Lastly we might want to get this discussion moved over to the M7 forum so those users can have a look see. We'll wait on that tho so EM and Scotty have a chance to chime in. They're a little more adept than I am, plus I'm a little rusty.
     
  12. arunasd

    arunasd Lurker

    I did perform fresh install (wipe) in aroma when installing viper and when installing ARHD. I also tried factory reset from bootloader multiple times. I did check md5 sum of Viper rom and it did match.

    Should I open a new thread in m7 section?

    Also, do you think perhaps installing stock recovery and stock rom might help?

    Thanks
     
  13. KOLIO

    KOLIO Guest

    If you do indeed have the M7 instead of the M8,just get with Granite1 & he'll likely move the associated posts to that forum......
    Another thread in the M7 forum probably isn't necessary,my guess is there's one there that this conversation can be moved to/merged with.
     
  14. arunasd

    arunasd Lurker

    So no ideas?
     
  15. Granite1

    Granite1 Zercron Encrusted Tweezer

    Sorry, been really busy with work and school. I don't think stock Rom and recovery are your problem. Also when I suggested factory reset, I was referring from recovery, not the bootloader. Doing a factory reset from the bootloader will wipe your internal memory, which I assume you don't want.

    I'm still not home from work yet, taking a break to eat dinner, once I have access to a computer, I'll try to move this conversation over to the M7 forum.
     
    KOLIO likes this.
  16. arunasd

    arunasd Lurker

    Factory reset from Bootloader didn't wipe the internal memory, I done that multiple times.

    I guess I will wait for some more ideas if someone thinks of any

    Thanks
     
  17. skinnyy

    skinnyy Lurker

    hi, i'm new to this forum
    i must thank you earlymoon for this thread!
    you saved my life and a expencive new phone
    my htc one m8 is now upgrading the apps so i hope it works
    big thumb up for you and your work
     
    EarlyMon likes this.
  18. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Welcome to the forums! :)
     
  19. budzam8

    budzam8 Lurker

    I just made an account to ask for your help sir
     
  20. budzam8

    budzam8 Lurker

  21. g13

    g13 Lurker

    I accidentally did a factory reset on my HTC One M8... anyway you can help me get my storage back
     
  22. Hey I had a question to ask you! I pretty much did similar to the guy you helped prior, where i have no os and accidentally wiped all my stuff. I have an unlocked HTC One M8 and my CID is 11111111 and im stuck on a white screen constantly and I dont really know what im doing.. i lost and cant figure out what to do. any way you can help?
     
  23. Cedric Sin

    Cedric Sin Lurker

    Hi arunasd I'm using the HTC One Max and I have exactly the same problem, if you can still use adb commands from a PC this method worked might work for you

    1. Install a rom with root included
    2. Reboot, systemui will crash but it's fine
    3. Turn on USB debugging
    4. Connect the phone to the PC, use the following adb command
    adb shell
    su
    restorecon -FR /data/media
    5. reboot into recovery and install the same rom again
     
  24. EatedCookies

    EatedCookies Lurker

    I have the same problem as jschohan with my AT&T HTC One M8 I have unlocked bootloader S-ON and TWRP in place.

    Installing '/data/media/sideload.zip'
    Checking for MD5 file
    Skipping MD5 check: no MD5 file found
    E: Zip file is corrupt!
    Updating partition details
    E: Unable to mount '/cache'

    C:\Users\Nick\AppData\Local\Android\android-sdk\platform-tools>adb devices
    List of devices attached
    -serial- sideload


    C:\Users\Nick\AppData\Local\Android\android-sdk\platform-tools>adb usb
    error: closed

    C:\Users\Nick\AppData\Local\Android\android-sdk\platform-tools>adb sideload D:\U
    sers\Nick\Desktop\AndroidM8.zip
    loading: 'D:\Users\Nick\Desktop\AndroidM8.zip'
    * failed to write data 'protocol fault (no status)' *

    C:\Users\Nick\AppData\Local\Android\android-sdk\platform-tools>dir
    The system cannot find message text for message number 0x235e in the message fil
    e for Application.
    The system cannot find message text for message number 0x235b in the message fil
    e for Application.

    DNS bad key.
    06/15/2015 07:10 PM The system cannot find message text for message number 0
    x2373 in the message file for Application.
    .
    06/15/2015 07:10 PM The system cannot find message text for message number 0
    x2373 in the message file for Application.
    ..
    06/12/2015 03:14 AM 1,011,200 adb.exe
    06/12/2015 03:14 AM 96,256 AdbWinApi.dll
    06/12/2015 03:14 AM 60,928 AdbWinUsbApi.dll
    06/12/2015 03:14 AM The system cannot find message text for message number 0
    x2373 in the message file for Application.
    api
    11/20/2010 11:23 PM 345,088 cmd.exe
    06/12/2015 03:14 AM 73,728 dmtracedump.exe
    06/12/2015 03:14 AM 338,944 etc1tool.exe
    06/12/2015 03:14 AM 196,608 fastboot.exe
    06/12/2015 03:14 AM 43,008 hprof-conv.exe
    06/12/2015 03:14 AM 816,004 NOTICE.txt
    06/12/2015 03:14 AM 16,513 source.properties
    06/12/2015 03:14 AM 700,928 sqlite3.exe
    06/12/2015 03:14 AM The system cannot find message text for message number 0
    x2373 in the message file for Application.
    systrace
    The system cannot find message text for message number 0x2378 in the messa
    ge file for Application.
    The system cannot find message text for message number 0x2379 in the messa
    ge file for Application.

    C:\Users\Nick\AppData\Local\Android\android-sdk\platform-tools>echo %PATH%
    C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\Sy
    stem32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\S
    kype\Phone\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files\AMI\DuOS
    \;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common
     
    #125 EatedCookies, Jun 15, 2015
    Last edited: Jun 16, 2015

HTC One M8 Forum

The HTC One M8 release date was March 2014. Features and Specs include a 5.0" inch screen, 4MP camera, 2GB RAM, Snapdragon 801 processor, and 2600mAh battery.

March 2014
Release Date
0
Reviews
Loading...

Share This Page

Loading...