1. Download our Official Android App: Forums for Android!

Root [HELP] ADB problem

Discussion in 'Android Devices' started by LeetHero, Jul 14, 2010.

  1. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
    I'm getting problem when I try to install the new ADB drivers.


    the problem is that getting "SAMSUNG GALAXY fast booster" when I fastboot it while trying to install ADB drivers again ( step 3, DaSchmarotzer tut )

    Any sulotions to solve this problem?
     

    Advertisement

  2. sgx100

    sgx100 Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    262
    Joined:
    Mar 18, 2010

    Mar 18, 2010
    262
    14
    38
    Jobless
    New Delhi, India
  3. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
  4. sgx100

    sgx100 Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    262
    Joined:
    Mar 18, 2010

    Mar 18, 2010
    262
    14
    38
    Jobless
    New Delhi, India
    Try this...You need to start clean

    Uninstall KIES/NPS If you have installed it ...Try using Revo Uninstaller...
    Uninstall all Samsung/ADB drivers you have previously installed from device manager
    Restart your computer
    Enable USB Debugging mode from Development menu...Disable Mass Storage Mode from about phone
    Now Attach the 7500 to usb...

    Report back...You shd see ADB Driver interface...
     
  5. maurinet

    maurinet Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    122
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    122
    10
    38
    Israel
    What Operating System do you have? Windows XP, Vista, 7, OSX? And, MOST IMPORTANTLY: 32 or 64 bits? - I had a bit of a hard time making it work on my 64 bit Windows 7, but somehow I managed. On Windows7 32 bits it worked almost automatically.
     
  6. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
    I did exactly what you said.
    Still the same prob,
     
  7. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
    I'm running Windows XP 32bit atm. I've my w7 at work..

    Is it any difference if i use xp, vista or w7?
     
  8. sgx100

    sgx100 Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    262
    Joined:
    Mar 18, 2010

    Mar 18, 2010
    262
    14
    38
    Jobless
    New Delhi, India
    try on a fresh system ( computer )
    and preferably use WIN XP 32 bit ...64 bits have some issues detecting drivers

    First try to install the adb drivers...Rest is a breeze

    Probably you hv used the wrong adb drivers ... try all the drivers available

    Im 100 % sure its a driver issue

    BTW..Did you go through the guides I posted with links ;)
     
  9. maurinet

    maurinet Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    122
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    122
    10
    38
    Israel
    You should also install "Droid Explorer", it's a very useful piece of software and it will install ADB drivers for your phone, that's what made it work in my 64 bit system.
     
  10. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
    It works now! i had to install it on another computer!
    thanks to everyone who helped me out.
    i appreciate!!
     
  11. LeetHero

    LeetHero Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    14
    0
    15
    u can close this thread now thanks
     
  12. sgx100

    sgx100 Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    262
    Joined:
    Mar 18, 2010

    Mar 18, 2010
    262
    14
    38
    Jobless
    New Delhi, India
    Grt ... Now enjoy Galaxo :D
     
  13. lez

    lez Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 6, 2009

    Dec 6, 2009
    4
    0
    5
    I seem to have hit an issue.....

    My phone wont start... (i7500)

    It hangs about 20 seconds in, I cant get past that. (was running current latest 1.6 galaxo)

    I can get into fastboot, and i did a fastboot flash recovery recovery.img

    I rebooted pone

    now it shows the mini recovery screen and says theres no rectools.tar.gzip

    Well thats ok there isnt......

    but adb is not seeing the phone so i cant push it on....

    stuck at this point

    before anyone tells me to go into settings and turn usb debuging on/off, remember it wont boot...

    Its showing up in device mangler as USB\VID_04E8 & PID_6603&REV_0100 - windows is installing the mass storage device driver for it, no matter what I set it to, it wants to keep going back to that.

    Its annoying the hell outa me not having my phone working!


    So, recap....

    Phone connects ONLY in fastboot or unmounted mass storage, no way to mount or format

    Not seen by ADB or Odin.

    Is there any other recovery images that I can try that are are not 'mini' as 'mini' does nothing without the zip files, which wont go on...
     
  14. maurinet

    maurinet Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    122
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    122
    10
    38
    Israel
    I think your problem has to do with not having all the drivers in your computer. What version of Windows are you running? 32 or 64 bits?

    In the meantime you could try to take out your memory card, put it in an external card reader, connect it to your computer and copy the rectools.tar.gz, update.zip and samsung.tar files to it.

    Let us know how you do!
     
  15. lez

    lez Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 6, 2009

    Dec 6, 2009
    4
    0
    5
    I have win7 32 and xp 32, same issue on both.

    I have downloaded drivers from the links above

    The phone is not presenting the right VID & PID to the system for ADB to see it, IE the phone is not in ADB debug mode, its in mass storage mode, or fastboot mode

    If i hold down the call andpower button phone comes on in fastboot mode, PC see phone as fastboot, and I can flash the mini recovery image to the phone. phone then reboots.

    If i hold volume down/call/power, phone comes on in recovery mode, ut has no recovery menu options except rebot, ans sayd i need to copy rectools to the phone with adb. phone is seen by computer as a mass storage device, of 0mb/unmounted. I cant format it from the pc, as its 0mb...

    ADB will not see the phone as it sees a mass storage device with a pid of 6603, i think this is wrong for an adb device, can anone verify what vid/pid i should see in windows for ADB device?


    Well for that I would need to disassemble the phone, and use surface mount desoldering tools, the 'sdcard' card memory is part of the phone......
     
  16. Bigmatt89

    Bigmatt89 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 23, 2010

    Aug 23, 2010
    2
    0
    5
  17. Lelouch

    Lelouch Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    655
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    655
    70
    98
    Kri
    I had the same problem, so I searched for the driver. I found it, installed it (update it) and now it's working without problems. Better to say, every time I connect the phone via USB my computet automatically recognizes the phone immediately.
     
  18. maurinet

    maurinet Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    122
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    122
    10
    38
    Israel
    Could you share the link to the driver?
    Thanx!
     
  19. Lelouch

    Lelouch Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    655
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    655
    70
    98
    Kri

Share This Page

Loading...