1. Download our Official Android App: Forums for Android!

Root help!! bootloader unlocked, root, s on, boot img issues

Discussion in 'Android Devices' started by imchilean, Jan 23, 2014.

  1. imchilean

    imchilean Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jan 23, 2014

    Jan 23, 2014
    6
    1
    6
    hello all,

    I have an htc inspire, about on my 5th one(warranties and insurance), so im not new to rooting them. I have an issue that has me stumped.

    It's bootloader is unlocked, it's rooted, but of course without aahk, it still s-on, which is no biggie, you just flash boot img after flashing rom..

    I can boot the stock rom, backup the stock rom in 4ext, and re flash it, and it boots...

    Also whenever I try to install any new roms from the xda list, roms i have used before, and flash boot img, via fastboot(s on), the phone will start and load the new rom, and the rom runs awesome with no issues.

    Nows where it gets tricky...

    If I turn the phone off, or pull battery, or if the phone shuts off for any reason, it will not boot unless I re flash boot img via fastboot. Once I reflash boot img, it boots fine and everything works great and the rom boots and nothing within is lost. Then if I shut it off, pull the battery, ect. the boot is gone.

    Its like once it is off, it is erasing its boot img.

    Then, if i boot into recovery and flash backup of stock rom/boot img, it boots. I can cut it off and on and it will boot, but its the stock rom i dont want because its just flashing the backup...

    I am lost and out of all of the inspires I have had, s on or off, I have never had this issue.

    I have looked through many forums and have yet to see this issue. Any help is greatly appreciated.
     

    Advertisement

  2. InducedChaos

    InducedChaos Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Dec 23, 2013

    Dec 23, 2013
    10
    6
    16
    Female
    Sacramento CA
    Make sure you have the proper kernel for the rom
     
    imchilean likes this.
  3. imchilean

    imchilean Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jan 23, 2014

    Jan 23, 2014
    6
    1
    6
    we figured it out in another thread, I think i posted it wrong here..the code I was using was

    (CMD from folder containing fastboot application)
    fastboot devices (wait for my serial to show)
    fastboot boot boot.img

    should have been

    (CMD from folder containing fastboot application)
    fastboot devices (wait for my serial to show)
    fastboot flash boot boot.img

    I was missing "flash" which is weird cause I had another inpire 4g, with s-on and the first fastboot boot boot.img worked every time..but once I put the flash in there, it worked like a charm..

    Again, this is only for those who have recently acquired an inspire(mine was from warranty) and cannot achieve s off(its pretty tricky).

    Thanks again for the reply!
     
    scotty85 likes this.

Share This Page

Loading...