1. Are you ready for the Galaxy S20? Here is everything we know so far!

HELP - cannot update firmware via kies

Discussion in 'Android Devices' started by blonkster, Aug 16, 2010.

  1. blonkster

    blonkster Member
    Thread Starter

    I have been waiting for kies to say that new firmware is available (when it works!) and finally it knows there is an update to my JF3 - presumably JM1.

    However, is says that 'this device's version cannot be updated'

    My SGS was bought from Mobiles.co.uk and is using an Orange SIM and as far as I can tell it is not locked or branded.

    The current firmware is

    PDA ...XXJF3
    Phone ...XXJF3
    CSC ...XAJF3

    Is this an 'Orange' CSC?

    Any other ideas on how I can get it updated?

  2. -Ollie-

    -Ollie- Well-Known Member

    Are you sure it is not a Kies update rather than a GS update?
    If you restart Kies without having the phone connected, do you still see the same message?
  3. blonkster

    blonkster Member
    Thread Starter

    No, kies is at the latest version, downloaded it agian to see if it would fix the problem - its the firmware.
  4. jimatr

    jimatr Newbie

    Can you double check that Kies is the latest by using the in-built "Check for Kies updates"? Just in-case the links on samsung aren't pointing to the latest.
  5. snapper.fishes

    snapper.fishes Android Expert

    I am having this problem as well. Right now my phone is on JG4, which is probably the newest version out there. However, in KIES it says that this version cannot be updated. (It used to say this is the newest firmware). So while there's no further updates for my phone, I am quite worried that I won't be update it in the future.

    Have you tried hard resetting your phone?
  6. blonkster

    blonkster Member
    Thread Starter

    I'll check tonight - just in case.
  7. blonkster

    blonkster Member
    Thread Starter

    I've not tried a hard reset - how do you do that, and will it affect apps/ data?
  8. farook

    farook Lurker

    I've had the same problem with mine. Aside from the terrible GPS, i was unable to get Kies to recognise my Galaxy S in anything other than USB Mass Storage Mode. I took the phone to the O2 store to try and get an update there and they were also unable to get Kies to recognise the phone. I arranged for the phone to be sent to engineers and so formatted the internal storage, and out of curiosity I tried connecting to Kies. This time it connected and when I tried to update firmware I got the same 'this device's version cannot be updated' message. Which is a joke really as I'm on the JF1 firmware which I believe is the earliest one around. The phone's been returned to engineers now, informing them that the GPS doesn't work and I can't update the firmware. Two weeks without my phone which is going to be a pain, but it would probably need doing at some point anyway as I reckon I wouldn't be able to update to Froyo when that eventually comes out, with (hopefully) the GPS and file-system fixes.
  9. snapper.fishes

    snapper.fishes Android Expert

    Don't do it. The new kies fixed the problem now. The message now display "Your phone is using the newest version".

    Support for Galaxy S SAMSUNG

    For future reference, hard reset will delete everything in the phone memory.
  10. stephen67

    stephen67 Newbie

    I just purchased my Galaxy S on Friday.

    I downloaded Kies and today was prompted to perform an upgrade, which I did.

    After it was completed, I connect my Galaxy and then was advised that there is a firmware upgrade.

    I clicked to have the update performed and I got this error:

    Model Name: GT-I900M

    Current Version: PDA JG9 / PHONE JG9

    This device's version cannot be updated

    I am with Bell in Canada. I got the phone for a discount price because I signed a three year plan.

    Is my error a serious issue.

    Does Samsung support the phones, or does one go through their carrier?

  11. -Ollie-

    -Ollie- Well-Known Member

    Just for my information, could you please post a screenshot of the firmware update available message?
    I would appreciate it.
  12. blonkster

    blonkster Member
    Thread Starter

    Well, it finally worked - now on JM1 and getting better GPS performance :)
  13. anand.rar

    anand.rar Lurker

    I am from Germany.
    and last week when i had bought the phone i had updated KIES, and the phone came with JF3 firmware. KIES says its the latest version!!!
    how can i update to JM1???? does it require rooting?
  14. firefox73

    firefox73 Well-Known Member

    As per posting I've just made answering your question in another thread, no the phone does not require rooting to get JM1. It may be that your network provider hasn't approved the update. My phone is sim free.

    Appreciate that you are new to Android and probably keen to get an answer quickly but without wishing to harp on, could people please do a search before posting and then only post their question in either a thread that relates to the subject or create a new one. It makes staying on top of subjects pretty tiring when they either thread drift or are duplicated.

    BTW welcome to AndroidForums anand.rar ;)
  15. anand.rar

    anand.rar Lurker

    Well..... Sorry to caused you disturbance, but FYI, i had searched in this forum quite a bit to find something regarding the latest official firmware, but those doesn't really clear my doubts. Hence decided to post my doubt here.

    MACEYEE Lurker

    Just to help the confusion, i have samsung kies in london, it wants to run the update when no phone is connected and makes very slow progress in doing this update on vista, whilst i keep having to verify the update splash screen to get it to continue. The update is 123823 kbs in size and takes forever to download... i dont even use kies i just set my phone to work via usb storage mode... if it completes i'll let you know of the changes its made.

    ps kies version was the latest download as of today on the samsung website!

    MACEYEE Lurker

    Updates samsung kies to version

    MACEYEE Lurker

    The update is for samsung kies not your phone and it updates the version to
  19. anand.rar

    anand.rar Lurker

    Finally upgraded to JM1.....
    I did a lot of googling to find how I can update official firmware to JM1 from JF3.
    Finally I read in xda-developers that one can take KIES to test mode (never heard that before.). once this is done connect the phone and luckily KIES will provide the upgrade to JM1.
    1. start KIES > OPEN the firmware upgrade window
    2. press alt+cntrl+u+p (while the firmware window is still open). you will get a pop up saying KIES is in test mode
    3. Restart your samsung (simple restart). then connect to KIES.
    4. I saw for the first time KIES telling me there is an update for my firmware.

    some have said that even this didnt work and some suggested tweaking the registry and changing the product code, thereby fooling KIES the actual location of use of the phone........well, i dont feel very confident in trying this.
    dantam1 and ArmadaTattoo like this.
  20. surreycrv

    surreycrv Lurker

    After much googling I can't find this issue anywhere. I managed to finally connect to kies with a new Win 7 machine, but the dialogue box that halts the process is it requires a full charged battery. So disconnect and plug the adaptor to the wall and charge to 100%, then reconnect. Same issue, over and over.

    can't connect on a vista machine, is there any other way to access the firmware upgrade other than this buggy Kies?
  21. stylelite

    stylelite Well-Known Member

    Hi every one, I found the following on XDA developers, so I thought I would post it here to help every one who is having trouble updating from JF3. This worked for me

    From what I have gathered on other forums (XDA Developers) its all to do with how your device is identifed in its product code.

    I bought my Galaxy S sim free from Carphone Warehouse and I get the same "can't be upgraded" and "is already up to date" from Kies. Others on XXJF3 have however been able to update to the JM1 build through Kies.

    It seems that the updated build has only been issued for "stock" ROMs. Despite buying SIM free from Carphone Warehouse my device seems to be treated as provider ROM.

    There are two ways of checking what the "product code" is. On your device use the code *#272*HHmm# (where HHmm is the current time in 24hr format that your device is displaying. Mine says the product code is CPW (which obviously means Carphone Warehouse is being treated a provider build). Others have seen things like VDI (vodafone ireland), ORA (orange) and so on.

    It seems (again from the other forums) that the stock ROMs have a product code ending in XEU (for UK - sorry I don't know the full set - go the XDA Developer forum for Galaxy S and search).

    The other way to check apparently (which I haven't tried yet) is to fire up Kies, connect the Galaxy, then before doing anything else go into the Registry Editor and look for the following key:
    Note the number at the end could be anything so you will need to look through

    This key you are looking for will contain the following value:
    "Product Code"= "GT-I9000KHDCPW"​
    The CPW bit is the key information (at least for my device).

    As this is an HKey_current _user setting it is only there when Kies is running and the device connected.

    Now apparently (and I don't know whether this works), if you change the registry entry to the value GT-I9000HKDXEU (again only for UK) and close the registry and then try the firmware update (all while still running Kies ovbviously), Kies will now think you have a stock ROM and offer the ROM upgrade to JM1.

    I will try this when I get a chance and feed back if it works. But at least it may offer an explanation and/or workaround.

    UK I9000 official firmware upgrade - Page 19 - xda-developers

    Registry Hack
    goalc and jatank like this.
  22. jatank

    jatank Newbie

    wow thanks that worked ^

    I was on jf3 from carphonewarehouse uk. same old firmware message from kies "this device cannot be updated"

    changed code to xeu on phone (*#272*HHmm#) from cpw. restarted. beware the phone resets to factory settings, so backup if bothered.

    Then connected phone to pc, started kies. went into regsedit (type regedit on the run bar on the start menu) looked for the product code as instructed, modify the final 3 digits from CPW to XEU.

    Hit the firmware update button and bam, new firmware available! it is updating as I type this.

    Thanks for the help man, Ive been checking for official updates to JF3 for ages!

    Love it.

  23. ArmadaTattoo

    ArmadaTattoo Well-Known Member

    thanks so much for this, it worked for me once I charged my battery. Vodafone ireland.
  24. sudburys

    sudburys Lurker

    Sorry to be a pain but I'm relatively new to all this so am still trying to learn....

    I have typed in the '*#272....... thingy' and see that my code is 'VOD' - which makes sense as I am on Vodafone in London UK. My problem is, how and where do you change the code to the generic uk code? - The 272 screen doesn't seem to allow me to change anything.

    BTW, I have the same problem with Kies not recognising my device... even when it is in debugging mode (with Kies both in and not in test mode).

    Help needed I'm afraid!!!! :thinking:
  25. stylelite

    stylelite Well-Known Member

    This is what you should see when you enter *#272*HHmm#(HHmm= 24 hour clock)
    scroll down until you see XEU click on it and then on install. Beware it will reset your phone back to how it was originally so back up anything important, contacts photos ect.
    If this doesn't work try the registry:
    open kies and connect your phone,
    open regedit,
    kies should already be shown, if not this is the registry key HKey_current_user\Software\Samsung\Kies\DeviceDB\12(this number may vary)
    under kies there are sub folders 1, 2, ect click on each one in turn and check the right hand pane until you find the product code/sales code, double click it and change the last 3 letters from what you have now VOD to XEU(for the UK)
    close regedit and go back to kies and click on firmware update and then ctrl+ant+U+P this will put kies into test mode it should now show a update to JM1.
    good luck[​IMG]

    http://forum.xda-developers.com/showthread.php?t=751639&page=19 this is the link for more info

    As for kies not seeing your phone, I also had this problem and the only thing that sorted it out for me was to uninstall kies and then manually remove everything from the registry, but make sure you have the latest version of kies first.

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date
Similar Threads - HELP cannot update
  1. Biggen69
  2. Biggen69
  3. tabi212
  4. dafiryan
  5. AZboi
  6. MartinW12
  7. Protonus
  8. HuaweiY7Pro2019_Tyong
  9. Utkarsh4
  10. MiroKlose

Share This Page