1. Check out our companion app, Forums for Android! Download from Google Play

General Help! Dadgum Conquer won't charge!

Discussion in 'Android Devices' started by Cinnamon1, Aug 27, 2012.

  1. Cinnamon1

    Cinnamon1 New Member
    Thread Starter

    Aug 27, 2012
    A month ago, my first Conquer began to go dead whilst on the charger. I used three different chargers and the same thing would happen, or it would show "charging" with little red light on, but it would actually be draining itself. The Sprint Store guy said I needed a new battery, so I got one. Same thing continued to happen. I went back & he didn't believe me until I plugged in my charger and showed him "20%" and waited around for a while then showed him "17%" so then he believed me and ordered me a "new" refurbished Conquer. It worked fine for about 3 weeks, and now it has started doing the same thing. Last night it had 41% charge when I put it on the charger and went to bed. At 3 a.m. I heard the alarm going off saying to "charge" and it had drained itself, all the while showing to be "charging"............ACH$^&*)(*_ What to do other than getting another one? (got 18 months to wait for the freebie):mad:


  2. BladeMaverick

    BladeMaverick New Member

    Aug 21, 2012
    Sounds like a common theme with the Conquer, as my friend's Conquer seems to do the same. Check out my thread to see if any of the things I've tried may fix yours. You might get lucky. :\ I've been waiting for a response since the 21st. I think the forum is pretty well dead. xD;
    Cinnamon1 likes this.

Share This Page