1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help!! Evo Phone Stuck Updating to 2.2

Discussion in 'Android Devices' started by Cryt, Aug 3, 2010.

  1. Cryt

    Cryt Newbie
    Thread Starter

    I have a rooted Evo, and I decided to go ahead and get froyo today. I used the software update and downloaded it, went ahead and let it update, and now about 2 hours later it's still updating. I'm stuck on the screen with the Android guy with a triangle and exclamation point in it.

    Is this normal? How long does this update take?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Shawnz

    Shawnz Android Enthusiast

    you are in recovery.

    Does it not boot at all now to the OS?

    You'll obviously lose root doing it the way you did. You might be better off d/ling a rooted 2.2 (3.26.651.6) ROM and loading that via your bootloader.

    Worst case revert to the stock un-rooted 1.47 ROM and then try to OTA update it.
     
  3. Cryt

    Cryt Newbie
    Thread Starter

    holding down the power button does absolutely nothing. popping out the battery = bad idea?
     
  4. Shawnz

    Shawnz Android Enthusiast

  5. Cryt

    Cryt Newbie
    Thread Starter

    nothing at all. this is what it looks like:
    ][​IMG]
     
  6. blkwrxwag

    blkwrxwag Lurker

    Push the Volume Up button and Power at the same time.
     
  7. Cryt

    Cryt Newbie
    Thread Starter

    I have, it's not working. I held them down, i press them repeatedly... i don't know what's going on.
     
  8. nizmoz

    nizmoz Well-Known Member

    Same problem here. I can't it to take the update. :(
     
  9. Cryt

    Cryt Newbie
    Thread Starter

    I popped out the battery. It was just froze in recovery, and that knocked it out of it. froyo didn't take, but i'll try it again in a little bit.
     
  10. marukai

    marukai Lurker

    I'm having the same issue. The installation bar starts to fill to 1/4 and then I get the screen with the Triangle and Green droid. I've tried pulling the battery a dozen times, but it always does the same thing. I'm rooted with Unrevoked 3
     
  11. kiz.cyrus

    kiz.cyrus Lurker

    Im at the same state you are I think its something with unrevoked because thats what I used and its still not working
     

  12. i popped out the battery three times and restarted and tried again and i still ended up with the exclamation point screen all 3 times. I went ahead and reflashed with the stock RUU and then downloaded the update and it worked

    [How To] Unroot and return to stock. - Android Central Forums

    edit: i too had unrevoked and came across this problem.. taking your battery out wont do anything bad.. it will just reload the phone like it normally does..

    if you have unrevoked you HAVE to either:

    1. Use a custom rom w/ froyo
    2. Re-install and reflash default RUU from link above and then do the update
     
  13. kiz.cyrus

    kiz.cyrus Lurker

    I got it. Just use clockwork root to reset phone and install pretty painless.
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...