1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help: EVO will Not Mount or Access Apps on SD Card??

Discussion in 'Android Devices' started by scudder, May 15, 2011.

  1. scudder

    scudder Android Expert
    Thread Starter


    I had this problem before (back in late January 2011) and a good friend in the forums "Akazabam" spent a RIDICULOUS amount of time helping me with various steps to wipe certain portions of my phone and/or using nandroid backups to get me back up and running. Using parts of some suggestions and parts of others, I was able to restore my phone to working order again, however, we were NEVER able to figure out quite WHY this issue is happening and, at this point, happening again:(

    I was hoping SOMEONE might have any answer so that I could not only understand the problem but could possible avoid this from happening in the future.

    So here's my problem...

    For some reason, my phone will stop loading / mounting / propagating the apps that are installed on my SD card. Any apps that I have on my SD card are unaccessible, will not launch and therefore cannot be used; anything installed on the internal memory of my phone can be launched.

    Another result of this problem is that, although it normally could, my computer will no longer mount my SD card through the phone USB to computer connection. It is as if there is NO communication between the phone and the SD card.

    I do know FOR SURE that the data on the card is there and has not been lost. I AM able to access the SD card wireless through an app such as SwiFTP so that I can access the card via FTP. Like I said, for some reason, the phone just stops communicating with the card, will not load or permit access / launching of the apps on the card.

    While I cannot access the apps on the phone, I CAN still write certain data to the phone (e.g., I can "backup to SD" certain information from apps that will launch). I also have NO PROBLEM accessing my pictures via the gallery. I can also take pictures and video and those file are written to the card with NO PROBLEM. So, with my very, very limited technical understanding, it appears that the phone to SD communication problem involves the APPS on the card.

    I am not EXACTLY sure if the following circumstance is a coincidence or might have something to do with my problem but the phone's failure to mount and make accessible apps on the SD card seems to sometimes correspond with a "low memory" on my phone, either the phone's internal memory or the memory on my SD card. I often hit the "10%-ish" memory remaining on my phone, corresponding to about 45-47MB of free space left to install apps. I also seem to run into problems if the available space on my 16GB SD card hovers around or goes below 6GB of free space.

    Usually all I have to do is uninstall or Titanium Backup/Archive apps to free up some space, get a few MB or more above that 10% remaining memory level and I'm good to go.

    But The BIG PROBLEM is when I actually find that the apps on my SD card are not mounting and, by then, it is "too late." for me to do anything unless I get LUCKY and the SD card is "magically" (randomly that is) recognized by the phone after a reboot. The PROBLEM is that when the apps on the SD card are not mounting, *ANY AND ALL ABILITY TO UNINSTALL APPS DOESN'T WORK*. Again, I do NOT know the tech issues with my problem but the phone probably has to access the SD card during the uninstall process which the phone is not allowing. ANY option I use...the basic Manage Applications option or an Uninstaller app or Titanium will NOT ALLOW AN UNINSTALL and just hangs incomplete.

    I have been able to "fix" my problem with some LUCK in that I have used a nandroid backup, lost about 10 days of data, and restored apps. Problem NOW is that I fear that my nandroid backups may very well have backed up the CORRUPTION/ISSUES causing the current problem with my phone. Also, MOST IMPORTANTLY, I am trying to figure out **WHY** this problem is happening to work around or avoid in the future??

    So, is there a problem with my card?? Is my android_secure directory corrupted?? Is this an internal/external-sd card memory issue?? Some other problem??

    I MUST be honest...I HAVE force-moved a few apps from internal memory to SD card but LATELY the move had NOT caused the SD card app mounting problems. In the past I have FROZEN some bloatware Spring crAPPS such as Nascar and Football to keep them from loading but I have recently UNINSTALLED A FEW BLOATWARE APPS (after a nandroid backup!) to free us some memory. Again, the uninstallation of this bloatware has NOT directly/immediately resulted in the problem I have with my SD card.

    So, has this happened to anyone else?? What has been your fix?? Anyone know WHY this happens??

    THANK YOU for your time!!!

    1. Download the Forums for Android™ app!


  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    scudder likes this.
  3. youdoofus

    youdoofus Android Expert

    do you have another sd card you could try out to see if its the card itself? it doesnt sound likely, but possible
  4. scudder

    scudder Android Expert
    Thread Starter

    Sorry if the answer to your question is hidden in all the information I provided originally but, yes, in the past (back in January/February), I have been able to flash a nandroid backup and "restore" my phone back to a previously working state. The problem in the past was that my backup was about 10 days old and I lost some data.

    With my current issue that has prompted my latest post here I have NOT tried the nandroid restore yet because (1) I'm trying to find out the REASON for my problem to avoid it in the future and (2) it is possible that my nandroid backups have much more recent data than 10 days ago and, because of that, might actually have backed up THE PROBLEM. I'm just trying to see if I can figure some stuff out before I do the nandorid backup like I've done in the past.

    With regard to the method I am using to move apps to the SD card, I am using a combination of the stock froyo apps2SD, Titanium Backup's "move to SD" option and the "Move2SD Enabler" app with the froyo apps2SD which "unlocks" the move to SD option in the phone, allowing you to move pretty much ANYTHING with the stock Manage Applications move to SD option (and, as a result, allows you to get yourself into trouble with what you choose to move if you're not careful!!).

    If I didn't mention before I am obviously rooted but I still have the STOCK ROM. I haven't flashed anything custom.

    I read a bit about the Darktremor option a few weeks ago...I believe what I read was that it "more completely" moves apps to the SD card so that there are less problems (and one could even run widgets from the card as well...)?? I had thought that I have to choose and flash a COMPATIBLE ROM that has Darktremor incorporated into the ROM...did I read correctly?? Or can I use Darktremor as a "standalone" option with my rooted stock froyo??

  5. scudder

    scudder Android Expert
    Thread Starter

    Crossed my mind but, at the moment, I do not have another card:( Original card was 8GB and now have a 16GB acting wacky so the 8GB backup is too small to swap.

    In the past day I HAVE been able to backup ALL of my SD card to my computer! During one of many reboots the SD apps actually MOUNTED and I was able to backup the SD card contents. I have a TOTALLY DIFFERENT ISSUE now with regard to the USB ports on my computer where I cannot mount any SD cards over 2GBs (don't ask!!) so I have difficultly swapping out another card to see if it is a card issue.

    That being said, if I AM able to swap out a card and/or reformat my current card, I had a couple questions....

    How do I go about reformatting the card?? I have a Mac with OS 10.4.11. Do I just trash the contents or do I need to do some sort of "deeper" reformatting??

    Second question...when I was able to backup the card, I also made a point of backing up the HIDDEN FOLDERS including .android_secure and all others on the card. When I transfer my old data to the reformatted or other card, do I transfer ONLY the visible folders or do I transfer the HIDDEN folders (e.g., .android_secure) as well??

  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i would transfer everything over to your computer and ref-format your card. you can re-format it through your phone. it should be in your settings/storage then format card. hopefully, once you move everything back onto your card your issues will be fixed.
    scudder likes this.
  7. beastinbolts

    beastinbolts Android Expert

    sorry I am in left field of this discussion but what is the reasoning behind eating up all kinds of space on you ad card by using apps2sd... they are stored in tb... what is wrong with that
  8. Rainmake

    Rainmake Lurker

    I have been experiencing the same thing. Not sure what to do. I had Sprint replace the phone once, but I am just frustrated at this point. I hope someone can find a solution to it. I find you can access the SD card also by going into Recovery and mounting it from there. Otherwise I do a recovery and just hate how much trouble it is causing. What a headache!!!

    Evo 4G
  9. scudder

    scudder Android Expert
    Thread Starter

    I will try that. I saw the reformat option in my Home preference folder but it was greyed out. I ASSume that I have to unmount the card to reformat. I'll do that and see what happens...thanks!
  10. scudder

    scudder Android Expert
    Thread Starter

    I wanted to reply to your question but don't what you mean when you said, "...they are stored in tb...." What is "tb"??
  11. scudder

    scudder Android Expert
    Thread Starter

    Sorry you're having the same problems. It IS quite frustrating. I'm gonna try the reformat option in a few mintues. I'll let you know what happens...

    I was wondering about general state of your phone?? I mentioned that my issues seem to occur when I have low internal memory (about 10%/45MB left). When did/do your issues seem to occur??
  12. youdoofus

    youdoofus Android Expert

    tb is teberculosis, no oops taco bell LoL ok, all kidding aside its titanium backup (i abbreviate it as TiB)
  13. youdoofus

    youdoofus Android Expert

    i know you said that you have alot of stuff that wont fit on your 8, but did this problem occur on your 8? or did it start when you got your 16? sounding more and more like a bum sd card... but ocn is correct in suggesting to reformat and try try again (if at first you dont succeed LoL)
  14. scudder

    scudder Android Expert
    Thread Starter

    Answer is YES...yes, I did have this problem with the 8GB card. The thought was that it was a space problem. I'm still not sure it could VERY WELL be the case, however, I have now had this problem recur with 6GB remaining on my 16GB card. To have THAT MUCH space available on my 16GB card should NOT be giving me problems...says me at least... :(
  15. youdoofus

    youdoofus Android Expert

    says me too.... odd that you were having the issue on both cards....
  16. scudder

    scudder Android Expert
    Thread Starter

    Ha! I gotcha now. I've seen in abbreviated more like "TiB" with "Ti" for Titanium. Anyway...

    If I follow you correctly, although TiB/TB has the apps backed up, the apps do not RUN from/through Titanium. That is just a backup should you run into problems. I'll also use TiB to "archive" apps that I have uninstalled...keep a copy in TiB and then uninstall and you can reinstall that app with or without your data if you should ever want to use the app again in the future.

    What I am talking about with moving apps to the SD is so that I can STILL USE THE APPS...still have them launchable. The EVO has a real crap-amount of space on the internal memory of the phone to install apps...like 400MB...but if you can install the app or move it to the phone and still have it function, you got a TON MORE space on the phone to install apps that you can LAUNCH.

    Did that answer your question?? TiB will backup your stuff and archive it...but moving apps to the SD card will allow you to RUN those apps...
  17. scudder

    scudder Android Expert
    Thread Starter

    Says me too about youdoo saying me too...or something like that...

    Which NOW brings me to the possibility that, as was suggested back in January/February when I first had this problem, that there is SOME sort of corruption, perhaps in the .android_secure directory of the card.

    About an hour ago I REFORMATTED the card and then COPIED back backed up SD card contents....NO GO. I appear to have simply reinstalled my problem. For the few moment that my card was wiped I WAS able to access my SD card and mount it through the phone to my computer. DUH though...there was NOTHING on the card so not too shocking that I was able to mount it. But when I reinstalled the SD contents to the reformatted card and rebooted, once again, my phone did NOT mount the SD card apps. Back to where I was... :(

    NEXT thing I'm in the process of doing is wiping the .android_secure directory and reinstalling my apps. RATHER TEDIOUS but, if I get tired, I can always nandroid restore my phone back to this mornings (no SD-mounting) state...

    I'll let you all know...
  18. youdoofus

    youdoofus Android Expert

    :) titanium will b/u and restore, but apps2sd is what you need to accomplish what youre attempting. have you tried doing a caulkins wipe all, then reformatting your card, and doing fresh installs of your apps, then using apps2sd? kinda long n drawn out i know, but soulds like a likely fix
    scudder likes this.
  19. scudder

    scudder Android Expert
    Thread Starter

    Since my previous reformat of the SD and reinstall of the SD simply reinstalled my previous problems (AWEsome!!) your suggestion is what I was leaning toward...

    I wasn't familiar with the "caulkins wipe all" did a search on Google and found a post if yours actually!! :


    I noticed it is a zip...is it a zip for a PC or is it simply a flashable zip that I access from recovery?? Also, I'm ASSuming that I don't have to worry about "unrooting" my phone, correct? Nor will I have to worry about my phone data with my card backed up and nandroid backups as well?? What exactly is WIPED...what is lost?? I'd prefer NOT to have to redo all my general phone settings if at all possible...

    Youdoofus, have you ever heard of "simply" trashing the .android_secure folder and reinstalling apps?? It seems that this caulkins wipe will wipe the .android_secure folder clean but wasn't sure what you've head about the .android_secure folder causing problems or becoming corrupted??
  20. youdoofus

    youdoofus Android Expert

    you assume correct regarding the unroot :) wipe all clears sht cache, dalvik cache, data and system folders within the system shell. its stuff that the android os rewrites every time you flash a new rom. Its the best thing to do to ensure that old system data doesnt interfere with the new stuff youre writing to the system data folders. ive not heard about the .android_secure causing problems as of yet (well besides you mentioning it) nor have i heard about apps2sd causing this specific issue either. sounds like you may hafta do a factory reset and start from scratch. pain in the a$$ i know, but it sounds like a sure fire fix. why are you doing the apps2sd thing anyways? i know the 440MB internal storage is far less than ideal for running several apps simultaneously, but are you getting force closes alot or something? FC's are the only reason ive ever seen for people to try this is why i ask. yes phone data is backed up on nands but that isnt the biggest issue here. this wipe_all is supposed to remove o.s. specific files and is especially helpful when going from one type of rom to another (i.e sense to non-sense to aosp) ive gone from aosp to aosp without wiping without issue, but is not advised to do that. i only did that cuz i was curious about what would happen lol anyways, im thinking that some of your installs are corrupt, and identifying which may be a bigger pain than the factory reset method. hope this overly long post helps man :)
    scudder likes this.
  21. scudder

    scudder Android Expert
    Thread Starter

    Sorry doofus...I've been incommunicado for a bit. House was "sick" and got a bit busy with some other things...including...

    Well, as I was sorta dreading but expecting, I did a FULL WIPE of the phone. I didn't use the caulkins wipe itself but various things I did (MOSTLY for my own edification and knowledge) wound up accomplishing the same thing that caulkins would have done but I accomplished it manually in various steps of wiping data, cache, dalvik...pretty much EVERYTHING to start over.

    Must admit I was a bit nervous and didn't know what to expect but as everyone has assured people in similar position as me, as long as you have your SD card backed up you lose NOTHING!!

    Now that being said, the part that I was dreading and the part that has been tedious is the reinstall. Titanium Backup is FAN-FRIGGIN-TASTIC. I've used it to reinstall apps before but NOT with a full wipe. I'm now selectively reinstalling some apps that had IMPORTANT data and other apps I'm installing "fresh" in case something I had was corrupted in the data portion of the backup or otherwise. In any case, Titanium is GREAT for keeping track of what you had in your phone.

    Other than a tedious process of reinstalling your apps, entering account information and resetting your settings and prefs for your phone and apps, there is just one thing that is slightly annoying. Since the phone is reset, the IMG and VID numbers for the camera pictures and video is ALSO reset back to ...001.jpg, etc. If you back up your pictures to the computer and you have not renamed or cataloged your pictures with a new name BE CAREFUL that you do NOT OVERWRITE your files with a "new" IMG0001.jpg replacing your "old" IMG0001.jpg.

    So, it has taken HOURS over a COUPLE DAYS for me to get back to pretty close where I was prior to my problems but it appears that the wipe has worked!! I am SMOOTH, I am FAST, I am CLEAN!! I am selectively reinstalling apps...I had a TON of crap so I'm culling and seeing what I really really need. Phone is working fine and faster with less crap...DUH, imagine that!!! I still do NOT know what happened to cause this SD card corruption/problem/whatever but I seem to be in good shape now!

    Agreed...hence the factory reset!!

    And NO NEED to apologize for a long post...I am KING of the Long Posts. Plus, you helped tremendously...thanks to you and everyone else!!
  22. scudder

    scudder Android Expert
    Thread Starter

    Rainmake...I'm not sure if your problem was the exact same as mine and you mentioned you had your phone swapped out with same results but as I just posted, the clean WIPE EVERYTHING method that was suggested has worked for me so far. Good luck...
  23. scudder

    scudder Android Expert
    Thread Starter

    Don't know if I commented before but my the "memory" I'm talking about is NOT RAM...I'm talking about the memory available TO INSTALL APPS. I never had a problem with running apps with the RAM that is available...only the space associated with INSTALLING APPS.
  24. Listerart

    Listerart Lurker

    I've read the entire thread and I'm having the exact same problem you're experiencing. It just started last night for me. I have a 32GB SD card I've been using since Dec. My EVO is rooted and has been for some time. All of the sudden, the card doesn't read correctly -- mounted but the phone doesn't acknowledge the apps that are on it. I've managed to get it to USB mount on my Mac desktop so I could copy it's entire contents off the card and erase it. Everything was going great until getting everything back the way I had it until I went to mount it on desktop to transfer files back over. The same problem comes back.

    My theory is that USB mounting it to the desktop actually does something funky to the card and causes the problem to resurface. I'm going to re-wipe the SD card and start again, this time using an app called WiFi File Explorer to move files to the SD card without having to mount it through the USB connection. I don't know what else to do at this point. Seems like it all works fine until I've tried to mount it to my Mac a few too many times.

    I miss my iPhone.

    UPDATE: Searching the web for more help on this subject, I did come across this thread over at XDA -- someone else having the same problem with a possible solution at the end of the thread. Will be trying this tonight: http://forum.xda-developers.com/archive/index.php/t-827023.html
  25. scudder

    scudder Android Expert
    Thread Starter

    Hey Listerart...

    Interesting thought you have as I highlighted above...though I haven't heard anyone else with that theory. I have a Mac as well and, as I'm sure you're aware, the Mac puts these hidden .ds.... files in every folder to assist with window positioning and other desktop data. I'm not sure what else could be causing the problems because of a Mac mount. I guess you could delete all the .ds files if you wanted but that could very tedious.

    Also would like to mention that I mount a Samsung Epic 4G to my computer to back up my wife's photos and have NEVER had a problem like I have with my EVO in this thread.

    So, Listerart, how has your phone been since your post??

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page