1. Download our Official Android App: Forums for Android!

Support Help! Google contacts won't stop syncing!

Discussion in 'Android Devices' started by rinso, Oct 5, 2010.

  1. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    I saw someone else had a similar thread, but when I clicked back this thread seemed to start itself automatically...

    Anyhoo, my google calendar and my gmail sync fine, but contacts gets the spinning wheel that never stops. Is there any way to fix this without rebooting and wiping everything off of my phone? How do you even reboot anyway?

    Other than this issue (I'm on 2.1, not rooted or anything) everything on the phone works just fine...hence my mere two posts.

    Thanks in advance...everyone here is so helpful.
     

    Advertisement

  2. cableguynoe

    cableguynoe Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,030
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    I would definitely try a reboot to see if this fixes your problem.

    Hold down power and you should get a power off option.

    Or, pull the battery.

    Then see if Gmail contacts is still spinning
     
  3. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Ahhh...success! I found another answer somewhere in here...deleted everything from "manage contacts" and just had a successful sync for the first time in over a month! Phew!
     
  4. doogald

    doogald Android Expert
    Rank:
     #56
    Points:
    483
    Posts:
    6,695
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,695
    1,927
    483
    If rebooting does not help, try this (note that if you have any phone contacts, they will be lost. This will reset your Google contacts only. If you have only Google contacts, you should be all set. If not, look for an app called UiA Backup Contacts in the market, and use that to export your contacts in CSV format to your SD card. Later on you can import them back, or - better - import them to Google Contacts in Gmail):

    From home, menu->settings->accounts & sync, tap your Google account, then turn off Sync contacts

    Then, go into settings->applications->manage applications
    Wait for the list to refresh
    Look for Contacts Storage. (You can hit menu, sort by size, menu, sort a-z, to get it into alphabetical order.) Tap Contacts Storage, then tap "clear data"

    Go back into accounts & sync, and turn on Sync contacts again.

    It should kick off a sync. Watch to see if it finishes.
     
  5. luckie_reubs

    luckie_reubs Newbie
    Rank:
    None
    Points:
    35
    Posts:
    12
    Joined:
    Nov 30, 2009

    Nov 30, 2009
    12
    0
    35
    Could you detail for me how you did this? I'm having major problems on my end, and I don't know if you mean from the Google end or the Android end in terms of "manage contacts".

    Thanks!
     
  6. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Well, the problem has resurfaced, so I'm not sure my fix is the best route. FWIW, I believe I went into the Andriod "manage contacts." I lost some phone info, but it seemed worth it, but not if the problem will keep cropping up.

    Any other advice anyone?
     
  7. doogald

    doogald Android Expert
    Rank:
     #56
    Points:
    483
    Posts:
    6,695
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,695
    1,927
    483
  8. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Yes, thanks doogald. That was the solution that worked originally, but the problem resurfaced a couple of weeks later. Not sure what the actual problem is, but I just cleared it out again and it's working fine again (for now). I expect the problem to be back pretty soon...
     
  9. doogald

    doogald Android Expert
    Rank:
     #56
    Points:
    483
    Posts:
    6,695
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,695
    1,927
    483
    Ok, good. It only happened to me once, back in May, but then I ended up rooting the phone. Since then, it's not happened. (Not that this means the stock ROM was the cause...)
     
  10. DaveDragon

    DaveDragon Newbie
    Rank:
    None
    Points:
    36
    Posts:
    26
    Joined:
    Apr 22, 2010

    Apr 22, 2010
    26
    4
    36
    I have to do this about once per month.

    One work around is leave Contact Sync off and only turn on if you've updated any contacts.
     
  11. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Thanks Dave. I may do that...but how do you have only the Contacts part of sync off? Sorry if that's obvious, but I've never figured that out.
     
  12. Podivin

    Podivin Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    3,679
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    menu > settings > accounts & sync > select the gmail entry then uncheck 'sync contacts'
     
  13. doogald

    doogald Android Expert
    Rank:
     #56
    Points:
    483
    Posts:
    6,695
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,695
    1,927
    483
    Are people having this issue also doing Facebook contact sync? Any other third party contact sync on the phone? I'm just curious...
     
  14. Podivin

    Podivin Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    3,679
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    Off and on I've seen grumbles about the Facebook sync doing something like the same thing. However, as I recall it mostly happens when the folks at FB update the software and 'break' something.
     
  15. DaveDragon

    DaveDragon Newbie
    Rank:
    None
    Points:
    36
    Posts:
    26
    Joined:
    Apr 22, 2010

    Apr 22, 2010
    26
    4
    36
    What he said...
     
  16. DaveDragon

    DaveDragon Newbie
    Rank:
    None
    Points:
    36
    Posts:
    26
    Joined:
    Apr 22, 2010

    Apr 22, 2010
    26
    4
    36
    I don't sync FB, I update manually.
     
  17. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Sorry...not to be dense, but under sync settings I have manage accounts > google > then it lists contacts, gmail, and calendar, but there's no option for checking any of them. If I click on one it starts syncing (it says "select to sync now.")

    What am I missing (other than some brain cells)?

    Thanks!
     
  18. Podivin

    Podivin Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    3,679
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    I suspect we're seeing a difference in ROMs. I'm on a 2.2 ROM, it may have options that yours does not.
     
  19. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Rats. Still on 2.1. Oh well. As long as I keep all contacts as google contacts it won't be a big deal.

    Thanks again!
     
  20. DaveDragon

    DaveDragon Newbie
    Rank:
    None
    Points:
    36
    Posts:
    26
    Joined:
    Apr 22, 2010

    Apr 22, 2010
    26
    4
    36
    You have Auto-sync turned off. Turn it back on and you'll have check boxes.
     
  21. rinso

    rinso Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    26
    Joined:
    Apr 3, 2010

    Apr 3, 2010
    26
    0
    15
    Hey! You're right! Thanks!
     
  22. crittera

    crittera Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 5, 2012

    Apr 5, 2012
    1
    0
    5
    I was having the same issues (constantly on no matter what I did the sync symbol would not go away) and it killed my battery extremely fast. I followed some advice (to a certain point) on here and finally found the problem

    From home, menu->settings->accounts -> Google account

    Then I looked at what I had syncing and found that the SYNC CALENDAR had a rotating sync sign. Once I disabled SYNC CALENDAR the sync symbol immediately disappeared.
     
  23. doogald

    doogald Android Expert
    Rank:
     #56
    Points:
    483
    Posts:
    6,695
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,695
    1,927
    483
    Welcome to Android Forums. If you really do want to sync calendar data, I think that you can solve this for good by going into settings->applications->manage applications, find "Calendar Storage", tap it and then tap on "Clear Data". (If you do not have "Calendar Storage", then do the same on "Calendar".) Then you can re-enable Calendar Sync and I'll bet that things will be fine.
     

Share This Page

Loading...