1. Check out our companion app, Forums for Android! Download from Google Play

HELP HTC Hero and SafeMode.. ARGHHH

Discussion in 'Android Lounge' started by wes029, Jul 21, 2010.

  1. wes029

    wes029 New Member
    Thread Starter

    Jul 21, 2010
    B/CS, Texas
    Hey guys.. Okay I have been trying to get this going so many dirrent ways Im going to post what I sent to HTC.. Explains what Sprint had me do, and HTC.. Hope you guys know something they dont.. Here goes::::

    I have a Sprint HTC Hero that is right at 6months old.. Phone info. follows:
    Firmware: 2.1-update1
    Base Version:
    Kernal Version: 2.6.29-bc0d2cff
    Build Number: 2.27.651.6 CL169236
    Software Update: 2.27.651.6
    Browser Version: Webkit 3.1
    PRI Version: 1.70_003
    Hardware Version: 0002
    I brought my Hero into the Sprint store and they did a firmware update to 2.1 and ever since then in the lower left hand corner it says "Safe Mode".. We have done a shutdown, removed the battery.. did a full system recover... Powered down the unit, turned unit back on while holding "home" and"power" button and it comes up with a picture of a black phone with a red triangle with a red explanation mark in the triangle.. Only way to get past this screen is to pull the battery... All of this and it still shows "Safe Mode" at bottom left hand side of screen. I am unable to see downloaded apps under "All Programs" Only way to see the applications downloaded is to go to "Market" and then go to "Downloaded"...... Nevermind.. now I cant even load "Market" it acts like its going to load and then just brings me back to "Home" screen.. Before I could go to "Market" and then "Downloads" and see what has been downloaded, but I still could not run the apps from that point because the "Open" button was greyed out. This all started when Sprint Store updated my firmware to 2.1 ... At this point they have NO idea how to get rid on the safemode so that I may start using my applications again... ANY help greatly appreciated!!!
    2nd E-mail to HTC:

    I have tried to do a "Factory Reset" with no resolution. I first tried the: HOME > MENU and tap Settings > Security > Factory data reset > Reset phone > Erase everything.
    *** On my phone its a bit diffrent.. its as follows: Home>Menu and tap settings>Privacy>Factory Data Reset>Reset
    But it did do the rest.. but SafeMode is still at bottom lower left of screen.. So I went on to the other suggestion: With the device turned off, press and hold MENU and the


  2. pigdogs

    pigdogs New Member

    Jul 22, 2010
    I am from the UK and have a Hero on the Orange network here. I have the same problem and have been trying to figure out for days on how to fix it.
    My problem is slightly different as I have rooted my phone with a recovery image so I can boot custom roms. However, as soon as any 2.1 or 2.2 Rom is flashed to the phone, I get the same safe mode error, nothing will clear it, some good news is that you can roll back to a 1.5 rom and the phone goes back to normal.
    There are some issues with the later Orange roms where you are unable to root them, so I had to downgrade to an earlier Orange rom in order to get a recovery image. As a separate issue, there is a ""bug" in the later versions of the Orange rom that stops you from unlocking the phone, downgrading the phone to an older rom should fix this, but doing this has not allowed me to unlock the phone, so I am wondering if this issue is connected to the safe mode issue?
    I have gained root access fine, while running the 1.5 rom and am able to get to the root su by using shell in adb, so all is fine, but as soon as the phone is flashed with the custom 2.1 or 2.2 image it goes to safe mode. The 2.2 custom rom I am using comes with a superusers permissions app, but it does not bring up any options when booted and also root access is not available from a terminal emulator while the 2.2 rom is running on the phone.
    As I have said before I have been trying to fix this for days, by trying different images, downgrading the rom to the earliest rom I can find (using the gold card method) formatting the SD card and trying to get it out of safe mode using adb.

    I've been searching the internet for days to find a solution, but can only find other posts reporting the same problem with no resolution - the only thing I can think it can be is a fault on the phone, or something in the 2.1 rom that the phone does not like. Other Orange users in the UK have managed to get 2.1 and 2.2 on their phones fine, using the same procedure as me Very frustrating. I would say to you to take your phone back to the shop you got it from.

    Any help or ideas from anyone would be great.

Share This Page