1. Download our Official Android App: Forums for Android!

Support Help! HTC One M8 stuck on Fastboot screen

Discussion in 'Android Help' started by Nisy, Mar 20, 2016.

  1. Nisy

    Nisy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 20, 2016

    Mar 20, 2016
    2
    0
    5
    Female
    Hi All, need some guidance on what I can do here.
    A couple days ago I put my phone on charge and all of a sudden it turned off and wouldn't turn back on again. Googled some help and we soft bricked it (?) - held all keys down for 90 seconds - then phone turned on but was stuck on the HTC intro screen. After a while it changed to the fastboot screen and now that won't disappear:

    *** Software status: Modified ***
    *** LOCKED ***
    *** Security Warning ***
    M8_UL PVT SHIP S-ON
    HBOOT-3.19.0.0000
    RADIO-1.29.214500021.12G
    OpenDSP-V51.2.2-00593-M8974_FO.1015
    OS-6.12.980.5
    eMMC-boot 2048MB
    Dec 1 2015,18:43:39.0

    I have the options of HBOOT, RAMDUMP, REBOOT, REBOOT FASTBOOT & POWER DOWN.
    I've tried all but RAMDUMP but nothing works and they all just come back to the fastboot menu straight away.

    I'm hoping someone can give some advice or instructions on what I can do to fix, that is if it can be fixed...?!

    Thanks :)
     

    Advertisement

  2. Hadron

    Hadron  
    VIP Member
    Rank:
     #7
    Points:
    2,218
    Posts:
    22,394
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    22,394
    15,679
    2,218
    Spacecorp Test Pilot
    Dimension Jumping
    First thing: have you ever modified the software (or, if you bought it second-hand, do you know whether the previous owner had)? Because that's what the screen is telling you.

    Had you had a software update to Marshmallow (Android 6)? I'm asking because a quick web search of your OS version suggests the Optus (Australia) Marshmallow. That update should have been released in January, but I'm asking in case for some reason you hadn't received or updated it? It looks like your system software has been corrupted, and during an update is the most likely time for that to happen on a device that hasn't been rooted, which is why I'm just curious as to whether there is any possibility that the phone was updating when this happened (some US carriers force updates if you don't accept them, but I don't know whether Optus are equally scummy)?

    You can still get into the bootloader, so it's fixable. However, the obvious way of fixing it involves a ROM Update Utility (RUU), which would reload the phone software completely. Unfortunately I've not been able to find an Optus M8 RUU at all, never mind a Marshmallow one (an RUU won't let you use it to downgrade software). It may be that you need to contact your carrier, but the words "modified" and "security warning" may cause them to ask questions. That's part of why I asked the original question (the other part being that if you had modified the software then that could be related to the problem). But "locked" is unusual when a phone has been modified (you need to unlock the bootloader to modify the system software, though you can relock it afterwards).

    I'm going to sign off now, but hopefully someone else will pick this up. But what I have been wondering is whether whatever corrupted the system software is responsible for the "modified" message? But at this moment I don't know what that is.
     
  3. Nisy

    Nisy Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 20, 2016

    Mar 20, 2016
    2
    0
    5
    Female
    I bought the phone brand new from optus and I haven't modified the system. I'm not a huge tech person when it comes to mobiles so I have no idea how you would modify it to begin with.

    I do recall my phone updating to the marshmallow OS but this was maybe 3-4 weeks ago. When I put the phone on charge I didn't see anything on my screen to suggest it was updating again. It was very random how it just switched off, I haven't a clue what could possibly have corrupted it, unless it was an app or downloaded files which could have infected it??
     

Share This Page

Loading...