1. Are you ready for the Galaxy S20? Here is everything we know so far!

help i can not delete some files from SD

Discussion in 'Android Help' started by InGearX, Jul 18, 2016.

  1. InGearX

    InGearX Android Enthusiast
    Thread Starter

    please help
    help i can not delete *some* files from microSD .. just some of my movies and etc ..

    with generic or any other file manager .. tried five different ones ..

    must be some file/user permission issues
    just says

    failed to delete file
    i tried reboot
    i tried safe mode
    i think the only way is to put microSD into my PC

    i am on Galaxy Tab S2 Marsh ..

    how can i fix this?
    thank you ..
     


  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    You can check permissions in most file browsers and then choosing "details" (or something to that effect) - a long press on the filename brings up the options in most apps I've used. That should let you see who the file owner is and what the permissions are: the typical format is a string like "-rwxr--r--", which would mean "owner has read, write, execute access, members of the same user group and other users (respectively) have read only". If it starts with a "d" that means it's a directory (aka a folder).

    You'd probably need a command line (terminal) to change these, unless your file browser offers the option, and will only be able to change them if you are the owner (or have write access, but if you have write access you could delete them anyway) or if you have root access. The terminal command "chmod ugo+w" would give everyone write access ("ugo+w" means "user group other +write").

    It may be that the PC is the simplest solution though.
     
    Dannydet likes this.
Loading...

Share This Page

Loading...