1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help!! I think I killed my phone

Discussion in 'Android Devices' started by Etwizzy, Mar 9, 2016.

  1. Etwizzy

    Etwizzy Well-Known Member
    Thread Starter

    Hello I have a problem. My phone which is a sph-l710 (Sprint). Suddenly half-died over the weekend. By half died I mean my phone is active but my antenna will not teach Sprint. (Short and sweet version of what the rep told me) through digging and research I found that where my phone used to have my phone number in the about phone section of this phone it has a different number, when it used to be my number that was there. I downloaded a SIM reader and it gave the same number as about phone e.g. 0000001234. If there anything I can do to fix my antenna so I can connect back to Sprint?
     


  2. svim

    svim Extreme Android User

    On the chance your antenna just needs to be reconnected to motherboard, try prying off the connector and re-connecting it (see step 20 below). It's referred to as the WiFi connector but as far as I'm aware the cellular and the WiFi connectivity work off the same antenna:
    https://www.ifixit.com/Guide/Samsung+Galaxy+S+III+Motherboard+Replacement/12696
    That said I don't know if your problem is the antenna, sounds more like a SIM card issue. Is your WiFi access still OK and it's just a matter of cellular connectivity?
     
  3. Etwizzy

    Etwizzy Well-Known Member
    Thread Starter

    My Wi-Fi seems to be ok however right now Wi-Fi is off and I'm using my LTE network. Sometimes the Wi-Fi don't wanna work.

    P.S. where can i find one if those plastic tools for the phone?
     
    #3 Etwizzy, Mar 9, 2016
    Last edited: Mar 9, 2016
  4. mikedt

    mikedt 你好

    Ifixit.com sells them. It's called a spudger. Places that do phone repairs should have them as well.
     
  5. svim

    svim Extreme Android User

    A tool like a spudger is nice but in a pinch you can also use a guitar pic or use the corner of a credit card. You just need something that's a thin, non-conductive, flexible piece of plastic.

    If your LTE is working I have to wonder if your phone's antenna is the source of your problem. Have you tried booting up your S3 in Safe Mode to see if some random app is screwing with your connectivity?
    http://www.basictechtricks.com/2013/07/samsung-galaxy-s3-safe-mode.html
    You might also want to clear the system cache partition.
    https://www.androidpit.com/how-to-clear-cache-galaxy-s3
     
    #5 svim, Mar 10, 2016
    Last edited: Mar 10, 2016
  6. Etwizzy

    Etwizzy Well-Known Member
    Thread Starter

    Thanks for all the help. I got the s7 edge today. I still wanna fix this and keep it as a backup
     
Loading...
Similar Threads - Help killed phone
  1. Brian Foster
    Replies:
    0
    Views:
    1
  2. taylorr423
    Replies:
    3
    Views:
    152
  3. Deepak SJ
    Replies:
    1
    Views:
    201
  4. Jimmy Luong
    Replies:
    4
    Views:
    322
  5. lonelykitten91
    Replies:
    9
    Views:
    354
  6. SRT GmbH
    Replies:
    1
    Views:
    155
  7. HuaweiY7Pro2019_Tyong
    Replies:
    4
    Views:
    305
  8. yasuo1738
    Replies:
    0
    Views:
    150
  9. Ruleej32
    Replies:
    0
    Views:
    130
  10. spman
    Replies:
    18
    Views:
    392

Share This Page

Loading...