1. Download our Official Android App: Forums for Android!

Support HELP! In-app internet access stopped working!

Discussion in 'Android Devices' started by InfiniteImp, Aug 12, 2011.

  1. InfiniteImp

    InfiniteImp Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Aug 22, 2010

    Aug 22, 2010
    3
    0
    15
    Toronto, ON
    I've got the strangest problem with my Xperia Arc. A few days ago I seem to have lost in-app internet access, but ONLY in HSPA mode; WiFi connections work fine. So, apps which need to access the internet can't do it as long as I'm using the cellular connection. If I connect WiFi, all apps work fine.

    Now the stranger thing is, I can access the internet itself just fine while on HSPA, same with emails, SMS, etc. The problem is only with the apps which need to access the internet (weather widget, market, streaming radio player, etc. This happened a couple of days ago. Worked perfectly for weeks before that (since I got the phone). No idea as to the cause; it's like something is blocking apps only from internet access and only while using the carrier's HPSA. Again, everything is fine if I connect in WiFi mode.

    Here are the particulars:
    Xperia Arc, unlocked and debranded (stock SE firmware 3.0.1.A.0.145)
    Android version 2.3.3
    Running on the Telus network (Ontario, Canada) - The phone was originally locked to the Rogers network.
    APN set correctly

    I did a bunch of research as to people who couldn't access the market with their 3G connection (I'm not on 3G but same principle I presume), cleared caches, cleared data for the market and other apps, shut down and restarted the phone, etc. In short, anything which others said worked for them. In any case, as I found out later, it's not just a Market issue, rather any app which tries to access the net.

    Any help would be greatly appreciated. I'm out of ideas.
     

    Advertisement

Share This Page

Loading...