1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help? "Incompatible with your device" & "cannot be installed in your device's country"

Discussion in 'Android Apps & Games' started by YukaCava, Apr 20, 2012.

  1. YukaCava

    YukaCava Guest
    Thread Starter

    My cellphone is Samsung Galaxy Mini S5570 with Gingerbread 2.3 as the operating system. So recently, I've just downloaded two ".apk" files because market won't allow me to download the application.

    It's "Cotto - Fashion up your Photo" which is not compatible with my device.
    and
    "DECOPIC,KawaiiPhotoEditingApp" which is cannot be installed in my device's country.

    I tried to install the ".apk" file but It won't install. It always end up as "application not installed"

    The other ".apk" files which I have downloaded before with the same problem works just fine when I tried to install them. But not these 2 files.

    I wonder if there's any solution to this problem?

    Thank you very much :)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. chanchan05

    chanchan05 The Doctor

    Have no idea for DecoPic, but Cotto is not compatible with your device because of hardware restrictions. Think of it this way: Cotto can't run on your phone for the same reason why Skyrim can't run on an HP Mini: Your phone isn't powerful enough.
     
Loading...

Share This Page

Loading...