1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help needed installing stock 2.2 on Vodafone Desire with HBoot 0.83

Discussion in 'Android Devices' started by l0gan5, Aug 11, 2010.

  1. l0gan5

    l0gan5 Newbie
    Thread Starter

    Hi all,

    sorry to trouble you, I have had a look through a number of threads but would like advise before proceeding further.

    My goal is to take my one-week old Vodafone Desire running and HBoot 0.83 and update it with stock Froyo.

    I began following the instructions here:


    and began the instructions for rooting the phone:

    [ROOT] Method for HBOOT 0.83 (SLCD phones) - xda-developers

    I got as far as Unrevoked telling me it had installed the ClockWorkMod and that my phone should reboot in recovery mode, however at this point the phone did nothing, just sat there with a black screen. I pulled the battery and the phone restarted as normal but I cannot see any reference to ClockWorkMod when I switch on holding volume down and power ?

    As far as I can tell I have root access as I can SU using Terminal, Titanium Backup installed ok and there is a SuperUser Permission app in All Programs.

    But I'm not sure where to go from here ?

    Also how do I tell whether my phone has Amoled or SLCD ? It's a UK model.


  2. teppic74

    teppic74 Android Enthusiast

    See this thread for some info:

    [FAQ] HBOOT 0.83 / SLCD - rooting and recovery - xda-developers

    Vodafone has said that the froyo update will not be branded, and will be out in a week or two, so you may want to wait.

    You have SLCD because of the black screen on recovery.

    edit: although since you have rooted, you probably won't get the update OTA now.
  3. l0gan5

    l0gan5 Newbie
    Thread Starter

    Thanks Teppic74,

    Still not sure what I should be doing next ?

  4. teppic74

    teppic74 Android Enthusiast

    If you want to install a custom ROM (like pre-rooted official froyo), you just need to reinstall unrevoked3 with the updated image contained in that FAQ. That will fix the black screen.

    It's difficult for you to install the official unbranded software because of your software version (which means you cannot upgrade to froyo OTA), so this is your best option.
  5. teppic74

    teppic74 Android Enthusiast

  6. l0gan5

    l0gan5 Newbie
    Thread Starter

    Sorry Teppic,

    I am completely stuck - I can't seem to get into recovery mode (or I can't see what I am doing!)

    I found this thread:

    [SLCD-BRICK] Fix is here! - xda-developers

    Not sure if I've messed things up installing ClockworkMod ?


    PS. Should probably have done more research but hey, you can't beat a bit of baptism by fire sometimes ;-)
  7. teppic74

    teppic74 Android Enthusiast

    As I said above, you just need to reinstall unrevoked3 with an updated image. Your phone isn't bricked.
  8. l0gan5

    l0gan5 Newbie
    Thread Starter

    Hi Teppic,

    Thanks for your patience! I'm sure it'll become second nature eventually ;-)

    OK, I have done the Unrevoked3 again which worked!

    I popped the pre-rooted Froyo zip on the card, installed it and voila, we're there :D

    Software is now showing 2.09.405.8.

    It feels incredibly fast too.

  9. anadroida

    anadroida Lurker

    l0gan5, how did you get it to work? Whenever I try unrevoked3 I get the same result as you mention in your first post - the screen just switches off & I have to remove the battery to reboot... :mad:

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page