1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help needed with app update

Discussion in 'Android Devices' started by turts11, May 19, 2011.

  1. turts11

    turts11 Newbie
    Thread Starter

    Hi,

    For some unknown reason every time i try and update Angry Birds Rio from the market place, my phone wont let me. It downloads 100% then i get a message saying cant download, try again.

    I've tried several times today, tried everything i can think of. I've turned the phone off and on, moved the app from the SD card and tried, then moved it back again and tried again. Still nothing. My mate has managed to download it on the same phone, HTC Deisre 2.2 on the same Vodafone network.

    Any ideas on how i can get this to work would be brilliant, many thanks in advance!!:mad:
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ajh94

    ajh94 Android Expert

    I'm also having this... I tried to do it over Wi-Fi just a minute ago - Also BTFON and Flash Player 10.3 won't update :/ Seems very wierd
     
  3. turts11

    turts11 Newbie
    Thread Starter

    IF, I ever find out why, or manage to figure it out myself i'll let you know. One of the strangest things i've come across on here though.:mad:
     
  4. SUroot

    SUroot Extreme Android User

    You must have enough free space in the /cache partition for the app to download. One thing to check is download "quick system info" and see if the free space is smaller than the app.
     
  5. turts11

    turts11 Newbie
    Thread Starter

    I've got loads of room on my phone, nearly 28mb free and 3.4gb on my SD card. Ive cleared my cache down and still no luck. There must be sime valud reason, Ive also tried on WiFi and on Vodafone network. I really am at a loss to figure it out!
     
  6. SUroot

    SUroot Extreme Android User

    I think you misread my post. Please read it again and follow the steps I said. Then feedback please. Thanks
     
    turts11 likes this.
  7. turts11

    turts11 Newbie
    Thread Starter

    Sorry, just done what you said, and yes the system cache free is 2mb lower than the app I want to download. I know Im proper stupid, but how do I clear this down and create enough room?

    Many thanks for your help!
     
  8. SUroot

    SUroot Extreme Android User

    Are you rooted?
     
  9. turts11

    turts11 Newbie
    Thread Starter

    No, not rooted sorry.
     
  10. SUroot

    SUroot Extreme Android User

    Hmm. I know how to do it on a rooted phone. I'm not sure it will work using adb on an unrooted phone, but you can try it.

    Firstly follow the red link in my sig to locate the adb & fastboot FAQ.

    Follow it to set up adb on your PC>

    Boot into recovery on your phone (from off, vol down+power, then highlight recovery using volume and select using power. Then Vol up + power. connect to PC using USB).

    Then get into adb shell (explained in FAQ)

    then the following command:

    mount /cache

    followed by

    rm -r /cache/download/*

    I honestly dont know if this will work without root. I'm guessing not, but since I havent got an unrooted desire to test on, I cannot be 100%

    Other than this I really cant think.

    The only thing I know for sure that will erase cache is a factory reset.

    You could always download visionary+ (google it) and temp root your desire (lost at reboot, doesn't affect warranty) then do a full backup with titanium backup. Then reset the phone, temp root again and titanium restore. That way you lose no data or anything...

    Its a tricky position to be in.
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...