Help HELP! Phone won't flash!

irishjoeyo

Android Enthusiast
I have a Bell Galaxy S Vibrant/GT-I9000M from Canada. It is stuck in an endless loop where it shows the "GALAXY S GT-I9000M SAMSUNG" black & white screen. It simply keeps flashing and I have to pull the battery.

I have tried flashing it with several different USA ROMS from samfirmware.com because they don't have any listed for Canada. From what ODIN shows, everything goes through fine. The first box above the COM port turns green and says "Pass!" and the process box toward the bottom shows "Complete". Immediately after that point, the endless loop occurs that I described above.

I can get the phone into Download mode just fine, but not into Recovery mode. I have tried flashing it on two different Windows 7 computers both with and without the PIT file and with and without the "Re-Partition" box checked, all with the same results.

Is this phone truly bricked? I am at a loss for what to try next. :(
 

irishjoeyo

Android Enthusiast
Thread starter
Anyone else have any ideas? Can anyone confirm if this means that this phone is permanently useless?

Anyone have a Canadian ROM for the GT-I9000M that I could try loading?
 

Shine.

Well-Known Member
Chances are your internal sd card has died! i9000M phones are bad for that! mine died couple weeks ago and had to replacee it! but i hope yours isnt, Best of luck!
 

irishjoeyo

Android Enthusiast
Thread starter
I'm not entirely convinced that it's gone bad. After all, when I load the ROM in Download mode, I get the blue bar going across the screen on my phone's display. In addition to that, my computer recognizes my phone and it shows up in Device Manager. ADB, however, says "device not found".
 
Top