1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Help! Rooted Evo won't reboot.

Discussion in 'Android Devices' started by MongooseGA, Feb 21, 2011.

  1. MongooseGA

    MongooseGA Member
    Thread Starter

    Hey all,

    My Evo is rooted, running the new Mikfroyo 4.5 and a Netarchy 4.3.1 cfs-havs-nosbc-universal kernel.

    I just purchased and downloaded SetCPU from the market, and while playing with the settings, the screen froze while running the app. Powering off with the power button did nothing, so I pulled the battery and powered back up.

    The phone is stuck on the initial "HTC EVO 4G" splash screen. I pulled the battery again and tried to reboot into recovery. Still no dice.

    So The screen has been stuck for about 10 minutes as of my last attempt and it's getting sort of irritating. Any advice?

    Thanks in advance,

    G.A.
     

    Advertisement

  2. akazabam

    akazabam Android Expert

    So what happens when you try going to recovery? Does it just get stuck at the splash screen, then, as well? What did you do in setcpu? It sounds like you probably tried to set the max too high. I assume you can get to hboot, correct? What is your hboot version?
     
  3. MongooseGA

    MongooseGA Member
    Thread Starter

    The phone did boot into recovery. I couldn't tell you which hboot version I have. Would Bootloader be the answer to that? I'm still a novice with everything.

    After I went to bed last night I ended up playing with the phone some more. I eventually reflashed the Mik4.5 rom and the phone booted up. Now the problem is, the phone won't scan for wifi devices. I can turn wifi on, but once it realizes that it cannot find sources, it shuts wifi off.

    I remember that I did not properly wipe my delvik cache when I flashed the netarchy kernel. Is it possible that this is causing my newfound wifi issue? Partition and delvik caches have all since been wiped as I've also reflashed the kernel through recovery.
     
  4. MongooseGA

    MongooseGA Member
    Thread Starter

    Update: I just reflashed to an earlier backup of mikfroyo that I had and everything works fine now. Don't know what the difference was.
     
  5. akazabam

    akazabam Android Expert

    Okay, you weren't in as bad of a situation as I originally thought based on your original description. Good job getting things back to normal on your own :). Here's the thing with setcpu - if you set the max to high, your phone won't be able to handle it. I suggest going no higher than 1152, but some can get away with 1190. When testing the max, *never* leave "set at boot" checked, or you'll be in trouble. In any case, just remember to be careful.

    That being said, Sometimes reflashing the ROM works, sometimes it doesn't. It's exactly what I would have told you to do if I'd known you could get to recovery. As you still had problems, you did the correct thing by restoring a nandroid backup. Likely, your problem was not due to not wiping dalvik cache. Yes, that will cause issues, but not like that. Something probably just got corrupted in /data that reflashing the ROM couldn't fix. Just remember to always make a nandroid backup before messing with something like setcpu or any mods.

    It's irrelevant now, but to find hboot version, turn the phone off then turn it back on while pressing volume down. You'll see your hboot version there. Likely, you have hboot 2.10.
     
  6. autorail1

    autorail1 Android Enthusiast

    Sounds Like you Set the Speed to High and also had it checked mark to remember on reboot. Dont check that box in the center of the screen until you know it works or it will keep booting to the Clock speed and crash (loop)
     
  7. -Ax-

    -Ax- Lurker

    "if you set the max to high, your phone won't be able to handle it. I suggest going no higher than 1152, but some can get away with 1190. "

    I have SetCPU and the app's max clock speed is 1113... ?
     
  8. akazabam

    akazabam Android Expert

    The min/max allowed frequency is set by the kernel. I'm sure you've noticed the stock kernel can go no higher than 998. It's the same with custom kernels. They aren't all the same. It has to be allowed by the developer. Setcpu will only allow you to use what is set in the kernel. Which kernel are you using?
     
Loading...
Tags:

Share This Page

Loading...