Root help rooting with superoneclick


Hi I'm trying to root my phone thts running froyo using superoneclick, I have all the drivers installed to do so and I put my phone into debugging and do NOT mount thee sd card, I open up the superoneclick exe and choose rageagainstthecage and click root, it kills the adb then starts it up then waits for phone and then starts to push rageagainstthecage but then it says running rageagainstthecage then tells me IF IT KEEPS LOOPING DISABLE USB DEBUGGING NOW and then from there it starts to loop but can't find my phone when it says waiting for device again. What's wrong? I've tried to disable usb debugging when it does that but nothing happens and I can't get it to root, thanks


Well-Known Member
Just follow the guide that's stickied here....getting root on 2.2.1 without fastboot isnt a great idea, and the devs here dont support it and may not help if you have problems.
Sorry...its not stickied, but its only a few threads down from way to do it


Android Enthusiast

i bought a dell xcd28
i tried to root the phone using superone click (latest version)
after following all the procedures, i got a msg tht my phone was sooted successfully
i even noticed the super user app on the phone

but when i try to install applications like wifi thether or titanium backup
it says tht my phone is not rooted, the SU doesnt pop up so tht i can grant permissions

how do i root the phone manually??

You're in the wrong forums for that can tell you more about your question than most of the people in this forum.