1. Download our Official Android App: Forums for Android!

Support Help SMS notification won't go away!

Discussion in 'Android Devices' started by atech087, Apr 1, 2013.

  1. atech087

    atech087 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Apr 1, 2013

    Apr 1, 2013
    4
    0
    25
    I got a text and i deleted it. The yellow messaging thing in the notification bar is still showing up but when i tap it, it takes me to the new message screen and says "You have entered an invalid adress". I clear the notification but whenever i tap on the messages it shows up again. The messaging thing on the bottom of the home screen has a yellow 1 by it. (See link Help with phone - Imgur ). Someone please help me!

     

    Advertisement

  2. Atma

    Atma Extreme Android User
    Rank:
    None
    Points:
    533
    Posts:
    6,069
    Joined:
    Dec 26, 2011

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Hi atech. Try this, Settings > Application Manager > All > Messaging > Clear data.
     
  3. atech087

    atech087 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Apr 1, 2013

    Apr 1, 2013
    4
    0
    25
    Hi I tried that and it worked until i got another message then the problem came right back.. Any other ideas?
     
  4. Atma

    Atma Extreme Android User
    Rank:
    None
    Points:
    533
    Posts:
    6,069
    Joined:
    Dec 26, 2011

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    Hey atech. Here's another fix I saw you might try.

    go to settings> developer options>and uncheck (do not keep activities) this must be unchecked, and also make sure limit background processes is set to standard.

    And another..

    Go to your message inbox, press the menu key, and go to settings. Look for "Manage SIM card messages", if there are any messages here, delete them. If that does not work, under message settings uncheck notification, and power off the phone for a few minutes.

    One more..

    Send a message to a landline. You'll get an error popup, open that message and if there is another message inside of it, delete.

    Lastly, try Handcent and disable your stock message app.
     
    dan55 likes this.
  5. atech087

    atech087 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Apr 1, 2013

    Apr 1, 2013
    4
    0
    25
    1.Hey i can't find the first option. I have developer options but no option for that.

    2. There is no messages in the SIM card. I disabled the notifications, turned off my phone, took the battery and the SIM card out. Turned back on in 5 minutes and then re enabled the notifications and it was back.

    3. I sent a message to a landline but got no error message back.

    4. I don't want to replace my messaging client.

    This is getting really annoying and idk why it is doing this. I contacted t-mobile support and they said they didn't know anything. Any other ideas?
     
  6. Atma

    Atma Extreme Android User
    Rank:
    None
    Points:
    533
    Posts:
    6,069
    Joined:
    Dec 26, 2011

    Dec 26, 2011
    6,069
    2,901
    533
    Male
    Survival
    North Carolina
    No, I'm sorry. That's about all the 'fixes' I could find. I'd say try a factory reset but I've seen others say that didn't help either.

    Only thing I can suggest is try Handcent, which is supposed to be much better than the stock app, or Go SMS.
     
  7. lbpoapres

    lbpoapres Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 10, 2013

    May 10, 2013
    1
    0
    5
    i was having the same problem and i just went into settings...application...then to skyvi...i unchecked the notification box on that app and it seems to have fixed the problem. The other thing i have found is that if i read and respond to a message through syvi then the alert wont go away. If i go through messaging now that i have unchecked the notification box in skyvi it appears to be working. I dont know if this will work for you or not, but good luck.

    update...i uninstalled skyvi and have not had the problem since.
     
  8. LogCx

    LogCx Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    1
    0
    5
    its the same problem i experienced i tried many ways many!! but none worked my phone is also a very shitty so there was no info available about it on the net,
    to solve this i
    1. installed the pc suite for my phone
    2. checked out the messages and deleted all of em but the "1" was still there so
    from the pc suite i refreshed the message app for 5 times and then suddenly a mssage appeared which was cozing the prob

    hope it helps
     
  9. 805serg

    805serg Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 29, 2014

    Jan 29, 2014
    1
    0
    5
    Only solution is to factory reset. i had to. All ur downloads are erased but glitch should be gone :)
     
  10. casawyer

    casawyer Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 27, 2014

    Sep 27, 2014
    1
    0
    5
    Found this: I was having this problem after a bunch of Facebook SMS messages hit my phone at the same time, jammed it up, and one of them got stuck in my notification bar. No mater what I did, I couldn't get rid of it.


    What you need to do is install "SMS Cleaner Free" by Carrot App Install and scan and delete messages.
    p { margin-bottom: 0.
     
  11. Mel Low

    Mel Low Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 22, 2015

    Jul 22, 2015
    1
    0
    5
    Female
    If you have removed your battery etc. and the date has reset to factory setting, I found I could not remove text message alert. By trial and error I found if, after you have reset the correct date and time in your main settings, you open your messages and scroll to the bottom (to oldest texts) you will see those messages that the alert is telling you are unread. You have to delete just those and it clears the alert. If your date and time was already correct not sure if this method works - but worth scrolling to the bottom of texts? No installs, no deletion of everything!
     
  12. Charcoal skull

    Rank:
    None
    Points:
    26
    Posts:
    1
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    1
    2
    26
    Male
    Hey. I just fixed this problem easily...

    1: Open your messages, and open the drop menu that gives you all the options. Click settings in that menu. Change the default sms to "hangouts".

    2: scroll to the bottom of "hangouts" and find the message that wasn't opened and read and open it and then delete it.

    3: open that settings menu again and change the message device back to your desired one. Problem solved.
     
    Bee2 and TheOtherPD like this.
  13. dan55

    dan55 Android Expert
    Rank:
     #74
    Points:
    263
    Posts:
    3,075
    Joined:
    Oct 23, 2010

    Oct 23, 2010
    3,075
    322
    263
    hi - ive just started getting this issue too with new but read sms - I found that option which is currently turned off as standard - so do I need to turn it on to clear the stuck notifications?

    .....will it start killing off background apps? :/

    many thanks
    dan
     
  14. TheOtherPD

    TheOtherPD Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 2, 2016

    Jul 2, 2016
    1
    0
    5
    Female
    Charcoal Skull's answer solved my prob. but I have an older version, I guess, so mine went a little different. So for people with older versions, here's what I did (based on Charcoal Skull's solution):

    >go to messages
    >go to options
    >click "folder view"
    >search for the message you deleted before reading, it should be there.
    >delete the message
    >then you have the option to either stay in the folder view, or you can click on options and click "message view" to return to your default view.

    Thanks Charcoal Skull!
     
    #14 TheOtherPD, Jul 2, 2016
    Last edited: Jul 2, 2016
  15. LazyDawgNC

    LazyDawgNC Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jul 16, 2016

    Jul 16, 2016
    1
    0
    15
    Male
    This started happening to me after linking Facebook messenger to my SMS. I would clear notifications and reboot. Gone. But the next time is send amsg boom is back again. I uninstalled fb msgr, still stuck. I noticed when trying to add a priority sender that he had a two icon over his photo. He had sent me some msmgs on fb but then i detached it from sms so they got stuck. I went to my messages app and selected mark all read and it finally went away.
     
  16. obtuce

    obtuce Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    6
    0
    5
     
  17. obtuce

    obtuce Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Feb 28, 2011

    Feb 28, 2011
    6
    0
    5
    I had a similar issue with my text notifications. I kept getting a notification for a text I had deleted. After weeks of deleting it and have it pop back up I looked looked and found that I had 2 messaging apps installed. A Verizon one and the one ive used for years. The 2 were always in sink before. But for some reason only on this text message it wasnt. It wasnt deleted from my Verizon messaging. I deleted it there too and my problem was fixed.
     
  18. Bee2

    Bee2 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 11, 2017

    Jan 11, 2017
    1
    0
    5
    Female
    I had the same problem and this worked for me! :) Thank you!
     

Share This Page

Loading...