1. Are you ready for the Galaxy S20? Here is everything we know so far!

HELP! Stuck in the "Downloading.. do not turn off target" Screen

Discussion in 'Android Devices' started by kentamayo, Aug 11, 2010.

  1. kentamayo

    kentamayo Newbie
    Thread Starter

    Was updating my SGS when it got stuck on the screen where Android is digging in the dirt and says Downloading... do no turn off target.

    Windows is also giving me an error "The Program can't start because RAPI.dll is missing from your compter. Try Reinstalling the program to fix this problem"

    I tried reinstalling Kies but nothing happens.... Why oh why couldn't Samsung have just let us update OTA..... [sigh]

  2. karnka

    karnka Android Expert

    There's an update in Kies????

    Anyone else heard about this?
  3. kentamayo

    kentamayo Newbie
    Thread Starter

    Yes, you can update your firmware through Kies.
  4. karnka

    karnka Android Expert

    I was aware that Kies was the delivery mechanism but there has been no word on Samsung releasing a new firmware via it yet to my knowledge.

    Do you know what exactly has been made available?
  5. kentamayo

    kentamayo Newbie
    Thread Starter

    Oh, my apologies.. I was on J4 on my way up to J5, and now it's stuck on that screen... this never happened to me on my previous Android units.
  6. karnka

    karnka Android Expert

    Ah, not exciting then and most likely not available in Europe.

    Sorry I have no help to offer with your actual problem!

    OTA would have been nice, yes.
  7. kentamayo

    kentamayo Newbie
    Thread Starter

    Can anybody help? I can't get it out of download mode, even Odin doesn't recognize it
  8. koolduud

    koolduud Newbie

    Reboot it with the switch on/off button - press for 10 seconds (or may be longer).

    For the RAPI.dll problem

    for windows 7 (and probably for vista also):

    The .dll error was solved by an italian user called manuel_84. Here it is:

    Go to --> C:\Users\[YourUsername]\AppData\Local\Temp\KiesInstall\CabFile\OsDependent\[Vista/XP]\Program Files\Common Files\Samsung\DeviceService
    Copy the two .cab files and paste them on your desktop. Click two times on them and take the .dll files inner them. So, paste only the two .dll files in the Kies installation Path (C:\Program Files \Samsung\Kies\)

    Now it should work

    better to put in these folders also
    program files/samsung/Usb drivers
    program files/common files/Samsung/DeviceService

    for xp:

    I had this same problem and the solution that I found on another forum is:

    • Open the following folder:
      "program files/common files/Samsung/DeviceService"
    • Search for _rapi.dll and _ceutil.dll and copy to desktop
    • Rename the dlls removing the "_"
    • Drop the "rapi.dll" and "ceutil.dll" (renamed) into following folders:
      program files/samsung/Kies
      program files/samsung/Usb drivers
      program files/common files/Samsung/DeviceService

    It worked for me
  9. kentamayo

    kentamayo Newbie
    Thread Starter

    Thanks for the help, solved the Download screen by yanking the battery out for a few seconds and the reinserting it. Will try the DLL patch tomorrow.
  10. guccimane07

    guccimane07 Lurker

    how do you take the battery out of the fascinate
  11. jsthil

    jsthil Lurker

    I'm having the same issue with my Captivate. Have you found a solution?
  12. Leap

    Leap Lurker

    I'm having the same problem on my Galaxy TAB but cant remove the battery
  13. Markkus

    Markkus Lurker

    @Leap: did you ever solve this on the Galaxy Tab? I'm having the same problem. Thanks.
  14. kn0t

    kn0t Newbie

    I had the same Issue and I was afraid to try and reboot it, I eventually got sick of it and did just that. I held in the power button until it shut off, I wait bout 30 seconds, the turned it back on. It came right back up for me.. Oh and for those that said do a battery pull, that's a great Idea but on my tablet, You can't take the battery out. Kinda like the I-phone in that aspect. Does any of yours come apart so you can pull the battery? I have the Tmobile Galaxy Tablet SGH-T849 .
  15. snapper.fishes

    snapper.fishes Android Expert

    We have a tablet section. Use that.
  16. kn0t

    kn0t Newbie

    Sorry about that snapper. I made an error and thought this was for tablets. Lol. My apologies all around. Thanks for telling me.. excuse me while I insert my foot in my mouth. I feel so stupid. Lol. :eek:
  17. snapper.fishes

    snapper.fishes Android Expert

    I want a photo of that. XD I can't even lick my foot~
    kn0t likes this.
  18. seepage

    seepage Android Enthusiast

    We also have a captivate section.
    And a fascinate section.
    And many other sections just have a look.
  19. seepage

    seepage Android Enthusiast

    Dont feel bad about it, half the people here are on the wrong forum.
    kn0t likes this.
  20. seepage

    seepage Android Enthusiast

    How do yo know?
  21. kn0t

    kn0t Newbie

  22. snapper.fishes

    snapper.fishes Android Expert

    You mean you never tried? Isn't it just one of those things that you just have to test?
  23. KimJo

    KimJo Lurker

  24. abdane

    abdane Newbie

    *** PLEASE HELP ***
    i was shocked when the odin said FAIL! in red and i didnt know what to do... so i removed the bettery... and now everytime i try to turn on my phone i just see a picture (mobile)--!--(PC), which means a connection with PC interrupted or smthn... but now i cant turn on the phone ! HELP PLEASE ! :'(

    oh and i tried that on my SGS2 not 1 ! i really hope i didnt do it and i really hope that it does have a solution :(
  25. p0tt3r01

    p0tt3r01 Lurker

    firmware update said FAIL! in red and i didnt know what to do... so i removed the bettery... and now everytime i try to turn on my phone i just see a picture (mobile)--!--(PC), now i cant turn on the phone ! HELP PLEASE !

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page