1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help to disable Search button

Discussion in 'Android Devices' started by 6a6ka, Dec 21, 2012.

  1. 6a6ka

    6a6ka Newbie
    Thread Starter

    Can someone help me to completely disable Search button on my Evo V 4g ?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. OverByter

    OverByter Resident Slide Rule Guru

    I'm not aware of any way to do this, even with a custom rom, what issues are you having?
     
  3. 6a6ka

    6a6ka Newbie
    Thread Starter

    Accidental press kicks me out of the game I play.
    Plus it generally annoys me
     
  4. davidmargolin

    davidmargolin Android Expert

    pa and other cm based roms should have an option to disable hardware buttons.. but need s-off for that
     
  5. Leslie Ann

    Leslie Ann Android Expert

    The easiest way is to delete Googlequicksearchbox.apk from system/apps. This is what I did to stop myself from constantly hitting it.

    Otherwise you have to go edit the button config, which means figuring out which one it is. There may be an app to help though, but just deleting that one file takes care of it.
     
    6a6ka and Ranhead like this.
  6. 6a6ka

    6a6ka Newbie
    Thread Starter

    I am running MidnightRom Sensless , S-off
     
  7. davidmargolin

    davidmargolin Android Expert

    and i know exactly what you mean...
    not sure why its the search button for you,
    i keep hitting the home button
    but i recently got myself a nice case and it gives raised egdes
    meaning i end up hitting the buttons much less..
     
    6a6ka likes this.
  8. ramjet73

    ramjet73 Android Expert

    You could try the ButtonRemapper app.

    I haven't installed it but I know some people have used it successfully on the Evo 3D.

    Edit: You might have to map it to something else because I don't see a setting to disable a button.
    Or you could try this.

    ramjet73
     
    6a6ka likes this.
  9. RG570

    RG570 Newbie

    I used app quarantine ,and just locked google search , now if i hit the button theres no response
     
    6a6ka likes this.
  10. 6a6ka

    6a6ka Newbie
    Thread Starter

    Thx , but I managed to stop " google search " in - manage aps / all menu
    That stopped google serch coming up when pressing search button.

    Deleting googlequicksearchbox.apk didnt work , system is not allowing me to delete it.

    Also tried editing any possible file in system/usr folder ... changing SEARCH to GRAVE , adding " # " infront of 217 SEARCH , etc ... didnt help , unless anyone knows specific method for HTC Evo V 4g , I dont know how to do this .

    Anyways thx all for advises. So far disabling worked half way .
     
  11. Leslie Ann

    Leslie Ann Android Expert

    Never had an issue doing it with Es File Manager. Done it many times.
     
    6a6ka likes this.
  12. johnvansavage

    johnvansavage Member

    make sure to set root in es file manager settings, and also tick the mount system as writable too if you want to delete or edit systems things, just be carefull with that option
     
    6a6ka likes this.
  13. 6a6ka

    6a6ka Newbie
    Thread Starter

    I think i did everything u said and it worked ( deleted the app ) but when i hold search button voice search comes up , I would like to lose that too
     
  14. Tejer

    Tejer Android Enthusiast

    You can just disable voice search through the app sections of Android. Just go to the 'all apps' section, find Voice search, then where uninstall would be there will be a 'disable' button. Just hit that and it's practically off your system and search button wont use it anymore :)
     
    6a6ka likes this.
  15. 6a6ka

    6a6ka Newbie
    Thread Starter

    yeah I understand , but I need to use voice search at some points , just not by pressing the hardware button
     
Loading...

Share This Page

Loading...