1. Download our Official Android App: Forums for Android!

General Help: UK 3G Issue with Three

Discussion in 'Android Devices' started by dpcthomas, Jan 9, 2013.

  1. dpcthomas

    dpcthomas Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 9, 2013

    Jan 9, 2013
    1
    0
    5
    Hi, I'm new to this forum but having some issues with my 3G connection.

    I went with 3 for my network with the Nexus as they offer unlimited internet and tethering as standard which I was going to use more with the Nexus than my old phone. However since getting the Nexus home although the 3G absolutely works the speeds I'm getting are rubbish.
    Speedtest.net app is showing about 250kb/s whereas on my old HTC Desire HD on EE i was getting up to 5mb/s.

    This isn't just in my house it is out and about, is there any chance I may have a hardwear issue or is this just the network? Three say i should have good signal and the phone is showing full HSPDA signal...

    Anyone able to help?!

    Otherwise thoroughly enjoying my first Nexus device :D
     

    Advertisement

  2. steslatt

    steslatt Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,145
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    1,145
    303
    163
    Male
    Design Engineer
    Manchester
    Only way to check would be to try the 3 sim in another phone see what speeds you get.
     
  3. MartinS

    MartinS Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    2,109
    Joined:
    Aug 23, 2009

    I can confirm (as you already know) that something is not right.

    I'm on O2 UK and the N4 is on HSPA 10 and I got between 5600 and 6200 Kbps in 3 tests just now.

    At least I can confirm that the N4 is capable of decent speeds on UK networks.

    EDIT:

    This maybe nothing but for some reason my N4 had defaulted to Tesco UK in the APNs, it may be worth checking that these are set up correctly.
     
Tags:

Share This Page

Loading...