1. Download our Official Android App: Forums for Android!

Support HELP!...Wi-Fi disconnects my Network?

Discussion in 'Android Devices' started by TheRobster, Sep 13, 2011.

  1. TheRobster

    TheRobster Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    53
    Joined:
    Sep 12, 2011

    Sep 12, 2011
    53
    4
    16
    Hi all.

    Another (stupid?) question from a newbie!

    I have just got my new SGS2, and I am slowly learning all about android, which is great.

    HOWEVER. Last night I noticed something quite weird & worrying......

    I have set-up my S2 with my home Wi-Fi and it works well. But, I then noticed whilst connected to the wifi, I had no indications on the top bar of any network (3,3g,E,H etc) but I had 3-4 bar of signal strength.

    On looking in Settings>About phone>Status, the Mobile network state said "disconnected" (or similar). I tried ringing my mobile from my home phone, but couldnt. I then turned wi-fi off via the green illuminated button on the top drop down menu, and immediately the mobile network state changed to "Connected". I then got an H or E or 3 indicated at the top, and was able to receive a call.

    So, it appears that when my S2 is connected with my home wi-fi, it disconnects my network?

    Can anybody shed any light on this matter?

    Many thanks

    The Robster
     

    Advertisement

  2. Hawker

    Hawker Android Expert
    Rank:
     #49
    Points:
    433
    Posts:
    4,096
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,096
    1,911
    433
    Male
    UK
    If you are connected wirelessly, then you wont see 3G Etc. on the top unless you go into maps or some similar navigation app. Yor mobile network state WILL say disconnected, meaning you are not actively using a data connection.

    Can you connect to the internet while you are connected wirelessly?

    As for you not being able to receive calls,go to menu>about phone>status
    what are your settings under Network, Signal strength, Mobile network type and Service State
    Check Network mode is set to GSM/WCDMA (Auto mode) in Menu>Settings>Wireless and network>mobile networks

    Also make sure you dont have flight mode ticked
     
    TheRobster likes this.
  3. TheRobster

    TheRobster Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    53
    Joined:
    Sep 12, 2011

    Sep 12, 2011
    53
    4
    16
    D'oh! How stupid do I feel?.......
    Just got home & everything is working fine :)
    It just must have been a chance that the signal dropped last night briefly so I couldnt make or receive calls, and I assumed it was a wi-fi connection problem due to seeing the "Disconnected" status.
    Now I am connected to wifi, I have the following:-
    Network= Vodafone
    Signal Strength = -97dBm
    Mobile network type = GPRS
    Service state = In service

    Thanks for your help, and sorry for wasting your time :)
     

Share This Page

Loading...