1. Check out our companion app, Forums for Android! Download from Google Play

HELP with acer android liquid e

Discussion in 'Android Devices' started by CollyWolly, Nov 26, 2011.

  1. CollyWolly

    CollyWolly New Member
    Thread Starter

    Nov 26, 2011
    I have an acer android liquid e that has been working fine up until now. When I try and use my phone the following message appears:

    The application Launcher (process com.android.launcher2) has stopped unexpectedly. Please try again.
    Force close

    I have tried switching the phone off and on again but still unable to use my phone.

    Has anyone experienced this before, or able to advise how to fix this problem.



  2. Hello CollyWolly, and welcome to Android Forums. :)

    We see that error message from time to time across many Android devices. The remedies vary a bit from one phone to another, but a good action to take first is to think about the most recent app or widget you installed or changed in configuration, the remove it and reboot then test the phone.

    If there is nothing new and no recent changes you can think of, try going into the application manager and clearing cache and data on all 3rd party apps you've installed, then reboot and test the phone.

    If still no joy, uninstall those apps and widgets one by one, rebooting and testing. This takes time, but is preferable to doing a factory data reset, which is something you may want to keep in mind to do if nothing else helps.

    I've moved your query to the Acer device forum for you, perhaps another user who has experienced that issue will chime in with an exact remedy for you. :)

Share This Page