1. Download our Official Android App: Forums for Android!

Help with apostrophes

Discussion in 'Android Apps & Games' started by staz1000, Apr 21, 2010.

  1. staz1000

    staz1000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    229
    16
    38
    I'm using an HTC Desire and mostly write using the 0-9 phone keypad. I'm having trouble with words that use apostrophes, especially "I'm" as the word it suggests is I'n. I tried adding the word to the user dictionary but it seems you cannot add words with apostrophes for some reason.

    Any suggestions?
     

    Advertisement

  2. DarlingScrewtape

    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 19, 2010

    Apr 19, 2010
    6
    0
    5
    Endsville, GA
    Stop using contractions.
     
  3. i VTAK

    i VTAK Android Expert
    Rank:
    None
    Points:
    98
    Posts:
    787
    Joined:
    Feb 10, 2010

    Feb 10, 2010
    787
    73
    98
    Indiana,USA
    That's weird, mine suggests I'o. I also use the T9 keyboard for texting. Try just hitting the 4 & 6 keys. In the suggested words up top it will show im as an option. If you select it, it will capitalize the I and add the apostrophe. T9 does a good job, but it does sometimes confuse me on it's predictions.
     
  4. staz1000

    staz1000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    229
    16
    38
    Thank you for your input.

    Yeah if I press just 4 & 6 'I'm' is the third suggestion along so I could do it that way, but I think the phone should be able to recognise that when I press the ' button the letters before and after are still linked together to form another word.

    I also have problems with other words such as 'isn't'. 'gsm't' is the word selected. I can understand if I just press 4, 7 & 6 that it might suggest a different word but as soon as I press ' it should be immediately suggesting 'isn't'. Just like on every other phone I've had with T9!
     
  5. i VTAK

    i VTAK Android Expert
    Rank:
    None
    Points:
    98
    Posts:
    787
    Joined:
    Feb 10, 2010

    Feb 10, 2010
    787
    73
    98
    Indiana,USA
    If you spell the word without apostrophies it will put it in for you. Like inputing 4768 and isn't is the first word that comes up. My biggest problem is with the word he. When I hit 43 the first word it comes up with is id, not I'd or he, just id. On most things it does pretty good though. I'm used to T9 from my old phone, plus it has no lag at all compared to the portrait qwerty keyboard.
     
  6. staz1000

    staz1000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    229
    16
    38
    Yep for many this works also I agree but I would like it if there was a one-stop answer rather than doing one word one way and another another way, for example 'we're' works just fine pressing 93'73 but not if you just do 9373.

    Ultimately there's an apostrophe button right there on the screen which I'd like to be able to use fully.
     
  7. i VTAK

    i VTAK Android Expert
    Rank:
    None
    Points:
    98
    Posts:
    787
    Joined:
    Feb 10, 2010

    Feb 10, 2010
    787
    73
    98
    Indiana,USA
    We're is the same way for me too. I agree it would be nice if it worked perfect, but it works well and I've learned to work around the little glitches. Good luck finding an answer.:)
     
  8. staz1000

    staz1000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    229
    16
    38
    lol thanks!
     
  9. ilh

    ilh Newbie
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    Apr 21, 2010

    Apr 21, 2010
    28
    4
    16
    Mine suggests I'o. I have found that if you hold the ' key so the list of " and ' comes up and then swipe across to ' then it works fine, I'm is the first suggested. Alternatively if I press 4 6 then it pops up I'm as the fourth option.
    As for isn't, weird that it does gsm't, but if you don't even bother with the ', press 4 7 6 8 then it works.
     
  10. staz1000

    staz1000 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    229
    16
    38
    If I press and hold ' it just changes it for a " and I get no suggestions.

    As I mentioned, I can skip the ' for many words and it works ok but I think it's stupid for them to put an ' button right there on the main screen but that doesn't actually function correctly.

    Thanks though.
     
  11. desire_one

    desire_one Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 25, 2010

    Apr 25, 2010
    2
    0
    5
    I've found the answer to this, as I was also annoyed with the non correction of the words that have an apostrophe.

    Settings>Language and Keyboard>Touch input>Text input> and then "tick" the "Spell Correction" for either keyboard types that you are using.

    In your case, the "Phone keypad & compact qwerty" option.

    I am also annoyed that i have not found this option earlier.. oh well. texting is going to be better starting Now! :)
     

Share This Page

Loading...