1. Download our Official Android App: Forums for Android!

Help With Blu Studio 5.0 d530

Discussion in 'Android Devices' started by 0nefellsw00p, Jan 27, 2014.

  1. 0nefellsw00p

    0nefellsw00p Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 19, 2013

    Jan 19, 2013
    1
    0
    5
    Male
    Plainville, MA
    Hello all, I'm hoping someone can shed a little light on an "interesting" problem I'm having with my new phone. This may be my first post on here, but I have scoured this and other forums trying to come up with an answer but alas have found nothing, so here goes:

    I am currently using Simple Mobile which operates on T Mobile's network. I have near-perfect signal at home but can't seem to use the damned thing for Facebook, Tapatalk, Zynga games, internet, etc without my interent connection timing out on me. I recently switched from Comcast to Dish Network and no longer have wifi at home so this is killing me.

    This phone screams on wifi, and it seemingly works fine everywhere else via my data connection except at home. I normally show an H or an E at home. From what I understand T Mobile is replacing all of its edge circuits with HSPA+, so I'm thinking they just haven't got around to upgrading the tower closest to my house as of yet. I decided to get my girlfriend prepaid service on T Mobile with that $30 per month 5GB plan through Walmart and slapped the sim in my old Motorola Defy and it works great. However, if I put that same sim in my phone I'm back to square one with the same data connection problems, so I know this is not a problem with Simple Mobile (plus like I said as long as I am not at home my phone works well, too.).

    So here's the real kicker -- if I use the PDANet+ app on my phone and turn on the wifi hotspot, it works just fine when I connect using my home desktop computer! This is so aggravating, why would I time out with my data connection for my own phone but as a hotspot it work flawlessly??? I'm pretty close to giving up on T Mobile because what good are they if I can't get a data connection on the phone itself at home?

    Also I should mention that all of the APN settings are definitely correct. Perhaps there is a baseband selection that I can't find somewhere in the Blu Studio 5.0 d530 that may help (I know there's one in the Motorola Defy). Maybe it's because T Mobile recognizes that my phone is not a T Mobile branded phone (but the Defy IS), and if so, how can they push the whole "bring your own phone" thing so hard?

    In any event, I may try just switching to Straight Talk but I really don't want to go through the hassle of porting my number and all that -- plus I'm not sure how good their signal is in my area. A search online for closest cell towers to my address results in T Mobile by a longshot.

    Any help is appreciated, guys -- I'm frustrated to no end here. :thinking:
     

    Advertisement

  2. Thom

    Thom  
    VIP Member
    Rank:
     #21
    Points:
    1,318
    Posts:
    11,869
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,869
    4,899
    1,318
    Male
    Software Developer
    Keene, NH USA
    Welcome to Android Forums. I moved this thread to the forum where phones are discussed that don't have a dedicated forum.

    ... Thom
     
    0nefellsw00p likes this.

Share This Page

Loading...