1. Download our Official Android App: Forums for Android!

Support help with google

Discussion in 'Android Help' started by kylekc92, May 1, 2016.

  1. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    So I'm running a galaxy s7 edge from AT&T and I use Firefox as my default browser. I have Google set as my default search engine as well. Everything that I type a search in the url bar it brings me to a Japan version of google search and not English.

    I've narrowed down what it could be, and it has to be something with my location services, but everything it set properly from what I see. I'm desperately looking for help with this.

    Things I've tried:
    Uninstall firefox, clear cache, change search engine and change back, check Google.com settings to verify english, check firefox language settings, contact samsung plus(said they would call back, its been 19 hours now), restart phone.

    What i found last night, my ads are all in japanese, and when im on wifi, the google search works properly to english which is why i think its a location thing.
     

    Advertisement

  2. girolez

    girolez Often Off Piste
    Rank:
     #48
    Points:
    543
    Posts:
    3,847
    Joined:
    May 29, 2011

    May 29, 2011
    3,847
    1,919
    543
    Male
    Retired
    Les Gets, France
    Hi

    I assume you are in Japan!

    When you do a search and get japanese results from google.co.jp you should see a "cog" at top right of the window. Press this, the second option down is "language". If you change it there your search results will still come from the japanese google but should be translated to English.

    Do you have a japanese bank card registered to your google account? If so, that may be the cause.
     
    scary alien likes this.
  3. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #8
    Points:
    2,138
    Posts:
    22,293
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,293
    23,645
    2,138
    Male
    space alien ;)
    Indy
    They're probably stateside if AT&T is their carrier / provider ;) :).

    @girolez's sage advice about the Language setting is a good thing to try/check.

    Cheers!
     
  4. svim

    svim Android Expert
    Rank:
     #44
    Points:
    608
    Posts:
    3,742
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,742
    2,785
    608
    Illinois
    Check in your Apps folder, there might be a 'Google' app and a 'Google Settings' app. (Both seem inter-related.) There are various Location, Ad settings, Account, etc. options in the Setting menus of both. Kind of confusing actually.
     
    scary alien likes this.
  5. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    I am not, nor have ever been anywhere near Japan. That's a common thing I saw online but that's not the case for me.
     
  6. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    So i tried @girolez's idea for using the "cog" and that seems to work. Everything is now in english, but it still brings me to google.co.jp. I can absolutely live with these results, but im curious if theres any way to get it completely fixed and go back to the standard google.com
     
  7. svim

    svim Android Expert
    Rank:
     #44
    Points:
    608
    Posts:
    3,742
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,742
    2,785
    608
    Illinois
    In Firefox's Settings menu in the 'Search' category which search engine is set as your default?
     
  8. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    Google is my default, and in those Google settings, the language is set to my system default language which is english
     
  9. svim

    svim Android Expert
    Rank:
     #44
    Points:
    608
    Posts:
    3,742
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,742
    2,785
    608
    Illinois
    As you mentioned Location being a possible source for this weirdness, do you typically leave Location enabled all the time? Maybe your phone's GPS just needs to get 're-calibrated'. If you install 'GPS Status & Toolbar' in its options menu there's a selection for 'Compass calibration' and 'Manage A-GPS state' that should reset your GPS. Also check in 'Diagnose sensors' to see if any of them have a red indicator (should all be green checkmarks).
    https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2&hl=en
     
    scary alien likes this.
  10. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    I gave that app a shot, nifty tool to have. I reset the GPS and did the re-calibrate process but still had no luck. After looking at the diagnosis, everything turned up with a green check next to it. I work in a cell phone store and have never seen this problem surprisingly. This is a pretty strange thing to have happen
     
    scary alien likes this.
  11. svim

    svim Android Expert
    Rank:
     #44
    Points:
    608
    Posts:
    3,742
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,742
    2,785
    608
    Illinois
    scary alien likes this.
  12. kylekc92

    kylekc92 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    6
    Joined:
    May 1, 2016

    May 1, 2016
    6
    4
    16
    Male
    Just to answer the problem, I downloaded an app called "hidemy VPN" and turned on the VPN for a few hours. Once I turned it off and tried the Google search it brought me to the normal google.com and not a Japanese version. I'm assuming it reset my location some how. Thank you to everybody who assisted in helping with the problem
     
    svim, girolez and scary alien like this.

Share This Page

Loading...