1. Check out our companion app, Forums for Android! Download from Google Play

Root help with half root

Discussion in 'Android Devices' started by DroidMakesPwn, Nov 3, 2010.

  1. DroidMakesPwn

    DroidMakesPwn Member
    Thread Starter
    25

    Sep 3, 2010
    8
    0
    25
    today i saw that there was an ota update and it seemed ok and i wanted it. i was running fission 1.1 rom. i thought that an acceptable thing to do would be do a nandroid recovery back to just rooted device and update and that worked well. problem is i lost root, which i expected, and now when i try to use the one click root method it successfully completes all tasks and even states "your device is rooted." however i cannot give any permissions to anything and in terminal emulator if i type su it says permission denied. i am kind of a noob but i am sure that means no root. so any ideas?

    btw when i try and use the unroot option it says i do not have superuser even though i do have it on the phone, but it is the old one from my previous setup with fission. thanks for reading my rambling and for any help.
     

    Advertisement

  2. Super_Six_Two

    Super_Six_Two Well-Known Member
    78

    Aug 12, 2010
    594
    76
    78
    NJ
    Download Superuser from the market and see if that fixes the problem.
     
  3. DroidMakesPwn

    DroidMakesPwn Member
    Thread Starter
    25

    Sep 3, 2010
    8
    0
    25
    tried that and it keeps saying failed to until. and now i tried to use rsdlite to use the 2.3.2 sbf and that failed. it didn't make it any worse but not im still in the same position. anyone with any ideas of whether the fact that every time i boot up my phone it still restarts right to bootstrap every time even though i do not even have it installed?
     
  4. inssane

    inssane Well-Known Member
    163

    Dec 17, 2009
    1,851
    156
    163
    Chi-Town
    Does the phone boot properly at all?
    If not, sorry, but it may be bricked if the sbf failed.
     
  5. inssane

    inssane Well-Known Member
    163

    Dec 17, 2009
    1,851
    156
    163
    Chi-Town
    And what do you mean "failed to until" on your Market error?

    Maybe DL superuser from xda forums as just an .apk??
     
  6. DroidMakesPwn

    DroidMakesPwn Member
    Thread Starter
    25

    Sep 3, 2010
    8
    0
    25
    Sorry it was supposed to be installed not until...damn swype haha. I solved my problem but it wasn't easy or documented anywhere. Basically I would try turning it on holding down different keys installing weird drivers for whatever the computer saw it as and eventually some combo got me into the stock bootloader and I flashed the partial 2.3.x from there really crazy. After that one click root worked like a charm.
     

Share This Page

Loading...