1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help with Rooting LG G5 Sprint LS992

Discussion in 'Android Rooting' started by sciencemathematics1, Mar 17, 2021.

  1. sciencemathematics1

    Thread Starter

    https://forum.xda-developers.com/t/...d-dm-verity-off-for-sprint-lg-g5-zv4.3523496/
    I tried this tutorial for rooting the LG G5 Sprint LS992.
    Everything works for me up to the point where you have to do adb disable-verity. This is the point after step 2. I know that step 2 works because the RUNMEFIRST dialog said to proceed to step 2 as it is supposed to say. Its just the next step where I have to do adb root and disable verity does not work. I know that it didn't work because when I tried the last step, then permission was denied, which meant that something did not work.
    ADB says that it only works for user debug builds. Does this mean the user debug build was somehow not installed when I tried to install it through this? Everything up to the part where the prompt comes up to say to go to step 2 proceeds well. Maybe it didn't install the user debug build when I factory reset the phone for step 2? Does anyone know what I should try doing?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    can you post a screenshot of the adb commands and it's prompts after?
     
    MrJavi likes this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    do you have usb debugging enabled on your phone?

    also the adb commands are done on your computer and not in the emulator.
     
    MrJavi likes this.
  4. sciencemathematics1

    Thread Starter

    Yes, I do have usb debugging available on my phone. I was doing the adb commands on my computer also, I opened adb on my computer to do the commands.
    This is the screenshot of the adb commands and prompts.

    upload_2021-3-18_1-52-24.png
     
    ocnbrze likes this.
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    ok and to be sure after step 8, you rebooted the phone into recovery mode and wiped data......correct?
     
    MrJavi likes this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    also which update are you on? this only works for v4, if you have v5 or higher this guide will not work for you.
     
    MrJavi and sciencemathematics1 like this.
  7. sciencemathematics1

    Thread Starter

    Yes, I did. I have done it several times actually, and each time it still did not work.

    I am on Android version 6.0.1, is that v4? I tried to look it up and it seems like it is.
     
Loading...

Share This Page

Loading...