1. Download our Official Android App: Forums for Android!

Root Help with super one click

Discussion in 'Android Devices' started by hm3grant, May 28, 2011.

  1. hm3grant

    hm3grant Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 28, 2011

    May 28, 2011
    1
    0
    5
    I am trying to root my atrix using the super one click app. It gets all the way to the the part where it says " installing psneutar" and then it stops. The window stops responding and when i unplug my phone it says program not responding.

    Please help
     

    Advertisement

  2. james27007

    james27007 Look into my Eye
    Rank:
    None
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    470
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    Welcome to androidforums, and I hope I can be of help. Before we start I need to know which version of the Atrix you have (AT&T, Bell, Orange...) and which version of the firmware are you running. However my answer works for all versions.

    From your description, it sounds like you have an AT&T Atrix and on 4.1.83 (menu --> settings --> about phone --> Build number)

    If you are on the AT&T Atrix and running 4.1.83, the only root method that works is gingerbreak. Check out the sticky at the top of this forum.

    http://androidforums.com/atrix-4g-a...turn-stock-other-hacks-atrix.html#post2598683
     
    Kulstad and ultradroid like this.
  3. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    I am having the exact same issue. I just got my update today.

    I have a Bell Atrix, running Build Number OLYLA_U4_0.37.23

    This is my first smart phone ever (had it only 2-3 weeks), and all my friends told me I needed to root it immediately! I (somehow!) managed to get it rooted using SuperOneClick, but haven't had any luck since I upgraded.

    Any help you are able to offer is *GREATLY* appreciated, and I ask that any instructions you offer me are of the "for dummies" variety.

    Thanks in advance!
     
  4. james27007

    james27007 Look into my Eye
    Rank:
    None
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    470
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    Looks like they killed the root exploit used by one click on the non-AT&T Atrix as well. So give gingerbreak a try. Info on how in the 1st post of this thread:
    http://androidforums.com/atrix-4g-a...turn-stock-other-hacks-atrix.html#post2598683

    Now a quick question, I know your friends told you to root, but did you need it and do you still need it? If not, than I would not worry about it.
     
    Kulstad likes this.
  5. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    I didn't think I needed to root in the first place, but I was *really* upset with the lack of battery life on the Atrix, as well as some of the useless (to me) applications on it that I couldn't uninstall (Uno, QuickOffice, etc). Reading these forums led me to this link, and Titanium Pro seemed to be the solution (well, only partially. The battery seemed to last a little longer, but not much. Sadly, Titanium Pro needs root and superuser.

    I am always cautious when it comes to non-standard usage of things, especially expensive and nice things like this Atrix. I have heard horror stories about how people have accidentally bricked their new phones, and I never want to be "that guy".

    There is so much to learn about this phone, and I find myself overwhelmed at times when it comes to learning about everything it does.
     
  6. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    I just finished following the directions at that link you gave me. I was able to get GingerBreak installed on my phone, but I can't seem to get rooted. I've downloaded the APK from this link, but no dice. According to Knightdulac on this page of the forums, s/he was able to get it work, and s/he has the same phone and version as I do. I have no idea what I'm doing wrong now.

    Sincerely, I have no idea why this has to be so difficult, or why it is so difficult and dangerous to either "performance tune" a phone, or to jump through all these hoops just to get a battery to last longer than 4 hours.

    (sorry about the whining. told ya I was a n00b at this :eek: )
     
  7. james27007

    james27007 Look into my Eye
    Rank:
    None
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    470
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    It's ok, everyone was a n00b once :)

    Anyways, so what happens when you run the app? Does it reboot, also, how many times did you run the app?
     
    Kulstad likes this.
  8. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    When I run GingerBreak on my phone, I first get a warning screen:
    "Please make sure of the following before rooting:
    - You have an SD card inserted and mounted
    - USB debugging is on"

    I've searched my entire phone, and the only thing that even remotely looks like an SD card is the white Bell chip behind my battery. I believe that's the SIM card.

    I *do* have USB debugging turned on.

    I click the OK button at the bottom of the warning window, and press the ROOT DEVICE option. From there I get a "this may take a few minutes" window, and a swirling graphic on the right-hand side of the window. From there, it seems to just hang. I've waited upwards of 45 minutes for something to happen (a reboot, a "this isn't going to work" message...anything!) but nothing does.

    I've powered off completely, I've removed the battery, I've tried it with my phone plugged in (via USB) to my computer, and I've tried it without the phone being plugged into anything.

    Given the amount of success stories I've read, I'm almost positive it's something I'm doing wrong, I just don't know what.:thinking:
     
  9. james27007

    james27007 Look into my Eye
    Rank:
    None
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    470
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    You must have an external sdcard. Go to a local store that sales micro sd cards cards, (I got my 2GB memory card from Walmart), get a cheep one and put it in the sideways slot to the right of the white sim card. Once you have the sdcard installed, it should work perfectly.
     
    Kulstad likes this.
  10. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    I will give this a shot. Is needing an SD card something new for this update? I am 100% positive that I don't have one (and didn't pre-update), and yet I was able to root with SOC.
     
  11. james27007

    james27007 Look into my Eye
    Rank:
    None
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    470
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    A little more info. To gain root access on an android phone, you need to be to able edit the main system folders, which are locked, so we use a file/app that creates a backdoor (known as an exploit) to temporarily unlock the system file and then it places a file called SU (which gives you access to the system folder) in one of the system folders. Once the SU file is in there, and you have superuser app installed, you have root access.

    Super One click used an exploit that did not need an sdcard to work. Well Motorola fixed that exploit so it no longer works. So a very skilled programmer found a new exploit and created gingerbreak to use this new back door. The downside is this exploit requires an sdcard. So once you have an sdcard, jus run the app, you do not need to reinstall it.
     
    Kulstad likes this.
  12. Kulstad

    Kulstad Newbie
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    13
    1
    16
    Canuckistan
    I think I have one more issue, and everything will be fine. I can't seem to press the THANKS button more than once!

    Thank you for your patience and guidance through this. I picked up a 4GB Lexar MicroSD card ($9 at FutureShop!), and installed it in the store. I tried GingerBreak right away, and in less than 5 minutes I was rooted.
     
    james27007 likes this.

Share This Page

Loading...