Help Help with Video

I'm on a Samsung Galaxy Tab 10.1, just upgraded to 3.2 and I'm have issues with videos playing. Specifically what happens is... when I'm in Facebook or in a browser and I "click" on a video it starts to process ( I get the play bar on the bottom of the video and I get an option to pause) but it's just a blank / black screen. I get sound but no video. I can pause and play the video but I can't view in full screen mode.

Can anyone help me with this? or give me an explanation as to why this is happening? Thanks!

BTW... Most of the videos I'm trying to view are YouTube videos, but not from the YouTube app. Just as I'm browsing the web or facebook.
 
I have the problem both with a samsung and a lenovo tab. I have also tried opera, dolphin, and maxthon browsers to no effect as well as mxvideo.

I purchased a samsung galaxy tab 10.1 for my father in laws xmas and his key requirement was to watch his local football teams web videos. Unfortunately i cant seethem on my tablet. I can see the non hd ones but not the more recent hd ones, and i also cannot see them on my daubhters lenovo android 3.1 tab either.

The url is*Warriors TV | Mon, 2nd January 2012 | Stirling Albion | Fixtures | Stenhousemuir Football Club

Basically i see the first image and then it all goes blank. I have the most recent version of flash and other videos work fine.I think it may bean android problem given that it doesnt work on two devices.Any help or support would be greatly appreciated.Thanks

Ted.
 
Top