1. Download our Official Android App: Forums for Android!

General HELP Xperia Play won't turn on!

Discussion in 'Android Devices' started by NitroEX, Oct 12, 2011.

  1. NitroEX

    NitroEX Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    4
    0
    5
    Earlier today while using the youtube app on my Xperia play the phone suddenly froze and turned off. At first I thought the battery had come loose (which it has done on occasion) because the phone wouldn't turn back on. However, after taking out the battery and putting it back in I still couldn't get the phone working again.

    The battery was not low enough for it to run out and I've even tried plugging in the charger but I still get nothing. (Not even the lights turn on)

    Another thing I've tried is removing the battery and trying to power it with nothing but the cable but even that gives me no response. Not even the lights turn on. It's completely dead!

    Can anyone help me out?
     

    Advertisement

  2. fuhrl

    fuhrl Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    131
    Joined:
    Sep 30, 2010

    time to use your warranty.
     
  3. oleb84

    oleb84 Android Enthusiast
    Rank:
     #484
    Points:
    53
    Posts:
    279
    Joined:
    Jul 15, 2011

    Jul 15, 2011
    279
    29
    53
    Male
    London
    ^ agreed
     
  4. XperiaTACO4G

    XperiaTACO4G Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    121
    Joined:
    Sep 28, 2011

    Sep 28, 2011
    121
    11
    38
    Sorry, sounds like it's faulty! Is it still under warranty?
     
  5. XXGORDOBOYXX

    XXGORDOBOYXX Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 18, 2012

    Mar 18, 2012
    1
    0
    5
    same thing for me
     

Share This Page

Loading...