1. Download our Official Android App: Forums for Android!

Root Hi forum! I've come begging for help :-(

Discussion in 'Android Devices' started by coreymike, Sep 13, 2011.

  1. coreymike

    coreymike Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Sep 13, 2011

    Sep 13, 2011
    8
    0
    5
    Hi everyone!

    I rooted my phone yesterday using the Revolutionary method and everything was hunky dory! Tried the cyanogenmod and thought it was pretty decent but was missing Sense so thought I'd give the Leedroid Rom a try...

    After wiping off Cyanogen and Selecting to install Leedroid off the SD card in recovery the phone went in to a bootloop when Leedroid tried to launch. "No problem" I thought, I'll wipe it and just put the old rom back on...

    I wiped but when I went to find the ROM on my SD card in clockwork recovery it says E: Can't mount /sdcard.

    The card works fine in my pc and I have backed up the contents of the card and formatted it etc but it won't allow me to get to any of the restore data on there or custom ROMs. When I try to mount the sd card in the 'mounts and storage' bit it just says Error mounting /sdcard! I have tried a spare SD card and also formatted in another htc android phone as well but I'm out of ideas :thinking:

    I would be unbelievably grateful if anyone could help me fix it. So grateful infact that I'd be willing to paypal some money or donate or whatever if someone gave me a working solution... :eek:
     

    Advertisement

  2. Hadron

    Hadron  
    VIP Member
    Rank:
     #6
    Points:
    2,468
    Posts:
    23,296
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    23,296
    16,911
    2,468
    Spacecorp Test Pilot
    Dimension Jumping
    My guess is that you have a "USB brick" - fixable, but unpleasant. Inability to read sd is a prime symptom. I'm on my phone at the moment, so can't easily find and post links, but try searching the forum for that (also misc error). Rastaman-FB has talked a few people through these, so searching for posts by him might help.

    Good news is that you used revolutionary, so should have a modern alpharev hboot. These support features to make fixing this simpler, so look in particular for posts that say something about this, as it will save you some hassle.

    Sorry I can't post the actual solution from here, but don't panic, I'm sure this is a fixable problem.

    The other question is, what did you do that caused it? May just be bad luck, but if not we want to avoid it happening again. You did not use an app called ROM Manager, for example?
     
  3. shauny13

    shauny13 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,274
    Joined:
    May 24, 2010

    May 24, 2010
    1,274
    303
    163
    Male
    Beautiful Dorset
    I fear rom manager here again???
     
  4. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,916
    Joined:
    May 25, 2010

    May 25, 2010
    23,916
    5,307
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    +1 on the Rom manager question
     
  5. Jon_LTD

    Jon_LTD Android Expert
    Rank:
    None
    Points:
    98
    Posts:
    786
    Joined:
    Sep 6, 2011

    Sep 6, 2011
    786
    84
    98
    Male
    Uk
    Ouch Mike. You must really be struggling:cool:

    Absolute nightmare, but you are in the right place. And I thought you just weren't answering my messages earlier.

    Let me know when you've sorted mang, and also share with how you did it because I don't want to end up in the same predicament!
     
  6. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    I detect rom manager use however its not too bad aa he is s-off via revolutionary which has misc flashing included.
    Simple to fix.

    Use the usb brick fix guide for 2 things only.
    See the section to enable sdcard functionality.
    See the link to create an mtd0.img for your phone

    One the above is done use fastboot to flash
    Fastboot flash misc mtd0.img


    If you used rom manager. Vow never to touch it again
     
  7. coreymike

    coreymike Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Sep 13, 2011

    Sep 13, 2011
    8
    0
    5
    Yep, I did use rom manager :eek: Then I found the 'Don't use ROM manager thread' :) Genius

    I have to say I am a total noobtacular noob so I'm not that down with the android lingo. In fact in retrospect I probably shouldn't have rooted :eek:

    I'm going to have a look for the USB brick thread for advice tomorrow although any additional advice on here would be greatly appreciated.

    A day without my android phone has literally been "the longest day"...

    Thank you all for your replies!
     
  8. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    doing what i said will fix it mate
     
    coreymike likes this.
  9. coreymike

    coreymike Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Sep 13, 2011

    Sep 13, 2011
    8
    0
    5
    Thanks Rastaman, I'm gonna have a look tomorrow when i'm not so drunked!

    Been out in town all day bar hopping without my smartphone :( Bad times

    I don't really understand much of the ADB bridge stuff so I apologise but I really appreciate any advice and support....

    I wish I hadn't gone anywhere near rom manager because I'm totally ****ed but I hope in the next few days I can resolve this.

    Thanks again
     
  10. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    you dont need to know about adb, its fastboot
    if you follow the guide on how to get fastboot installed and working then do the steps as mentioned above you will be fine
    its litterally exactly as i posted.
     
Tags:

Share This Page

Loading...