1. Check out our companion app, Forums for Android! Download from Google Play

Root Home and search keys stopped working on rooted LG optimus U

Discussion in 'Android Devices' started by j1012la, Nov 8, 2012.

  1. j1012la

    j1012la New Member
    Thread Starter

    Aug 31, 2012
    Hello all,

    This is the first time I've ever had to start a thread over phone complications. I have an LG Optimus U US670 with root and one day out of the clear blue my home, search, and lock screen buttons stopped working. The home and search buttons do absolutely nothing but light up when pressed, so I can't have more than 1 program running at once because the only way to get to the home screen is by repeatedly pushing the back button. It used to show me a list of recent apps when long pressing the home button but it doesn't do that anymore either. Another thing I noticed was my lockscreen went missing and the lock/power button will only black the screen or say power off when long pressed. It used to have a list of selections when long pressed. There's been no water or physical damage to the phone, but I was clearing up caches and freeing up memory before it happened so I'm unsure of what I've done wrong. I've tried restarting the phone, removing the battery, etc., but no luck. I was surprised to see how many others who have had the same problem but I've found no solutions. Some have say the issue has something to do with Google and I remembered uninstalling a program connected to the Google play store called Google play services. Im pretty sure the problem didn't exist before that uninstall. Since then, I have reinstalled Google play services and reinstalled the play store but still nothing. I REALLY REALLY do not want to reset my phone if optional. I've read where several people had their phone bricked, or resetting was unsuccessful in resolving the problem. If ANYONE can help me out I would be more than thankful!


  2. Brian706


    Jul 25, 2012
    Hi j1012la! Sorry to hear you are having problems. I am not familiar with your device but I will try to make a couple of general suggestions that will hopefully help.

    Do you have a custom recovery installed on the phone? Have you tried entering recovery and wiping the cache & dalvik cache?

    Do you have a nandroid backup made in recovery? If so, how current? You may be able to boot into recovery and wipe everything and restore that backup to the last known working state and lose minimal data.

    If neither of these work, you may have to bite the bullet and do a full wipe and reflash of the rom. You can minimize the blow however by downloading something like Rom toolbox, Titanium Backup, or My Backup from the Play Store. You may be able to get all your apps and data backed up before formatting everything and then restore your data.
    If you restore all data and get the same problem, you may need to wipe and flash again and then restore your data 1 item at a time (rather than batch restore) to try and pinpoint the trouble maker.

Share This Page