1. Are you ready for the Galaxy S20? Here is everything we know so far!

How can the USSD problem of Casio commando c811 be solved????????

Discussion in 'Android Devices' started by yahyazadeh58, Oct 8, 2015.


How can the USSD problem of Casio commando c811 be solved????????

  1. Change rom by root explorer

  2. developing new rom

Multiple votes are allowed.
  1. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    There are a lot of ways for solving the other problems of this handy. However, anybody has not solved the problem of USSD that comes back in Chinese word. I have seen this problem in different kinds of mobile phones. This problem should be in a specific place in android phone rom.

    1. Download the Forums for Android™ app!


  2. space_cat

    space_cat Well-Known Member

    I'm on Verizon in the US, and Verizon doesn't use USSD, so I can't really test anything. I've seen the problem when I've travelled, but can't offer a solution.

    Some of these apps might get around the problem.

    At this time, it is doubtful that anyone is doing enough work on this phone to find a solution. The user Doctoror is our main developer here, and I believe his provider does not use USSD either.

    This thread has more info on the problem:

    #2 space_cat, Oct 8, 2015
    Last edited: Oct 8, 2015
  3. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    I have nearly used all of USSD app for solving this problem, but it has not had any results so far. I have even tried to change the default dialer, but whenever I have tried to dial with any dialer, it automatically open Casio default dialer. I have even tried to inactivate default dialer by Titanium, but again noting happened.
  4. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    Every of this web pages, I have read them several times, but there is not a solution for this problem. as I previously mentioned, in addition to casio commando some other cellphone have such problem. so far, the problem has been solved just with changing rom by the manufacture of them. however, this problem should be in somewhere in Android rom. it is necessary a professional person solve this problem.
    I have already used m020 rom that is ICe cream, it has not such problem, and USSD runs well, but it has several other weak points. therefor, I decided to use m070 rom. I have solved all of the rom problems except USSD.
  5. Doctoror

    Doctoror Well-Known Member

    Yes, there were no USSD problems with M020. This problem was introduced in M040.
    Unfortunately the USSD problem is not currently solved by anyone. I'm afraid I'm not working on it and not investigating this issue further. I found my way around not using USSD at all. My provider supplies an app in Google Play which does all stuff that you could do via USSD.
  6. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    If I had your knowledge about android, at least I tried whether I could solve this puzzle or not.
  7. trinhtuong88

    trinhtuong88 Lurker

    I have a proplem like this, can't fix this ???:(:(:(

    Attached Files:

  8. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    There is no possibility to solve this problem. and I could not find any solution for it. in addition, i checked several roms so far. the only possibility. you should just use m020 rom or 4.0.4 ice cream that a lot of problem. I see you have very nice rom. i did not test it before, could you please share it with me
  9. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    I forgot to ask you. did you have ever had 4G signal or not?
  10. trinhtuong88

    trinhtuong88 Lurker

    I think proplem at setting on "Reference country setting":(:(, touch then error "unfortunately ...":thinking::thinking:, if fix this here, I think everything ok.Oh my Rom use Nextlaucher and theme of them, :D:D

    Attached Files:

  11. yahyazadeh58

    yahyazadeh58 Newbie
    Thread Starter

    no it does not work. it just help you for sending sms without deleting you country code. for example for Germany it is +49 if you put this in your reciver you can not send sms.
    trinhtuong88 likes this.
  12. trinhtuong88

    trinhtuong88 Lurker

    Who can fix this proplem ?:(:(:(
  13. trinhtuong88

    trinhtuong88 Lurker

    Thank "TheDriver" :)
    There is a problem with USSD responses with some foreign languages (others than English).
    Device doesn't handle some encodings correctly and and shows a bunch of unreadable symbols.
    The only man, I know, who have explored USSD problem is liver87 from 4pda. He've turned the device into the modem mode, then used an external program to send/receive USSD's from the PC.
    He stated responses was shown correctly which points to the modem FW is working OK. The problem is located somewhere in dialer and/or its related resources (e.g. telephony service etc.). If this is the truth someone can decompile the dialer (other apk's) find the place USSD's are being decoded and fix it.

    You can read original post in Russian here:
    Translate with Google translator.
    You can contact liver87 to ask some details. He's from Ukraine and I don't know does he speak English freely.
    I should remember, I do NOT have Casio device on my hands and never had, so I can't debug this problem.
  14. If you use ussd to check balance you can use sim toolkit to check(it worked for me in my country - Viet Nam)
  15. piludo36

    piludo36 Member

  16. trinhtuong88

    trinhtuong88 Lurker

  17. Hello everyone, I have tried to fix this error. I finally succeeded. You can download the file Phone.apk that was recompiled. Just put your phone into airplane mode, copy Phone.apk into /system/app on your phone. After that set permission for it to rw-r--r-- and restart your phone. I have test it on my c811 android 4.1.2, it 's ok. I will write instructions step by step how to fix this error step by step when i have free time :D
    ***Note: remember backup your old Phone.apk and Phone.odex (if you have not deodex Phone.apk) in case of it 's failure.
    Link download here: http://www.mediafire.com/file/ddvx9gi2cvo0ril/Phone.apk

    Vietnamese: Xin chào các bạn, trong thời gian mình sử dụng casio c811 android 4.1.2, mặc dù gặp 1 vài vấn đề nhỏ nhưng mình cũng đã cố gắng tìm cách khắc phục, và hôm nay mình đã rất vui vì đã sửa được lỗi encode sai ussd, lỗi này cũng khá khó chịu. Các bạn chỉ việc bật chế độ máy bay trên điện thoại, copy file Phone.apk đã chỉnh sửa vào /system/app, khởi động lại máy và hưởng thụ :D
    **Chú ý: Các bạn nhớ backup file Phone.apk cũ và Phone.odex trước khi copy file Phone.apk mới vào phòng trường hợp có lỗi thì lấy lại file cũ. Mình sẽ viết lại từng bước làm thế nào để sửa lỗi này khi nào mình có thời gian rảnh.
    #18 thaihoangduylinh, Jan 29, 2018
    Last edited: Jan 29, 2018
    trinhtuong88 likes this.
  18. mikedt

    mikedt 你好

    It's traditional characters, so not from mainland China, but it doesn't make any sense to me. It's like something a spambot would do, basically gibberish.
    #19 mikedt, Jan 29, 2018
    Last edited: Jan 29, 2018
  19. it was error when decode characters that were encoded in utf-16LE, i have fix it by modify system app: Phone.apk. Characters, It's like Chinese but not

Casio G'Zone Commando 4G LTE Forum

The Casio G'Zone Commando 4G LTE release date was April 2011. Features and Specs include a 3.6" inch screen, 5MP camera, 512GB RAM, processor, and 1460mAh battery.

April 2011
Release Date

Share This Page