1. Are you ready for the Galaxy S20? Here is everything we know so far!

How can you tell if you lost your root access? How could that happen?

Discussion in 'Android Devices' started by mslisaj, Aug 18, 2010.

  1. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    I have been having a memory problem for the last few days. I decided to use my Nandroid and go back a month and restore. Everything worked fine but then I tried my Titanium back up and it wouldn't load. Then I tried my file explorer and it wouldn't load and said I needed root access. My SU program appears to work but my access to that seems limited now too. Could I have lost root? How could this happen? I haven't done any rom modifications or anything. My Nandroid backup still works and I can restore to different dates but the two programs that I have that use root don't work now. Help!

    Thanks ahead of time for the response........


  2. dpeeps74

    dpeeps74 Well-Known Member

    yeah, which is what i pointed out on XDA. it's also why cachecleaner wouldn't work. you need to re-root your phone. if you follow the manual adb steps right to the point where it says you're rooted, you're good. you may then be able to reinstall superuser permissions (think the latest version is 2.3? it's on xda). otherwise, after you root, you should be able to do a nandroid or do a wipe/flash and be fine. you'd get a lot further here if you'd accept people's advice and not create a dozen threads where you just dismiss everything people suggest.
  3. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    Dear Mr. Dpeeps.........

    Thank you for your help. I do appreciate it and I have been following everyone's suggestions. I have even acknowledged most of them and given the results. I have hit all the forums as my problem still exists. I am a very limited user and I don't understand all the terms. It took me an entire weekend, probably 24 hours to root and rom my phone. It wasn't easy for me and the men that help me get through it were great. But all I have are these forums to get me going. I got to Damage Controls latest rom and that was like pulling teeth to get working and when I was done I had had enough playing with this device to last me a long time. I haven't done anything to it for six months except update the programs I have had. Then I got a low internal memory warning. I went through and cleared out the cache on every program I could find. Solved the problem for awhile but then the warning kept coming back. I would clear cache and be okay but then I found myself riding on the ragged edge of 16MB of internal memory. Below 16 and the warning comes on. I tried task managers that were suggested to no avail. I tried the cache cleaner but it didn't work as some where along the line I apparently did something that caused me to loose root. This had to happen in the last two days as three days ago I used the Root Explorer Program and it worked.

    I am not trying to be a pest, I'm trying to understand and learn about this phone a piece, very small piece at a time. I am not a programmer by trade but rather a lowly truck driver and this phone is my life line. I wish I just could take it somewhere and get it fixed but that is not an option as it IS or was rooted and it has a custom DC rom on it.

    I just received a note suggesting I open up a "shell" on the phone and see if it's rooted to get the bad news. I don't even know how to open a shell on the phone. I can do it from my laptop but I won't have access to that for a few days. So please forgive me if I seem a little desperate to get a hopefully simple answer to all my problems except a complete wipe and reload to factory settings. I sincerely thank you and everyone else for trying to help me. But right now I think I'm going to Nandroid back a month and at that point I had almost 50MB of memory. At least at that point everything worked. I won't have Titanium or File Explorer but then again at this point I can't play with the device plus I will have all that memory that hopefully will keep me going 'till I have to time to wipe and start over.

    So thank you Mr. Dpeeps and everyone else who has taken their time to help me. I sincerely appreciate it and I do read the forums that I post questions on and I do respond with answers to other folks when I can help them......... But for now I'm in a corner and just trying to band aid this phone back together and keep it running. I just can't thank you all enough for all your help...........


  4. Joehunni

    Joehunni Android Expert

    Just download a new rom and flash it (or reflash whatever you have after a full wipe). If you have root but have superuser issues, this should get you back on track.
  5. dpeeps74

    dpeeps74 Well-Known Member

    oh brother..ok..i get it. we all get it. we all love our phones (ok for some it's a love/hate thing) that's why we're here and why we go through all the trouble we do with them...so they do what we want, and when we want them to. if my phone became unusable, i would be pretty lost i'd imagine, and a couple of friends would think i'd gone crazy when they get home and i'm just there sitting on their doorstep cuz i have no way to reach them.

    i believe the person was telling you how to check root. to do that, you open terminal emulator on your phone...i guess it's on damagecontrol, never ran it. from there you type "su" without the quotes and press enter. if it tells you access denied, you lost root. if it gives you a $ prompt, you have root still and your superuser permissions are messed up. I know this isn't your original problem, but cleaning cache really requires an app, which is why they make a couple (i don't think cache is your whole problem, but i run cachecleaner every couple of days and have seen it delete 10MB easily). then beyond that it really comes down to the other things that have been recommended...uninstalling apps you don't use and clearing data from apps with excessive data.

    if you already did a nandroid, you probably did nothing wrong to lose root...for some reason that happens on some roms when you run nandroids and probably other scenarios could cause it as well. also as someone mentioned on xda, if the mail app your using does have a bug and you happened to encounter it, probably nothing you could have done about that either.
  6. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    Well, I looked all through the DC components that I can find and I can't see or figure out the "terminal emulator". I don't see a place where I can use a command line...... So I'm stuck there. Here are the know facts about this super user problem. It worked two days ago. I have the latest version on my phone. I have three programs that have SU Permissions. Titanium Backup, My Backup Pro and Root Explorer. The odd thing is that My Backup Pro apparently works. Also I have ES File Explorer on the phone too. I have root access with that but it never seem to need the SU Permission to access it. I have taken the phone back to my June 30th Nandroid and the phone is working. I can't use the effected programs. I can open the Super User Program and it is running and has given the "green light" to the effected programs. So there you have it. Phone working. Pressure is off. I'm not going to do any of the updates that I have done to the programs I have in my phone now. I have gone through and manually cleared every programs cache that I can find and I have 45MB of memory so I'm running. But still have no idea where my memory has been going and now am I still rooted?? Who know............

    Thanks again for your help.........

  7. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    Mr. Dpeeps, interesting comment about the mail program having a bug. I have been starting to think of the word virus. I'll watch my memory closely now that I have gone back six weeks and see what happens to memory. If I can hold memory then maybe everything is okay and I did have a bug that is stuck now in a Nandroid. Then I just have one problem to sort out and that is the SU or maybe Root Issue........

    Interesting............ See.... We're certainly learning stuff here..........

    Lisa :cool:
  8. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    I found a terminal emulator "ConnectBot" and installed it. Got my command line and entered SU and it said access denied. I also typed WHOAMI and access denied that way too so I guess this is proof that some how I lost root. So the next question is how do I get it back? Looking in the root forum there are two guides and they are sort of specific:

    One - for a stock phone running 1.5


    Two - Phones that have received the OTA or the factory 2.1.

    I'm not in either situation any more so what do I do?

    That's the current question now............... I'm certainly in a graveyard spiral with this phone now...........

    Lisa :(
  9. andygu3

    andygu3 Android Expert

    I think I read somewhere that running the official RUU from Sprint will put you back to stock. Maybe search for some info that way, then if you can run the RUU, reroot!
  10. dpeeps74

    dpeeps74 Well-Known Member

  11. mslisaj

    mslisaj Android Enthusiast
    Thread Starter

    I am following through as I alway do to thank you all for your help and tell you how I resolved the problem. I received some great advice from everyone and the last tip, which is usually my luck was the best.

    The bottom line someone questioned why I thought I lost root. I explained what was going on and the best and final suggestion was to down load the latest Superuser.apk and flash through "recovery". Yes I had to ask exactly what that meant but I followed the directions and did it. Problem solved. I had SU working on my phone for Root Explorer and Titanium Backup. Then I downloaded Cachecleaner and it worked this time perfectly and it found 25MB of junk on my phone and cleared it out. So now I'm running 40MB of internal memory with all my programs working rather snappy now. In my estimation I screwed up the SU with the memory manager that was recommended somewhere along the line. When it didn't do anything for me I uninstalled it and I think my SU went with it. But the phone is fixed and I want to thank you all for your time in responding to my problem and requests. Sometimes multiple............

    Thanks again.....

    Lisa :D

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date

Share This Page