1. Download our Official Android App: Forums for Android!

Root How delete all calendar entries from Droid?

Discussion in 'Android Devices' started by Redflea, Jan 3, 2010.

  1. Redflea

    Redflea Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    2,623
    Joined:
    Oct 6, 2009

    Oct 6, 2009
    2,623
    289
    163
    What's the quick and easy way to clear out my Droid's Gmail calendar?

    I sync two/from Outlook and the cloud, and need to clear off my Droid and Gmail to get things back in sync after some changes I've made.

    The last time I wanted to do something like this, I emptied (deleted) my Gmail calendar on the web, but for some reason the phone calendar didn't clear out, and I ended up doing a reset to start over...

    I'm sure there's an easier way, like removing the account from the phone, but it's the primary account and I don't want to delete my contacts from the phone or cloud.

    Any ideas appreciated...
     

    Advertisement

  2. Redflea

    Redflea Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    2,623
    Joined:
    Oct 6, 2009

    Oct 6, 2009
    2,623
    289
    163
    I have root, if that helps...is there a file on the Droid I can delete or replace to clear the Gallery - this is frustrating, I've deleted the calendar entries on Google and did a sync, but the events are persisting on the Droid....
     
  3. Redflea

    Redflea Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    2,623
    Joined:
    Oct 6, 2009

    Oct 6, 2009
    2,623
    289
    163
    Solution found...someone on Howard Forums, whom I'm forever indebted to, had the answer...

    Settings->Applications->Manage Applications>Calendar->Clear Data

    I did the clear data on that, all the data in my calendar was still there! Interestingly, when I returned to App Manager and looked at Calendar again, the data field was back to the same number as before I had deleted it (set the value to zero).

    So I looked at the list and found there was a "Calendar Storage" app in the list right below the "Calendar" entry.

    So I did a clear data on the Calendar Storage" item and voila! By the time I exited app manager and returned to view my calendar, the old, bad data was gone and my phone was populated w/the new, clean calendar data from Google Calendar.

    Saved me a factory reset to clear off my calendar so I could start syncing again w/new data. Very cool...
     
  4. rtd1978

    rtd1978 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 9, 2010

    Feb 9, 2010
    1
    0
    5
    thanks for this workaround.

    did the steps listed above, but had to delete the calendar-widget from sense. after redocking the calendar-widget - bad data was gone (week numbers in my case)

    ... rtd1978
     
  5. Jammerman

    Jammerman Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    4
    0
    5
    Estimator
    KC, Missouri
    I tried that before, and now again. I am using the Droid on 2.1. "Calendar" does not appear in my applications.

    I just need to switch my Calender to my new Gmail Account- everything else is changed over, but the calendar is stubborn.
     
  6. Jammerman

    Jammerman Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    4
    0
    5
    Estimator
    KC, Missouri
    I went ahead and reset to factory defaults. It fixed the calendar problem and was really painless. I had restored my phone back to the way I liked it in about 20 min.
     
  7. lifespaths

    lifespaths Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jul 13, 2010

    Jul 13, 2010
    1
    2
    6
    When your applications are listed, press the "Settings" button, choose 'Filter', and select "All". Calendar will then show up. --LP
     
    nelso and Howard Packer like this.
  8. wayneaj

    wayneaj Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Aug 11, 2010

    Aug 11, 2010
    1
    2
    6
    Systems Engineer
    Phoenix
    Goto Settings -> Applications -> Manage Applications -> -> All -> Calendar Storage -> Press Clear Data.
     
    apitsos and Howard Packer like this.
  9. nelso

    nelso Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 21, 2010

    Nov 21, 2010
    1
    0
    5
    Thank you so much for this info! I had all kinds of annoying repeating appointments I didn't want/need attached to my calendar. When I switched from my (sucky) Incredible to my (magnificent!) Droid2 all of the events came in individually, rather than as repeating events. So it would have been impossible to delete them all and their annoying notifications. (We're talking several repeating events per day, mainly classes at my gym which I - of course - never attend!)

    Thanks to the help on this forum I got rid of the old calendars and now have a new one which contains only the most important info - Paydays and Bills Due!
     
  10. apitsos

    apitsos Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 30, 2010

    Aug 30, 2010
    2
    0
    5
    Web & Graphic Designer
    Athens, Greece
    That was the solution... So simple! Thank you so much. You saved me time as I had to wipe my device and set it up from the beginning.
     

Share This Page

Loading...