1. Are you ready for the Galaxy S20? Here is everything we know so far!

How do I delete ALL contacts on ALL my accounts (except possibly Outlook)?

Discussion in 'Android Devices' started by ship69, Jan 11, 2016.

  1. ship69

    ship69 Well-Known Member
    Thread Starter

    Hello

    My Samsung Galaxy Note 3 phone has about 5+ dulicates for every contact.

    I am absolutely SICK of this. I just want to delete all the contacts on my phone in all my accounts. Linking doesnt work. I seem to have up to one entry for each of:
    - Exchange
    - gmail
    - whatsapp
    - viber
    - DejaOffice
    - Twitter
    - Skype
    - Meetup
    - Nine
    - Outlook
    - Linked in
    - Google

    I tried various things to only display contacts from my master list (Outlook/Exchange) but that failed. It either hid all my contacts so that I could only find them if I searched, or showed all the duplicates.

    NIGHTMARE.

    Out of desperation I even tried downloading this app
    "Delete All Contacts"
    https://play.google.com/store/apps/details?id=com.DeleteAllContacts
    ...which says be very careful as it will delete all contacts from your device. It ran for about 2 minutes. It seemed to find about 6000 contacts....

    But the *$~*ing contacts are still there !!

    How do I get rid of them ALL so that I can start again?

    With thanks

    J

    P.S. I am on Android 5.0
    My PC runs Outlook 2016 (on Win8.1) with hosted Exchange and has my master copy of all my contacts. I have exported them to a .PST file and can re-import as required.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. svim

    svim Extreme Android User

    Sounds like you've got your Outlook contacts all saved and backed up on your PC, and you just want to start over clean on your Note, try this:
    -- Double-check that you've unchecked the Contacts syncing in all the accounts in your Settings >> Accounts.
    -- Then go into your Settings >> Application Manager, swipe over to the 'ALL' tab, scroll down and click on the 'Contacts' app. Click on the 'Force stop' button and then the 'Clear data' button. There might also be a 'Contacts storage' app, do the same, Force stop and Clear data.
    -- Now run that DeleteAllContacts app and restart your Note. If your Contacts are now cleaned up, try going back into Settings >> Accounts and re-enable the syncing for JUST your Outlook Contacts.
     
  3. ship69

    ship69 Well-Known Member
    Thread Starter

    OK I did all you suggested. But when I came to DeleteAllContacts app, this time it got stuck at "1%". So I rebooted and tried again. Same problem. So I rebooted my phone yet again. Contacts are now empty.

    So I go to Settings ==> General ==> Accounts to get my list of accounts.

    I then tried:
    Microsoft Exchange ActiveSync ==> Account [myEmailAddress] ==> I re-tick Sync Contacts which claims it has been synched just now. So I hit the Back button. There is now "Microsoft Exchange..." at top of page and "Sync All" text to it, which hit. For half a second it says that it is "Synching" but when hold Home button and I go back into Contacts app there still arent any entries at all.

    I checked on my PC and my contacts are still present. I change one contact entry in Outlook2016 on my main PC and yes, that change ripples through to my Outlook2016 on my laptop. So Exchange is working on PCs.

    So I reboot the phone for good measure and go back in to Settings ==> General ==> Accounts.

    Wait! Okay suddenly some of my contacts have re-appeared. However it only seems to be the tow that I have just edited in Outlook on my PC. (WTF?)
     
  4. ship69

    ship69 Well-Known Member
    Thread Starter

    UPDATE:
    Now I reboot the phone (for good luck) and check phone is back on-line.
    Now I go Contacts (orange icon) ==> Settings ==> Contacts==> Contacts to Display

    If I select the Exchange icon I only get the 2 contact entries that I have changed on my PC being visible on my phone.

    If I select the Contacts to Display as being DejaOffice I get the whole lot of contact including duplicates.
    If I go into DejaOffice there are no contacts there. Even my mysterious!


    OK I start the whole process that "Svim" suggested, all over again. I stop all accounts including Exchange from synching, I re-run my Delete All Contacts app. This time it finds about 1000 contacts to delete. I reboot the phone. I look in Contacts on the phone - nothing there. Go into Settings ==> Accounts and allow Exchange to sync again.

    But it's the same problem. No contacts appear unless I have just edited them in Outlook.

    So finally I figure [ GENIUS! ] if the stupid sync only responds to contacts being "edited", maybe if I re-import all my contacts from my .PST backup the phone system will be fooled into thinking that ALL the contacts have changed (they haven't - they've been over-written!)

    After about 5 minutes the darned thing starts to sync. FINALLY.
     
  5. svim

    svim Extreme Android User

    Looking into the matter more, apparently you're caught in a pissing match between Google and Microsoft. Over a period of several years Microsoft dropped supporting the dated but common WebDAV protocol from its Exchange servers in favor of its own Exchange ActiveSync (EAS) protocol. Then in 2013 Google cut back support for EAS so now only paid Google Apps account users still have full Exchange access, regular Gmail users do not. So syncing Exchange email is still OK but Contacts and Calendars are now more complicated. This link has some workarounds:
    http://www.slipstick.com/outlook/sync-outlook/syncing-outlook-with-an-android-smartphone/

    Google's announcement on its EAS support:
    https://support.google.com/a/answer/2716936?hl=en
    WebDAV
    https://en.wikipedia.org/wiki/WebDAV
    EAS
    https://en.wikipedia.org/wiki/Exchange_ActiveSync
     
    Crashdamage likes this.

Samsung Galaxy Note 3 Forum

The Samsung Galaxy Note 3 release date was September 2013. Features and Specs include a 5.7" inch screen, 13MP camera, 3GB RAM, Snapdragon 800 processor, and 3200mAh battery.

September 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...