1. Are you ready for the Galaxy S20? Here is everything we know so far!

How Do I turn off Automatic Google Downloading

Discussion in 'Android Lounge' started by startac4, Jun 10, 2021 at 5:34 PM.

  1. startac4

    startac4 Member
    Thread Starter

    I just got a new phone to use for traveling (T-Mobile does not have service in a bunch of places where I go). It's Tracfone Samsung Galaxy J2 which rides on the Verizon network, which does have service most everywhere. In setting up the phone, it would not let me get past the "Accept Google downloading" stuff whenever it wants to. The "advice" it gave is that after something is downloaded I can search for it and delete. That is completely un-acceptable. How do I disable this intrusive google annoyance (yes - I realize that "intrusive", google" "annoyance" are repetitive synonyms)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. puppykickr

    puppykickr Android Expert

    Yeah, Google sucks.

    I just set up two new phones for my ol'lady and I.

    Now I finally figured out the trick.
    When setting up the device, skip the part about adding your Google account.

    Yes, it appears that you can't.
    Keep tapping the center or the back navigation button until you are back to home.

    If you have already added your Google account, then delete it.

    Settings
    Accounts
    Google
    (delete)

    Now go into

    Settings
    Apps
    (show all)
    (show system)

    Find Google, Play Store, Google Services, and other Google crap.

    Enter each one, and select permissions.
    Deny any that you don't like.

    Go back and at the bottom select Advanced.
    Deny permissions to 'Modify System Settings' and the like.

    Yes, this is tedious- but worth it.

    Can you live without the Play Store?
    There are other appstores that are not annoying like Google.

    Most of what Google wants to forcefeed your device will come from there.
    Deny permissions.

    If you deny something that is needed, believe you me, your device won't shut up about it.

    In fact, very few of the permissions are actually needed on a functional device.
     
    ocnbrze likes this.
  3. puppykickr

    puppykickr Android Expert

    After you have set the device up how you want it, go ahead and add your Google account.

    Go to
    Settings
    Accounts
    +

    Open it after you log in, and check the settings.

    If you really want the Play Store, go back to it in the apps settings, and enable it, double checking the permissions.

    Open the Play Store, tap your avatar, and go to settings.
    Disable auto update.

    Check all other settings.
     
    ocnbrze and Dannydet like this.
  4. mikedt

    mikedt 你好

    Samsung Galaxy J2, came out in 2015, running Android 5.11. Your question/rant maybe academic, as that rather old phone is very unlikely to receive any more downloads and updates, as it's no longer supported by Samsung and/or Google.

    But anyway I've never seen this issue for myself, and have only read about it on AF, specifically with devices supplied and customised by US carriers, e.g. Verizon and Tracfone. So AFAIK it's NOT Google been "intrusive" it's the carrier, with the "annoyance".
     
    #5 mikedt, Jun 10, 2021 at 10:57 PM
    Last edited: Jun 10, 2021 at 11:06 PM
    ocnbrze and puppykickr like this.
  5. puppykickr

    puppykickr Android Expert

    It is the carriers, as they provide these phones at an extreme discount.

    They make most of their money back by selling you minutes/airtime, but also make money from these crAPPs provided (force fed) to the device by Google.

    My guess is that Google is also giving the carriers some cash to force these substandard spyware apps onto devices.
     
    ocnbrze, Dannydet and mikedt like this.
  6. Kunalsb11

    Kunalsb11 Lurker

    Google Chrome: Disable Automatic Downloads
    1. In Chrome, select the menu at the upper-right corner of the screen, then choose “Settings“.
    2. Select “Site Settings“.
    3. Expand the “Additional permissions” settings.
    4. Choose “Automatic downloads“.
    5. Toggle the switch to the desired setting.
     
    ocnbrze and Dannydet like this.
  7. startac4

    startac4 Member
    Thread Starter

    Thank you puppykickr for taking the time to post all those details. And thank you mikedt and Kunalsb11 for the information you posted.
    I tried to follow everything you noted but not sure I got everything with "google" in the name. But it was a big help.

    As for this being an old model/cheap phone, that was wanted I wanted. This phone is only for traveling to selected places where T-Mobile doesn't have/won't build towers so I don't need a first class "new model" phone. If this will work for calls and text messages in non-T-Mobile areas - and doesn't spend the day doing auto-downloads - it will meet my needs.
     
    ocnbrze likes this.
  8. startac4

    startac4 Member
    Thread Starter

    Well...something just happened . I don't know what I touched but now I have this google rectangle, with what looks like a mic, in the middle of the home screen, in between two rows of my icons. Any suggestions as to what else I need to do to get rid of yet another google annoyance?
     
  9. startac4

    startac4 Member
    Thread Starter

    This is an experience. So I just tried holding it down and it gave me the option to remove it. Phew!! Don't know how it sneaked in there but it's gone now:)
     
Loading...

Share This Page

Loading...