1. Are you ready for the Galaxy S20? Here is everything we know so far!

How do I un-root???

Discussion in 'Android Devices' started by T.J.B.44, May 26, 2011.

  1. T.J.B.44

    T.J.B.44 Lurker
    Thread Starter

    Just for future reference, can someone explain to me how I can un-root my phone(LG Optimus M). Originally 2.2.1

    Running sense U.I.

    Much thanks in advance for any help.

    1. Download the Forums for Android™ app!


  2. log1c

    log1c Android Enthusiast

    If you used Gingerbreak to root your phone, go back to that app and there should be an option to unroot the phone
  3. T.J.B.44

    T.J.B.44 Lurker
    Thread Starter

    I didn't use a one click root app. I used one of the tutorials on this website.
  4. mikekelso421

    mikekelso421 Android Enthusiast

    You can probobly use the LG update tool. There us an option in there called recover phone. That will probobly unroot it. Possibly.
    T.J.B.44 likes this.
  5. T.J.B.44

    T.J.B.44 Lurker
    Thread Starter

    Lol how possible is it? Don't wanna try it unless i'm sure.
  6. Darnell0216

    Darnell0216 Android Expert

    It'll definitely undo everything software related. Hell I even erased my MEID/pESN with it by accident and had to send it into LG Support (note below).

    Just keep in mind that USB Debugging should NOT be enabled using LG Updater. It may crash with an error crippling your phone. It can still be recovered, but the process will get even longer. Though we do now have a way to restore pESN without warranty service.
    ginji_ban07 likes this.
  7. joneidy

    joneidy Android Enthusiast

    I didnt feel like doing a new thread for this. So I will explain here how to unroot or go back to stock mode.
    First make sure you have LGNPTS installed (Go here and follow the guide until the step where you need to select the .bin file)

    Open LGNPST and make sure that you are under Provision > Upgrade. Then choose the .prl and the .scr files from the guide to their destination just as the above guide says it.
    Then download this FILE, extract it and select it as the .bin file.

    Click START you will need your spc code just look in the guide above to get it.

    Let the process gets to 100% and your phone will be back to stock mode.

    Hope this helps guys :)
    savanna, teh_dude, nomorefear and 3 others like this.
  8. blaxican25

    blaxican25 Android Expert

    nice post joneidy.
  9. T.J.B.44

    T.J.B.44 Lurker
    Thread Starter

    Haven't gotten around to trying it yet. Probably gonna give it a shot today. Thanks for the info everybody.
  10. Odis

    Odis Newbie

    i followed the guide and added the new bin file. it goes to 100% and completes and reboots but gets stuck on the android boot screen. any ideas? i did double check everything. its all installed correctly and inputted correctly..
  11. joneidy

    joneidy Android Enthusiast

    MMM pull battery and press this combination of buttons while phone is off. Press home vol down and home. Until you see a little android. that should fix that problem :)
    Odis likes this.
  12. Odis

    Odis Newbie

    Thank you. It worked like a charm. your the best Joneidy.
  13. hantheman7

    hantheman7 Lurker

    joneidy....THANK YOU SOOO MUCH! I was easily able to root my phone with Gingerbreak but I'm guessing I removed more then I should have because I could not get any updates or apps from the market and continued to get "android.proccess.media" errors no matter what I did. Seems like I tried everything from formatting and swapping out the sdcard to deleting all my apps, etc... but rolling back to the original rom seems to have done the trick... now I'm off to rooting it again :eek:)
  14. Darnell0216

    Darnell0216 Android Expert

    Use the list of safe apps sticky. Sounds like you deleted the Metro Browser. It's required for the phone to function. :)
  15. double1

    double1 Well-Known Member

    LGPSN finds the bin file and lets me attach it but the prl and src files dont show up when i try to add them. They show up as blank white pages when i unzip then to C: so I think they're not transferring correctly. ?

    Never mind. I found it.

Share This Page