1. Download our Official Android App: Forums for Android!

Tips How do set wifi-only (so no cell-tower access is possible)

Discussion in 'Android Devices' started by cookdav, Sep 12, 2014.

  1. cookdav

    cookdav Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    19
    Joined:
    Apr 30, 2011

    Apr 30, 2011
    19
    1
    36
    software-web-engineer (Linux/Android/Windows-7)
    GeekWorld
    Ok, just got the Galaxy S5 today as my 2nd Android device (in addition to my Nexus-7).

    So, once I entered the house for first time, it SAYS I'm connected to wifi.
    (Tho I never gave it my wifi-password...so it proxied that pwd, or something?)

    But, that's not my primary question. I'm trying to figure out how
    to be sure that cell-tower access is disabled, while I'm in range of my home
    wifi, so that it is impossible to incur any data-plan charges (to Verizon).


    How would I do that? :thinking: :smokingsomb:
     

    Advertisement

  2. ANDROIDFAN99

    ANDROIDFAN99 Lurker
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Jul 17, 2012

    Jul 17, 2012
    9
    3
    26
    Atlanta
    Go to settings> data usage> mobile data. Uncheck
    mobile data box
     
  3. AppleCultApost8

    Rank:
    None
    Points:
    16
    Posts:
    14
    Joined:
    Aug 28, 2014

    Aug 28, 2014
    14
    3
    16
    Another way you can do that is just turn on airplane mode in the settings. WiFi still works on airplane mode.
     
    cookdav likes this.
  4. LDrifta

    LDrifta No Stranger 2 Danger
    Rank:
    None
    Points:
    323
    Posts:
    3,907
    Joined:
    Jun 7, 2011

    Jun 7, 2011
    3,907
    3,202
    323
    Male
    Graphic-arts
    Lynn, MA
    wifi does work in airplane mode but yu have to turn it back on :p haha but im curious as to how it auto-connected to your wifi..? do you not have a password set or do you live next to a metro store? lol
     
    BRAINZ2013 likes this.
  5. acraftylady

    acraftylady Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    338
    Joined:
    Mar 18, 2013

    Mar 18, 2013
    338
    26
    43
    It sounds like your wifi at home is not secure. I have to input my wifi password for all my devices to set them up the first time. Mary
     
  6. cookdav

    cookdav Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    19
    Joined:
    Apr 30, 2011

    Apr 30, 2011
    19
    1
    36
    software-web-engineer (Linux/Android/Windows-7)
    GeekWorld
    No, my home wifi-network IS secure. [ Every other device, up til now, has required
    me to enter that pwd on the first wifi-usage. But, I think Google must have 'proxied'
    my wifi's pwd from my other Android-device...the Nexus-7, or something similar. ]

    Ok, sounds right...airplane-mode should be what I want...I'd never thought hard
    enough about what airplane-mode is trying to achieve. Thx!

    But, now that I realize that I'll have to remember to UN-DO airplane mode when I
    leave my house, I'm not sure I'll remember to do that each time I leave.

    So, if I make no changes at all, the behavior is gonna be that it will 'prefer' to use
    wifi, anytime it becomes connected to a working wifi, even when a cell-tower
    connection is also in range and established, right?

    I see a new thread here, explaining that there are (are supposed to be) some
    'arrows' or something, both to indicate when a wifi-connection is established
    and other arrows for the cell-tower (Verizon-connection)?

    Please describe more precisely just WHERE I'm supposed to be seeing these
    arrows. (Yes, maybe 4 hours after I brought home this new Galaxy S5, I
    also saw it apply this new upgrade to 4.4.4 of Android, so maybe I'm
    having this other 'missing arrows' issue described in that other thread, too.)
    :(
     
  7. AZgl1500

    AZgl1500 Extreme Android User
    Rank:
    None
    Points:
    618
    Posts:
    6,396
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,396
    3,141
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    I have posted on this type of thing more than once, and your problem can be solved very easily.

    My method is to use * MacroDroid - Device Automation - Android Apps on Google Play

    and create a macro that will turn off Mobile Data whenever the WiFi is connected.

    It works a treat and it is fully automatic.

    TRIGGER: WiFi State Change
    Select: Connect to Network
    OK
    Choose network of your choice
    OK

    ACTION: Mobile Data On/OFF
    Select: Data OFF
    OK

    touch right arrow on top of display
    ignore Constraints
    touch right arrow again

    enter an appropriate name,
    ie, WiFi on, Data off
    OK

    clear app

    check it out

    enjoy
     
    cookdav likes this.
  8. acraftylady

    acraftylady Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    338
    Joined:
    Mar 18, 2013

    Mar 18, 2013
    338
    26
    43
    I have the data icon showing on my pull down screen so I can just toggle it on and off that way. I leave it off until I need it. When it's on the 2 arrows on the app light up in green and when off they are not green but that blue color. I guess I am not sure exactly what your problem is as when I leave that on off data is completely off. Next to that icon on the pull down screen I have one that says wifi, same thing, lit up green it's on and when I turn it off it's blueish.

    You can have what ever you want on that notification screen. Go to settings, notification panel and drag what ever you want in the active buttons section like the data and wifi one.

    I know someone said they had trouble with both being on at the same time after the Verizon update but I just got the update yesterday and am not having that trouble. Mary
     
    cookdav likes this.
  9. cookdav

    cookdav Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    19
    Joined:
    Apr 30, 2011

    Apr 30, 2011
    19
    1
    36
    software-web-engineer (Linux/Android/Windows-7)
    GeekWorld
    Ah, thx for pointing out how to modify that notification/swipe-down screen's contents. That's going to help me understand this issue better! :)
     
  10. MeatLoafT

    MeatLoafT Member
    Rank:
    None
    Points:
    38
    Posts:
    96
    Joined:
    Feb 11, 2013

    Feb 11, 2013
    96
    18
    38
    Male
    Indiana
    If you have a Google account set to back up your settings and contacts, it also backs up WIFI passwords. So if you had it on your old phone and used the same Google account, your WIFI SSIDs and passwords you've connected to come back on the new phone.
     

Samsung Galaxy S5

The Samsung Galaxy S5 was announced in 2014 and was the company's first flagship of the year. The device featured a 5.1-inch display with a resolution of 1920 x 1080, 2GB of RAM, 16GB of storage, and a 16MP primary rear camera.

Share This Page

Loading...