1. Download our Official Android App: Forums for Android!

General How do you keep wifi turned off?

Discussion in 'Android Devices' started by rcyphermd, Jul 26, 2016.

  1. rcyphermd

    rcyphermd Android Expert
    Thread Starter
    Rank:
     #201
    Points:
    78
    Posts:
    822
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    822
    57
    78
    When I am at work, I need to turn my WiFi off. Everytime I click it off, it turns on again later. I have all the settings in wifi as off. Suggestions? I have a Verizon edge.
     

    Advertisement

  2. RangerPivot

    RangerPivot Member
    Rank:
     #770
    Points:
    16
    Posts:
    55
    Joined:
    Feb 2, 2011

    Feb 2, 2011
    55
    7
    16
    Atlanta, GA
    While I don't have a definitive answer for you... I'll state that this exact thing happened on my Note3, S6, and Note5 when I was with Verizon. I recently switched to T-Mobile, bought an S7 and when I turn wifi off, it stays off.
    Somewhat more interesting is that I have a verizon tablet that I stuck a t-mobile sim in. Wifi would always turn itself back on here as well. When I put the t-mo sim in i got an annoying notification that would not go away stating that this "is not a Verizon sim." The only way to get this to go away is to kill all verizon processes. When I kill these processes wifi stays off.
    So, I suspect that there is a Verizon process that's turning wifi back on.
     
  3. rcyphermd

    rcyphermd Android Expert
    Thread Starter
    Rank:
     #201
    Points:
    78
    Posts:
    822
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    822
    57
    78
    How do I find that process and turn it off?
     
  4. RangerPivot

    RangerPivot Member
    Rank:
     #770
    Points:
    16
    Posts:
    55
    Joined:
    Feb 2, 2011

    Feb 2, 2011
    55
    7
    16
    Atlanta, GA
    The process that seems to be doing it is called "activation agent." It restarts every time I reboot the tablet and again tells me that "SIM card is not from Verizon Wireless."

    One of the permissions on this says, "connect and disconnect from wifi."

    So, every time I reboot this tablet I have to force stop this process and wifi does what I tell it to. Again, I am no longer on Verizon so I feel safe disabling it. I have no idea what force-stopping it while on Verizon will do.

    I'll play around with the tablet some more while leaving this process running. I rebooted and turned off wifi about 10 minutes ago and so far it hasn't restarted itself. I'll post back if I discover anything.
     
  5. Bg260

    Bg260  
    VIP Member
    Rank:
     #32
    Points:
    763
    Posts:
    3,538
    Joined:
    Apr 30, 2016

    Apr 30, 2016
    3,538
    3,664
    763
    Male
    Freelance Entrepreneur
    Lincoln
  6. RangerPivot

    RangerPivot Member
    Rank:
     #770
    Points:
    16
    Posts:
    55
    Joined:
    Feb 2, 2011

    Feb 2, 2011
    55
    7
    16
    Atlanta, GA
    Well, it's definitely "activation agent." Within an hour after rebooting the tablet with this process running wifi turned itself back on. I force-stopped that process and turned off wifi... 12 hours later it's still off.
    This isn't a typical app where you can open it and select options... so I have no idea how to disable it without just killing the process outright. And again, causes no issues killing it but I am now on T-Mobile.
     
  7. Bg260

    Bg260  
    VIP Member
    Rank:
     #32
    Points:
    763
    Posts:
    3,538
    Joined:
    Apr 30, 2016

    Apr 30, 2016
    3,538
    3,664
    763
    Male
    Freelance Entrepreneur
    Lincoln
    Are you using cellular data?
     
  8. Bg260

    Bg260  
    VIP Member
    Rank:
     #32
    Points:
    763
    Posts:
    3,538
    Joined:
    Apr 30, 2016

    Apr 30, 2016
    3,538
    3,664
    763
    Male
    Freelance Entrepreneur
    Lincoln
    Just got a better look. Verizon branded phones do not play well with others. Locked or unlocked. Well known fact.

    Please read this:

    http://m.androidcentral.com/getting-your-phone-sim-unlocked-easy
     
    #8 Bg260, Jul 27, 2016
    Last edited: Jul 27, 2016
  9. RangerPivot

    RangerPivot Member
    Rank:
     #770
    Points:
    16
    Posts:
    55
    Joined:
    Feb 2, 2011

    Feb 2, 2011
    55
    7
    16
    Atlanta, GA
    Well, to expand on my situation. I switched from Verizon to Tmobile. I did buy new phones from Tmobile because I didn't want to have weird things happen that I would always question might be due to having a verizon phone.
    Anyway, I got 4 lines for the price of 2 from Verizon, so I took one of those 4 sims and plugged it into my Verizon tablet. It works absolutely perfectly except for the annoying "This is not a Verizon Sim" notification that I can't clear unless I kill Verizon's "activation agent" process. Killing this process coincidentally stops wifi from auto restarting... which is what the OP was asking about.
     
  10. Bg260

    Bg260  
    VIP Member
    Rank:
     #32
    Points:
    763
    Posts:
    3,538
    Joined:
    Apr 30, 2016

    Apr 30, 2016
    3,538
    3,664
    763
    Male
    Freelance Entrepreneur
    Lincoln
    Sorry, I was briefly confused. But, yes if that with will help the OP that is great. We get a lot of questions here that are directed towards Android and 7 out of 10, maybe are the fault of the Carriers, OEMs or User malfunction;)
     
  11. rcyphermd

    rcyphermd Android Expert
    Thread Starter
    Rank:
     #201
    Points:
    78
    Posts:
    822
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    822
    57
    78
    I still cannot turn my wifi off for more than a few minutes. How can I keep it off if I want? Thanks for your advice
     
  12. rcyphermd

    rcyphermd Android Expert
    Thread Starter
    Rank:
     #201
    Points:
    78
    Posts:
    822
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    822
    57
    78
    doesn't anyone have an idea how to solve this, or does everyone just let their wifi on all the time?
     
  13. mikedt

    mikedt 你好
    Rank:
     #7
    Points:
    2,238
    Posts:
    24,193
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,193
    13,300
    2,238
    Teachaaa
    Jinan, China
    Don't use a Verizon version Samsung? Which is what this thread is about. Although if that's your carrier and you're on a contract, you may not have much choice. Myself, I've never had to deal with anything like this, I turn WiFi off, it stays off. No Verizon here of course. Although I do leave WiFi on most of the time, and it seems to have no effect on battery life with the Oppo.
     
    #13 mikedt, Oct 20, 2016
    Last edited: Oct 20, 2016
  14. TrueFangz

    TrueFangz Well-Known Member
    Rank:
     #135
    Points:
    148
    Posts:
    226
    Joined:
    Oct 21, 2013

    Oct 21, 2013
    226
    168
    148
    Male
    USA
    I generally leave WiFi on all the time, when at home and/or work. The only times I turn it off is if I'm away all day and don't want to worry about connecting to public WiFi networks. Anyhow, each time I've turned the WiFi off from the notification bar pull down menu, it's stayed off until I've manually turned it back on.
    This has been true to all my Samsung phones (Note 3, 4, 5, 7 and now S7 edge) on Verizon.

    So I'm starting to wonder if you might have a 3rd party app installed that is set to toggle WiFi. Have you tried booting in Safe mode? Try that, and toggle WiFi on and off manually and see if the setting sticks.
     
  15. rcyphermd

    rcyphermd Android Expert
    Thread Starter
    Rank:
     #201
    Points:
    78
    Posts:
    822
    Joined:
    Oct 14, 2009

    Oct 14, 2009
    822
    57
    78
    Thank you . How do I boot in safe mode ? How would I tell if an app in guilty ? I appreciate your help!
     
  16. TrueFangz

    TrueFangz Well-Known Member
    Rank:
     #135
    Points:
    148
    Posts:
    226
    Joined:
    Oct 21, 2013

    Oct 21, 2013
    226
    168
    148
    Male
    USA
    No problem.

    This should go the trick


    1. Turn the device off.
    2. Press and hold the Power key past the Samsung Galaxy S7 edge screen.
    3. When "SAMSUNG" appears on the screen, release the Power key.
    4. Immediately after releasing the Power key, press and hold the Volume down key.
    5. Continue to hold the Volume down key until the device finishes restarting.
    6. Safe mode will display in the bottom left corner of the screen.
    7. Release the Volume down key when you see Safe Mode.
    Turn off safe mode
    1. Press and hold the Power key.
    2. Tap Restart.
    If this works, and your WiFi stays on and off when you toggle, then we can blame a 3rd party app. If that's the case turn off safe mode and boot normally, then the best thing to do will probably be analyze your apps yourself. Think about which apps you've installed, and what they do. Any apps like custom tools, schedulers, even social media apps or games could be the culprit. Go to your app manager, and select the app you may be suspicious of, then click permissions, and see if it says anything about Auto waking WiFi (or something similar to that effect)

    You could then temporarily uninstall 1 app at a time to see if that was the winner. (if you uninstall more than 1 at a time, you won't know which one it actually was.)

    Hope this all helps, and works!
     

Samsung Galaxy S7

The Samsung Galaxy S7 was launched in 2016 and was one of two devices in the lineup. The device features a 5.1-inch display with a resolution of 2560 x 1440, 4GB of RAM, 32GB of storage, and a 12MP rear camera.

Share This Page

Loading...