1. Are you ready for the Galaxy S20? Here is everything we know so far!

How I rooted B&N 1.4.1 and got the Android Market to work

Discussion in 'Android Devices' started by bobstro, Dec 24, 2011.

  1. bobstro

    bobstro Well-Known Member
    Thread Starter

    Note: This works for B&N 1.4.2. Just substitute the B&N 1.4.2 references for 1.4.2 below. I'll update this guide when I have time.

    First of all, I want to emphasize that I did none of the original work required for this effort to succeed. I only seem to follow instructions carefully, and know just enough to figure out what instructions to ignore. I'm posting this here because I'm hoping others will benefit from skipping a few of the painful steps I went through to get this working.

    GMPOWER recently posted an updated procedure over at XDA that should be considered the authoritative source for information pertaining to the latest versions of ManualNooter. I'm keeping this thread active because of the numerous enhancements beyond basic rooting that can be important.


    This guide is for anybody wanting to root the stock Barnes and Noble 1.4.1 firmware. Is it worth it? Probably not. With all the options available today, reverting to B&N makes sense if, and only if, if you want to use any of the following B&N capabilities:
    • Read to me (mostly children's book)
    • Enhanced content (e.g. Conde Nast magazines such as Wired, New Yorker, though some of these are becoming available via 3rd party sources.)
    • Newpaper or magazine subscriptions (auto-update)
    • B&N Free in-store reading
    • Support from friends with stock Nooks or B&N (conditional upon being rooted)
    • The B&N reader experience and shell. The B&N Android Nook app is not the same thing as their firmware experience, at least not yet. Someday, they may update the B&N Nook Android app, but it is pretty poor right now. If you want to read B&N stuff, then 1.4.1 is a big deal.
    If these apply, consider keeping your NC at B&N 1.4.1. If you want 3rd party content (e.g. Kindle), then root it, but make sure you've got it configured NOT to auto-update, since B&N has killed sideloading with OTA updates.

    If you will not be using B&N content, then go with Cyanogenmod or similar. The B&N firmware suffers a lot of shortcomings compared to the "full tablet" experience:
    • Lots of settings are missing.
    • Getting a 3rd party keyboard to work is possible, but very kludgy at present. I had luck with SwiftKey by copying the apk from /data/app to /system/app as directed in NookColor Tools.
    If you're looking to install CyanogenMod or other firmware, check out Koopakid08's A Noobs Guide to Getting Started with a Custom Rom on the Nook Color.

    I started out reading and trying the procedure described the XDA thread on rooting 1.2 and 1.3:

    [NC][1.2][1.3] ManualNooter 4.6.16 - xda-developers

    However, it is critical to realize that the directions early on in that thread do not work for 1.4.1. For B&N 1.4.1, GMPOWER has posted an updated procedure:

    [[NC][1.4.1][1.4.2] ManualNooter 5.02.19

    • If you need a bootable ClockworkMod SD card running or later, complete Step 1.
    • If you've overwritten the B&N firmware on internal eMMC memory (e.g. CyanogenMod), continue at Step 2.
    • If you're running a version of B&N firmware prior to 1.4.1, continue at Step 3.
    • If you are running unrooted B&N firmware 1.4.1, continue at Step 5.

    1. Create bootable CWM SD. You need to create a ClockworkMod (CWM) bootable SD card to reset your device back to standard B&N firmware, and to install the "manualnooter" root kit. Colchiro has posted a nice summary here on Androidforums. His guide includes the latest ( CWM versions.
    2. Restore to stock B&N ROM. I'd been running CM7.1 on emmc, so had to go through the process of restoring to a stock B&N 1.3 ROM. Depending on the age of the article you read on how to do this, you may have problems either formatting /data or get into a boot loop at the 'n' logo. You need a current CWM to be able to successfully format /data. If /data is not properly formatted, you will get a bootloop at the B&N splash screen when you restart. Not a big deal to fix, but you can waste a lot of time on this. As of this writing, CWM is the latest, and should allow you to format partitions without problems.
    3. Register B&N firmware with B&N. After restoring to B&N 1.3, I re-registered my device to make sure B&N functionality would work. After all, the only reason to bother with 1.4.1 is if you intend to use B&N content. Otherwise, save yourself the trouble. NOTE: We are not root yet.
    4. Update B&N firmware to 1.4.1. Update to 1.4.1. I got my copy of 1.4.1 directly from B&N [EDIT 01162012: I have verified that the latest as of this date still works as described here.] Your Nook Color will also update to the latest if you just let 1.3 unrooted go to sleep if you don't have ClockWorkMod installed to eMMC. I have confirmed that this procedure works with the following nookcolor_1_4_1_update.zip md5sum: 2a27f54b65431a096af4f07967bcd6b5 (post-Christmas 2011)
    5. Root using ManualNooter. With 1.4.1 running unrooted, download manualnooter-5.02.19.apps2sd.zip from GMPOWER's latest thread at XDA. (Note: I suggest the apps2sd version. See GMPOWER's notes.)
    6. Copy manualnooter-5.02.19.apps2sd.zip (or whatever the latest is) to your bootable SD recovery card (created in Step 1).
    7. Boot the recovery SD card.
    8. Install manualnooter-5.02.19.apps2sd.zip.
    9. Remove the recovery SD card and reboot your NC. It boots any card present, so this is kinda important. Behold the pretty startup screens. You should have root at this point.
    10. Be sure to select Zeam as your initial launcher. Note that if you press the 'n' key at this point, you'll be taken back to the B&N interface, and not have ready access to anything non-standard. This is not a big deal. Simply press 'n'->Search and enter zeam in the search box. It should locate zeam. Select it to launch.
    11. To enable 3rd party apps to load, you must open the NookColor Tools program. There's a magic check box that enables 3rd party apps at the top. By default, the text is white on white, so impossible to see. Select that box twice - to uncheck then recheck (toggle) it. When you are done, it should be checked.
    12. To get 3rd party apps to show up in the Nook interface, download Nook Color App Manager from the Market. HINT: Don't go overboard and select everything. Select only those things you really want to see in the B&N Walled Garden. You might also want to select the HomeCatcher app (included in ManualNooter) to allow using the 'n' button to go to your launcher of choice, but I do not. My philosophy is to keep the B&N interface as much as possible, or I wouldn't have gone to all this effort. When I need "power user" functions, I just launch zeam using the search procedure listed above.
    13. Disable OTA updates. B&N auto over-the-air (OTA) updates apparently break root, and lately, sideloading. There seems to be some debate about what works best for this, but I've gone for modifying the devicemanager.db using SQLite Editor to open devicemanager.db and change registry->com.bn.device.fota.mode from "auto" to "manual". You can use an alternate method with a free sqlite3 binary from the command line. So far, no nasty OTA surprises.


    Here are some common problems and what to do about them:
    • Can't overclock. GMPOWER has indicated that an overclocked kernel is not provided with manualnooter. You need to install Dalingrin's overclocked kernel for B&N 1.3 (NOTE: Dalingrin's hosting site for these files seems to be offline. Doncarauana has posted a set of temporary links to the kernel files you can try. You will also need a copy of Dalingrin's Nook Color Tweaks installed to access the overclocking and voltage settings.
    • Can't format /data when restoring to stock firmware. You probably followed an old guide on how to do this. Depending on the age of your NC, the version of CWM you're using may not handle partition changes. You need to update CWM. See Step 1, above.
    • Bootloop at the 'n' logo when trying to restore B&N firmware.You probably goofed. Hard as it is to believe, it's very easy to miss the fact that /data wasn't formatted. This is the same problem as the preceding problem. Just follow Step 1, above, and be sure /data actually gets formatted.
    • 1.4.1 is rooted, but unable to install anything from Android Market or Amazon App Store. When this happens, everything appears to be working, but after downloading, apps will fail to install. They key is to use GMPOWER's latest manualnooter and do not every, even once, install one of the older 4.x.x versions. Refer to Steps 4 and 10, above. I had to restart from scratch to make up for not paying attention and running the old manualnooter versions. Something to do with a database patch that causes problems.
    • Facebook and other apps are missing from Android Market. UPDATE: This is fixed with GMPOWER's manualnooter-5.01.24.zip or later. (For other apps: A simple workaround is to install the app onto another Android device, then use Android Assistant to make a backup .apk and copy that to the Nook Color. If you only have a Nook Color Android device, you can create a bootable SD with CyanogenMod (see above) and install to that, then use this procedure to copy the .apk over.)
    • Can't reset Market or other app data. You will quickly notice that the B&N firmware does not provide a lot of the common Android settings you're probably used to. One of these is the Manage Apps settings. One work-around for this is to use AnyCut to create shortcuts to some of the missing settings. Open AnyCut->New shortcut->Activity->Development. (Be patient. It can take a LONG time to populate the list.) This will create a Development on your Android (not B&N) launcher home screen. From there you can select Manage applications as well as some other missing functions. Another method is to launch NookColor Tools (installed by manualnooter).

      WARNING: Be careful experimenting with AnyCut and NookColor Tools. You may find that there are 3 (or more) "Settings" options. The 2nd one will wipe your device. DO NOT USE IT. Trust me. It will even zap your SD card. I think this is a remote wipe function that gets triggered. Be careful!

    3/5/2012: Updated to note 1.4.2.
    2/19/2012: Updated to include GMPOWER's latest manualnooter-5.02.19.apps2sd.zip.2/15/2012: Added info on using AnyCut to restore some missing settings, added warning about 2nd Settings (trigger auto-wipe) option.
    2/14/2012: Updated to add link to manual procedure for blocking OTA updates using sqlite3.
    2/13/2012: Updated to include link to GMPOWER's thread on his ManualNooter for NC 1.4.1.
    2/6/2012: Updated links for Dalingrin's overclocked kernel to include Doncarauna's temporary links.
    1/24/2012: Updated to reference GMPOWER's manualnooter-5.01.24, restored references to Dalingrin's OC'ed 1.3 kernel.
    1/22/2012: Updated to reference GMPOWER's manualnooter-5.01.21, remove references to APPS2SD not working. It's working now! Removed overclock kernel as a concern. GMPOWER's latest MN includes it. Added link to Colchiro's SD HOWTO at Androidforums.
    1/16/2012: Updated description of 1.4.1 update now that I've verified this procedure works with the latest, and added link to SQlite OTA blocking procedure.
    1/11/2012: Updated link to GMPOWER's ManualNooter update to be more concise.

    1. Download the Forums for Android™ app!


  2. NLCA

    NLCA Lurker

    Hello! This is my first NC and also my first time rooting. I've been reading forums for hours and I'm confused on something you wrote. It seems like it's something basic. I'm not understanding somethings and have some questions before I start.

    "I've gone for modifying the devicemanager.db using SQLite Editor to open devicemanager.db and change registry->com.bn.device.fota.mode from "auto" to "manual". So far, no nasty OTA surprises."

    What is deviceemanager.db and how can I get it?

    Do I download SQLite Editor after I get devicemanager.db?

    Thank you
  3. jaykap

    jaykap Member

    after following ur guide, i managed to get everything up and running fine. no problems so far.
  4. bobstro

    bobstro Well-Known Member
    Thread Starter

    That is the database you edit using SQLite or equivalent. Change the field registry->com.bn.device.fota.mode to "manual".
  5. rsfaze

    rsfaze Lurker

    would these root steps work on 1.4.2 ?
  6. bobstro

    bobstro Well-Known Member
    Thread Starter

    I believe that is the version that broke sideloading. I've only seen success with 1.4.1, sadly. You can roll back, however. I'd be curious to know if a factory reset puts you at 1.4.1 or 1.4.2. That might save you some work.
  7. matt0106

    matt0106 Newbie

    I followed this almost exactly. I just had to look up how to make a CWM bootable SD card. You should put a link to one. But thank you very much for this.
  8. matt0106

    matt0106 Newbie

    According to B&N's website 1.4.1 is the most recent. But yes it works on 1.4.1.
  9. bobstro

    bobstro Well-Known Member
    Thread Starter

    I found the information here. However, it looks like Colchiro has posted a more comprehensive summary on these very forums here. I've created an 8 GB "rescue" SD card and load anything I need for rooting, restoring or enhancing onto it.
  10. bobstro

    bobstro Well-Known Member
    Thread Starter

    I downloaded the latest as of a few days ago, and ran an MD5 checksum on it and compared to the version I'd downloaded before Christmas. They are not the same. I'm not sure if "1.4.1" on the web site really breaks anything or not. I haven't felt like trying it out myself. :)
  11. matt0106

    matt0106 Newbie

    Could I use the default Android text editor?

    By changing "com.bn.device.fota.modefota operation modefotaauto" to "com.bn.device.fota.modefota operation modefotamanual?"
  12. matt0106

    matt0106 Newbie

    That's how I updated mine before I "rooted" it and it works. Everything works fine, so far. I haven't found anything that doesn't work yet.
  13. bobstro

    bobstro Well-Known Member
    Thread Starter

    So you downloaded 1.4.1 from B&N recently, and you're not having problems? The tests:

    1. Can you install apk from SD?
    2. Can you download apps from Android Market?
    3. Can you download B&N content?

    If so, that's good news. Looks like "the latest" is still OK. I've been reading about a "recent OTA update" that's broken things for folks, but since I've blocked OTA updates, I haven't seen this myself.
  14. matt0106

    matt0106 Newbie

    1. yes I can
    2. yes and they work
    3. I haven't tried but I'll get back to you on that asap
  15. matt0106

    matt0106 Newbie

    Last night when I rooted my nook, I powered my nook off and on a few times. After like the third boot, it would turn on, but then it would sit on the nook color rainbow letters screen. I think I got a boot loop.
  16. colchiro

    colchiro Extreme Android User

    That's why we create backups in recovery so you have something to restore.

    You could try booting off your bootable sdcard (you do still have it?) and format cache (mounts) and delete Dalvik cache and fix permissions (advanced menu). Your next boot will take longer (about 5 minutes).

    Meanwhile I'd plug it in to charge and let it run for awhile. (Hope you have some battery left.) I have seen it pull out of it after 30 minutes.

    It will not charge while boot-looping, not sure about charging in recovery.

    Worst case you could format data in recovery, which means you lose all settings and apps (market will restore paid apps) OR return to stock 1.3 (removing cwm), update and re-root.
  17. matt0106

    matt0106 Newbie

    I did a factory restore and it restored it to 1.3.0 then I updated back to 1.4.1 and re rooted it. Can I have manual nooter and my backup on the same SD card?
  18. colchiro

    colchiro Extreme Android User

    You are limited only by space on the card. If you backup from the card, it'll tell you if it's full with an error.

    Do you have a different sdcard you use with stock rom? You can backup to that from Rom Manager, provided you don't boot off a sdcard (dual boot).
  19. matt0106

    matt0106 Newbie

    Does doing a system restore fix everything?

    I have a 2gb sd card so is that enough for the back up and manual nooter zip? I tried having the other card and when I tried to restore it said something about m5 sums not matching. How do you do dual boot?
  20. colchiro

    colchiro Extreme Android User

    Dual boot is where you have CM7 (or other rom) installed on your sdcard and B&N stock rom (usually unrooted), but could be any rom, installed on your NC. At startup, you get a menu that let's you choose which one to boot up. Sounds cool, but sdcards are hard to setup, slower than roms on emmc and always fail at some point.

    Each CM7 backup is about 1 gb so doubt you could put two on a 2 gb card, but one should be no problem.

    md5 error means the backup is damaged or you renamed it with illegal characters in it (like spaces).
  21. matt0106

    matt0106 Newbie

    Well I just did the manual nooter unzip thing in CWM and used that, what exactly did that do though?
  22. colchiro

    colchiro Extreme Android User

    Manual nooter lets you install other apps like Android Market and other apps that let you tweak the stock rom.

    Sorry, forgot to answer your other question.... restoring a backup from recovery gets you back to exactly the way you were when it was backed up, (except any changes you made to the sdcard).
  23. matt0106

    matt0106 Newbie

    No, I meant like holding power and n at the same time, would that fix it?

    And ok, well that's really all I wanted, I don't want a different OS. But is running manualnooter still rooting it?
  24. Sorry but i'm new to rooting..
    I first started off at v1.4.1 then followed steps 4 - 10.
    I installed MN 5.12.20 (which is the latest) and when i rebooted it took forever to get past the Nook Color rainbow screen.
    I went into Nook Color Tools and the check box was already checked.
    Then i went into the market and signed in.
    I tried downloading Nook Color App Manager, but the installation just paused then canceled itself.
    Help would be greatly appreciated!
  25. matt0106

    matt0106 Newbie

    Go into nook color settings and just tap the checked box once to uncheck it then tap again to check. I don't know if that actually does anything but I did it and I haven't had any problems.
Similar Threads - rooted B&N got
  1. Marvin P Droid
  2. Yesi Trotamundos
  3. enby_dashie
  4. Yesi Trotamundos
  5. Yesi Trotamundos
  6. Yesi Trotamundos
  7. asiopat9
  8. kumaranil13k
  9. CrunchyShadow
  10. kumaranil13k

Share This Page