1. Are you ready for the Galaxy S20? Here is everything we know so far!

How much it takes to launch a simple "hello world"

Discussion in 'Android Development' started by robothito, Feb 4, 2016.

  1. robothito

    robothito Newbie
    Thread Starter

    Hello.
    I would appreciate some help.

    After having all kinds of problems day before yesterday I started from 0.
    I created another "first application" with the classic "hello world".
    First it got all kinds of "rendering problems" but I pushed the refresh little button in the design window and got the "hello world message"
    So I tried to run it (with a new device I made)
    and NO ERRORS... it seems to be going fine
    the message says "device connected emulator 5554"
    The emulator phone appears with the huge "ANDROID" message
    after a minute the main screen of the phone appears...

    and that is it...

    "Hello World" never appears... How long does it take to launch this simple "hello world" app??
    Is it ever going to launch??
    Do I need to do anything?

    Well, I have work tomorrow so I am going to let the mac running all night to see if it finally appears but seriously how much does it take??

    Thanks for any help, I really appreciate it
     



    1. Download the Forums for Android™ app!


      Download

       
  2. AZgl1500

    AZgl1500 Extreme Android User

    um, 1st I think it would be a good idea to let us know what you are doing?

    Writing a program in 'C', 'Basic', '6502 machine code?', "WordPress?" ??

    I know the result you mentioned, and the 1st time I did that, I had to punch holes in a piece of cardboard and feed that into a Card Reader, and then the Teletype Machine went clunk clunk and printed out a jumbled mess on a piece of paper tape....
     
  3. robothito

    robothito Newbie
    Thread Starter

    I am sorry... isnt this an Android Forum?? :eek:

    I am running Android Studio and I am doing nothing on my own. I am just trying to run the project that Android Studio builds by default. Which should take seconds after all it is not my code or anything I did. I am just trying to run the thing that the builders of android put there .
     
  4. AZgl1500

    AZgl1500 Extreme Android User

    You never once mentioned "Android Studio", so just how in the hell are we supposed to know that? PLUS you still have NOT told us what device you have in your hands that you are trying to use that app on???

    Garbage In = Garbage Out

    now that you have, I will back out, I have never seen that app.... and if you had said so in the first place, I never would have poked my nose in here in the 1st place...

    You got to remember, none of us are PAID to help you, nor are we "Mind Readers"....
    We just try to read what you tell us... and then from that, we try to diagnose what you are doing, versus what you get for a result.
     
  5. scary alien

    scary alien not really so scary
    VIP Member

    Welcome to our AndroidForums, @robothito :).

    Let me move your thread over to our Application Development area where our dev folks often hang-out.

    Hang on...:)
     
    codesplice likes this.
  6. scary alien

    scary alien not really so scary
    VIP Member

    Okay...all moved! :)

    I don't really use the Android Studio (I'm still hanging on to Eclipse ;)) and I never use a virtual device to test with--I always use a real target device, principally because the emulator via Eclipse used to be soooooo slooooowwwwww.

    Anyway, hopefully someone else (our esteemed @LV426 perhaps?) might chime-in with some ideas for you.

    Cheers and best of luck!
     
    robothito and codesplice like this.
  7. Deleted User

    Deleted User Guest

    The emulator will take a fair amount of time to start up, but really it shouldn't take all night to launch your app. Once you got past the Android boot up stage, your app should have been started. Btw, once the emulator's started, check that your app has been installed. Can you see it in the installed apps screen, like on a real phone?

    It might have crashed, first thing to check is the Logcat output window in Android Studio. Do you see any runtime errors or exceptions?

    And as @scary alien says, consider using a real device to test with. It's so much quicker than waiting for the emulator.

    Android sample apps should work out of the box. But if your app didn't even show up on the emulator, and there was no "application crashed" dialog, I suspect you might have some build problems. Check the Gradle console - are there any errors? If you have UI layout issues it would cause problems. But Android Studio is usually pretty good at flagging up build errors and making you aware that something's not right.
     
    robothito and scary alien like this.
  8. ac4android

    ac4android Well-Known Member

    Click on File -> New and enter following info:
    Application name: MyHelloWorld
    Company Domain: robothito.com -> Next
    Then, check Phone and Tablet, in drop down box, I generally select a Minimum SDK of API17 -> Blank Activity -> Next ( for now accept the defaults ) -> Finish

    On action bar, click on Run -> Run 'App'
    On the "Device Chooser" screen, click on the ... button, it will take you to a screen for creating an AVD
    Click on "+ Create Virtual Device" (the button at lower left hand corner)
    Select Nexus 4 (for now) and follow instructions to create your virtual android phone
    Go back to Device Chooser screen and from its dropdown list for Android virtual device, select the AVD you have just created.
    Make sure the Launch emulator button is on

    On my laptop, it takes about 2-3 minutes for the AVD to pop up.

    Hope that helps
     
  9. HeavensSentSword

    HeavensSentSword Well-Known Member

    I would try to reinstall the whole thing. You may have some corrupt files in you build or accidentally deleted something useful.
    Are you working off of a tutorial? If the tutorial is old then it wont work as well as you would think because some of them that are floating around for new users are too old and don't support Android studio that well.
     
    scary alien likes this.
  10. robothito

    robothito Newbie
    Thread Starter

    I discover that it was a silly thing

    When I try run the application the AVD starts and that is it. The application is not installed.(my situation before)
    You have to push the run button again, and then the application is finally installed.

    Thank you very much guys for the help,. it is very much appreciated.
    I have now another problem , (I wrote another thread for that) and I would appreciate some help there please.

    (Basically the problem is: when I run the app on a nexus S it runs but when I try to do it on a nexus 5 or 9 there are some problems with not enough memory... )

    Thanks again!
     
    HeavensSentSword likes this.
Loading...

Share This Page

Loading...